QNAP server core - Turn off Firewall [resolved with correct Firewall rule]

The only way I could get ARC to work was to turn off the QNAP firewall. I tried port exceptions in the firewall but didn’t get anywhere. So if anyone has the problem of unable to connect properly this may be a temporary fix until someone can figure out how to configure the QNAP firewall.

My advice is to turn the Firewall back on immediately. Your QNAP is now vunerable to hackers and ransomware.


I would strongly suggest that you keep your firewall on, especially with the mess that QNAP are in with all the hacks/malware!

@Christopher_Kelly2 - I have a HS-264 and did not have to change anything on the QNAP.

Thanks, but that was the only way I could do it. I have a static IP from my ISP, which is obviously different from the internal IP that is used by the core. So, I really don’t know how to configure it so it works, but OK I’ll turn it back on. Mine is the TS-453D

@Christopher_Kelly2 - I also have static IP from my ISP. What I use looks like this:


Try use (Localhost) instead. It did help me :slight_smile:

I am NOT an expert - but maybe it can fix your problem.


Hi Torben. Thank you. I tried this, but still does not work. For me it’s definitely the QNAP firewall for me. I appreciate your help on this though. Chris.

1 Like

what are you using as the source in the qufirewall rule?

I’m running roon on an Ubuntu VM in virtualisation station rather than the qpkg app though.

Mine works ok with this rule:

Hi. I’m not using VM ware, just normal qpkg firewall app. The error I’m getting is below, xxx blanked out as that’s my external IP address:

“connectivity”: {“status”:“NetworkError”,“status_code”:504,“error”:“error: Error: ETIMEDOUT, response code: undefined, body: undefined connected? undefined”},
“external_ip”: {“actual_external_ip”:“xxxxxxx”,“router_external_ip”:“xxxxxx”},
“natpmp_autoconfig”: {“status”:“NotFound”},**
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

The natpmp autoconfig…not found.
I dunno, I’m really not up to speed with all this firewall stuff, lol.

do the port forwarding manually, think the nat pmp or upnp in arc is not very reliable

(nat pmp and upnp are just two different ways of doing the same thing)

I tried this manually

No joy…if that’s done correctly that is. As I say I’m really not good on that sort of thing.

Blanked out my external ip address.

the source won’t be your external IP address, change that to “any”


Boom! It works. Thanks Chris. Changing to “any” worked a treat. You are a star my friend! Thank you so much.

1 Like

FYI the source is the device running the roon arc app so that could be an iphone or ipad etc.

If you are nervous about security you can also change the source from “any” to the specific country you will be using the app in (will block those pesky hackers in China, Russia and Holland)

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.