QNAP TS 670pro, Roon does not see my music on disk

everything worked flawlessly before the update

This is the Database location not your stored music files.

You need to add the folder here not just point it to your QNAP. I take it you’ve tried adding a folder where your music files are located?

I’m trying to add a folder with music, but ROON does not see any folders on the hard disk, but only sees the disk itself

Снимок экрана 2021-11-04 в 20.28.21

maybe I don’t have the correct ROON version for my qnap

Have you enabled Multimedia Console on your QNAP?

I don’t understand where to do this before the update everything worked fine

Sorry but I didn’t realise you already had Roon installed previously. When performing an update on a previously installed version of Roon there should have been no need to specify folders etc as they would have already been set. I’m a bit confused as to what you had tried to do? According to Chris the developer of the App this version should work for older installed versions of QNAP firmware but I cant say for definite.

Processing: RoonServer_2021-10-03_x86_64.qpkg…I have this version from the post about qnap ts 870 installed on qnap, maybe it does not fit my 670 pro, maybe you can advise me the version for my qnap

This is the latest version and is required to run Roon 1.8 (Build 846). Which version of Roon do you have installed?

I installed a new version of roon 1.8 on imac, manually installed roon for qnap, launched roon on imac, the program detected the kernel and offered to connect to it, then I entered the email and password and asked me to indicate where the music is located, everything only sees the hard drive, but does not see the folder![Снимок экрана 2021-11-04 в 20.54.23|690x388](upload://k0![Снимок экрана 2021-11-04 в 20.54.32|690x388](upload://9d


zfGkC3iKNRbSuaX2bgWhlOL0E.jpeg)
UW0pxX0os5rwIvyerfY1BnBBL.jpeg)


As BlackJack stated earlier it would be worthwhile reading here:-

Sounds like a few people have issues. I updated the qpkg to version 2021-10-03 before attempting to update the Roon App to version 1.8 (Build 846) on a QNAP TS-873A and everything worked perfectly.

Hope you get it sorted, sorry I couldn’t help.

no, nothing helps, kshcht does not see the folder on the hard drive, can you advise where to go for help?

I would post on this thread as Roon have set this up for any issues: -

I posted on here just now just to say that I upgraded without issue. Best to keep it all in the one place.

Have you tried using the “Add network share” at the bottom of your second screen shot? It seems doing this manually may solve your issue.

the problem is solved, it turns out that it was necessary to manually register the path to the smb folder so that roon will see it and start scanning

Good to hear

There seems to be a bug, which is currently investigated. Local files should actually not need to be mounted over smb.
See:
https://community.roonlabs.com/t/roon-server-stopped-after-update-qnap

This might be a workaround, but I’d recommend to change it back to local files, once the issue is resolved.