Qobuz - Media Loading Slowly for Hi-Res

Roon Core Machine

Win 11
I5-9600K
32GB
1TB NVME
500GB NVME
1TB SSD

Networking Gear & Setup Details

Gigabit Ethernet
968 Mbps download
997 Mbps upload

Connected Audio Devices

Chord Electronics Qutest
USB

Number of Tracks in Library

23,363 Tracks

Description of Issue

I am hardwired over ethernet with fiber internet and while streaming I can still pull roughly 1000 Mbps both ways. If I stream above 24/96 or more specifically, if I stream 24/192 (I can still pull ~930 Mbps) play back will start to stutter and then stop. Usually within one track, definitely within two tracks. This only occurs streaming with Qobuz and not my local Hi-Res of DSD.

I have already tried restarting Roon, my network devices and cleaning my library.
Does this feature just not work or is there something else I can try?

Qobuz api streams seem highly susceptible to dns resolution issues also some providers seem to have problems with them at certain times. Only recently I could not get it to work via any app not just Roon where it had worked flawlessly for years.

If you can change dns servers on your router try setting it to either Google’s DNS server 8.8.8.8 or Cloudflare 1.1.1.1 and see if it helps.

Thanks. I will give that a try later tonight and see if it resolves it.

I tried changing to a different DNS and that didn’t help. Looking at my system resources I’m only ever using around 8mb/s for Roon streaming. It also turns out this happens with any music over 24/48.

If you have VPN, try VPN to another state or country, then restart Roon. See if this makes a difference.

Thank you. I don’t use any VPN’s though. Out of curiosity I disabled Roon’s built in MQA Core Decoder to test. I immediately noticed that starting new tracks and pausing and resuming current tracks now occurs at the same speed as my local files. I think (hope) I may be on to something here.

I’m going to test this to see if it makes any improvements.

Update: No luck. I have tried everything that has been suggested and I have not been able to have Qobuz not stutter and then stop playback of Hi-Res music. I filled out the prerequisite information so if someone from Roon support would respond to my thread I’d appreciate it.

More updates: I have done the following:

  • Changed to Google DNS & Cloudflare DNS
  • Enabled multicast routing
  • Enabled jumbo frames
  • Disabled IPV6
  • Tried USB 3.0 gen 1 & 2 ports and USB 2.0 Ports
  • Changed USB cables
  • Uninstalled and reinstalled ROON
  • Tried WASAPI and ASIO drivers
  • Tried a different DAC
  • Disabled XMP
  • Disabled my CPU overclock
  • Monitored my system resources while the issue occurs
  • Updated all Ethernet/Wi-Fi drivers

I feel confident in saying the issue is not on my end. ROON support has yet to chime in. I’m sure they have many things to do. Having done my due diligence though, I would appreciate assistance or at the very least an acknowledgement of the issue.

My system resources never showed signs of change when the error occurred (over 65% RAM free, CPU under 10%, network usage averaging 7Mbps down).

The only semi work around is capping Qobuz to 96 where performance is less hindered. IMO the issue is either ROON itself (the problem acts like a memory leak/ is definitely a matter of insufficient cache for the Hi-Res 192 files being streamed) or Qobuz itself. My guess is ROON itself since when playback starts if I immediately pause the track and resume playback just before ROON releases my DAC it will stream 192 without issue. I can also stream the same files without issue as soon as ROON is removed from the playback process.

1 Like

Most of what you tried are worthwhile. You may also disable Energy Efficient Ethernet in Windows network adapter advanced properties, although this is very unlikely to be the problem in your case.

Turn it off as it tends to cause problems.

Several other things you may try:

  1. In router, disable firewall, Netgear Armor (if using Netgear), QoS, bandwidth management, and all sorts of advanced features.

  2. To further confirm your network is not causing the problem, please try Roon DSP Engine to upsample everything to 384kHz PCM (or DSD256) and play from your local music files instead of Qobuz.

  3. Download Qobuz app for Windows and try it for 192kHz albums.

  4. Get a VPN trial and VPN to other states or countries. Then restart Roon.

2 Likes

Thanks, I am going through this list trying things now. A fair amount of my previous troubleshooting I reversed if it showed no signs of improvement. I have all of the “network nannies” off except the firewall so I’m starting my troubleshooting with that step and moving through the list.

Thanks for the recommendations.

Hey @David_Robinson,

Ben with the support team here - so sorry for the delay in getting to your thread!

You’ve done an excellent job troubleshooting so far, I’m really sorry to hear you’re still running into this issue! I was able to pull a fresh diagnostic report from your core, and see a few interesting things.

The first, which I don’t believe to be related, but odd nonetheless, is a system exception error tied to Lastfm happening right around the time of playback. If possible, could you test out disabling lastfm and see if that oddly has something to do with this?

Another oddity I’m seeing is a poor connection warning, which based on your OP shouldn’t be occurring:

Warn: FTMSI-B-OE qo/31C1DB35: poor connection kbps:5455.0 (min:5566.0)

As a small next step (my apologies if you’ve already done this) can you please test out running playback only from the system output of the windows core, maybe to a pair of headphones, and see if the same issue occurs?

I’ll be taking your issue to our development team for further investigation. Let me know if any of the above helps in the meantime!

Thanks, David! :pray:

1 Like

Thank you for your reply. Please see the below bullet points for a quick up to speed:

  • I have resolved the Last FM error (signed in, then disconnected, no improvement so I signed back in)
  • Disabled my firewall and re-enabled (no improvement, while disabled so I re-enabled it)
  • I can and have been able to play any of my local 192k FLAC files and DSD 64 -128 files without any issue but also upsampled to DSD 256 in Roon with no issues for local file playback as a test
  • Windows OS playback of all media has been flawless without a hitch
  • Trying to playback the same 192k tracks in the native Qobuz app for Windows has yielded the same error in playback

I think this has to do with the data error you listed. I have no doubt this is a throughput issue but I’m not sure on the “why”. Previously I couldn’t get Qobuz to replicate the issue I am having in ROON but today (albeit after many network tweaks to try to fix playback in ROON) it resulted in the same pop’s and click’s as the stream broke up that ROON has been having. Again, this was also with 192k songs.

Is there anything I can look at network wise or is this likely just a Qobuz issue? I haven’t found any recommended network configuration settings from Qobuz that are applicable to me (ports, settings, etc.).

Thanks for the help, I’m all out of ideas

Describe your network infrastructure - brand/model of modem, router, WiFi access points, network switches powerline network adapters, etc. and how everything are connected together.

Run Qobuz app on iPad (over WiFi to your router) to retest 192kHz, while you have a direct line of sight from the iPad to the router antenna with no obstacles.

If you happen to have a proper cable, connect the iPad to the USB DAC.

If you have a lightning port on the iPad, the proper cable is the authentic Apple Lightning to USB 3 camera adapter.

1 Like
  • For this I am using my iPad mini 6 on 5ghz within 3ft (~1m) of my router (ASUS RT-AX82U): USB C to A adapter → USB 2.0 Certified Cable → Chord Qutest

I have Fiber from my ISP and there is no modem. Below is how my usual setup is configured.

  • ISP wall outlet (not powerline) → CAT 5 → ASUS RT-AX82U → CAT 5 → ROON Core → USB 2.0 certified cable → Chord Qutest → to preamp/amp/etc.

There is another fork at my router (using a seperate ethernet port out, back into the wall jack over CAT 5 or 6, I’m unsure)

  • CAT 5 (from wall with physical outlet (not powerline) → ASUS RP-AC1900 (Mesh Node) → CAT 5 → Apple TV & Sengled Home Hub (from separate ports on RP-AC1900, all over CAT 5)

When I tested the iPad as the source it still stuttered on 192k and then failed and skipped to the next song in the queue. Speed Test for it returned 387Mbps down and 287Mbps up.

Thanks and let me know if you have any suggestions.

Make sure IPv6 is disabled.

  1. In the Asus router, change DNS to 8.8.8.8, reboot the iPad or PC and retest

  2. In the Asus router, change DNS to 1.1.1.1, reboot the iPad or PC and retest

If none of the DNS solves the problem, and now that you’ve proven your wired internal network is not faulty, the only remaining cause is the download speed from Qobuz CDN.

Finally, you would have to:

  1. I assume you have an iPhone, repeat the test failure with iPhone and then switch it to 4G instead of WiFi. If 4G works but WiFi does not, it proves your Qobuz CDN is not operating well with your ISP.
  2. Try a VPN.
  3. Temporarily lend your Qobuz account (with a temporary password) to someone you trust in your region who has an iPad but with a different ISP to test it for you. I assume the problem is reproducible even if the iPad is not connected to a USB DAC.
2 Likes

This sounds the same issue I was having had it on all zones wired and wireless and only with Qobuz and it was at any res at bad times. In my case it was only at sparodic times not contstantly I could go all day then it would have a few 10 minute spates over a hour. It was sometimes during the day but it mainly at night but not any fixed time.

I eventually found It also affected every other device that played Qobuz and only Qobuz. My internal network was sound. Could stream 4k on multiple devices locally and from internet , move data around freely and fast, no background tasks or backups running on network at times it happened. Had full internet bandwith and little latency. Monitored my BB connection for a week and nothing showed up. Did network speed and connection tests to and from all Roon stuff, nothing suspect.

Roon could play back any local file up to DSD. Radio Paradise would stream no issues lossless, during these times though Qobuz would have fits for about 10 mins then resume.

I tried absolutely everything when it was happening and nothing stopped it. Even went back to basic network and still the same. Then it just stopped doing it, it was an issue for about a month to six weeks. I have not had it happen again. I am using Qobuz less than I was and playing more of the music I own but I have used Qobuz and not had any issues now. When it was prominent in even Mrs Gipsy commented on it as she experienced it when listening. I have not changed anything so I think this is a localised issue likely with their CDN and your/mine ISP none of which is in our control. I do think they have a less than stellar backbone. You can see lots of other issues with native streaming in devices if you Google especially on WAM forum.

1 Like

Thanks. That’s about where I’m at as far as just having to write it off as a Qobuz issue. I can’t see what else it could be. Nothing else on my network has any issues, just like you wrote and I have went through everything.

I appreciate the input on your experience. I give up lol. There’s nothing else to be done about it but at least I have pinned down it’s not something on my end that is mis-configured.

Thanks to everyone for chipping in to try to help me sort it, truly.

David

Also until that point I had had trouble free Qobuz in Roon or other apps for years. Same network in place, same core. It just started and that was that.

Who is your ISP? Mine is Virgin Media in the UK.

Hey @David_Robinson,

As a next step, could you please reproduce the issue once again and share the specific date and time as well as the name of track that is playing when the issue occurs? From there our team can truly investigate everything that’s happening at the time of the issue (at least on Roons end!)

I also wanted to say a big thank you to @wklie for the excellent troubleshooting questions here as well. This is certainly an odd issue, and a difficult one to pin down!

I’ll be monitoring this thread for your reply. :+1:

I’m in the US with a local ISP in Tennessee called EPB.