Qobuz media loading slowly, issue

No idea what’s going on but I use my Macbook Air as my core and I am streaming wirelessly to an ifi zen stream, and when I’m using roon I can’t play any songs for more than a few seconds and then I get the “Qobuz media loading slowly…” message and it stops.

I can open up Qobuz app on my laptop and stream with NO issues at all. An internet speed test came back 110 Mbps download, 10 mpbs upload.

I have rebooted the computer, modem, roon, have logged out of qobuz and logged back in thru roon, nothing is helping.

Any ideas or tips?

Unfortunately you just can’t compare the wifi performance of the native Qobuz app with Roon.
Roon is a LOT more demanding and bandwidth intensive.
I would wager if you can get the ZS onto a wired connection you will have an end to your problems.


It’s been working this way for a few years now, haven’t made any changes, and if 110 Mbps is not enough for Roon then that’s insanity.


I have higher than that and WiFi to endpoints is touch and go here so…
Quite likely something has changed in your local vicinity that’s now hurting your WiFi signal, that’s one of its drawbacks along with not being duplex.


If that is the case then it’s time for me to quit roon.

If I can stream from the Qobuz app or from the browser with zero issues, then why deal with issues that roon has with 100+ mbps speeds. That’s just stupid.

As @AceRimmer tried to explain speed isn’t the likely factor here.
It’s more likely to be wifi interference that didn’t exist before or due to duplex - in this case wifi, for sake of simple explanation, being like a one way street.
Traffic only goes one way at a time. Ethernet is a two way street.
This is why Roon recommends at least the Core be connected via ethernet.


Internet speed (throughput) is not relevant if the issue is with your local wifi having too much latency


Speed of internet per se is really only part of what can make or break WiFi performance.
Latency and other traffic all count too.
And as I have already said the very lightweight Qobuz native app is relatively easy to stream WiFi wise.


I know you know, but adding for @Aaron_Underwood:

Maybe most importantly, when streaming with the Qobuz app it downloads compressed FLAC. From the Roon Core to the endpoint it’s already decoded, so that’s 40% more traffic right there, which can easily push a marginal wifi speed over the edge. Plus Roon’s multiroom synchronicity requires much smaller buffers, so fluctuating wifi speed hits it harder.


Another possibility/question springs to mind here.
Is this occuring on Redbook CD 16/44 quality or just hires streams?


It’s happening with all streams thru roon, no matter what the quality.

This just started today, again, hasn’t been a problem in the past with the exact same setup.

Again, are you sure that your wifi quality did not change, including what your neighbors are running or other influences? Did you check your wifi channel congestion (a good wifi router will show you this, else there are apps)

I could not stream wifi to my phone with Roon when I was out on the terrace. Then I got a new phone and it worked. Such is wifi.

Another question, is this only when streaming Qobuz or also with local files in Roon?

So, I can stream 4k video all wireless BUT Roon can’t handle music the same way?

I think there is another issue here. If not then Roon is incredibly inefficient.

@Suedkiez nothing that I know of changed. I am looking at my router “orbi” app (I have two zones to cover the house) and nothing in the way of congestion is going on, nothing out of the ordinary.

I don’t have any local files used for roon.

Again, the requirements are different. How much buffer does the TV have (does it have to run several screens in sync over the network? I guess not). Plus video codecs are adaptive and drop bandwidth when needed, music codecs don’t and Roon RAAT neither.

The Roon recommendations are clear: Wifi on endpoints is OK if it works, but if it does not, you know where to start looking.

Avoid connecting high resolution/high performance audio devices to Roon via WiFi to ensure optimal performance.

This and wifi recommendations in:

1 Like

I do appreciate everyone’s input, I just don’t get why I never had issues in the past.

The bolded part is the problem. It is difficult to know for sure with wifi :slight_smile:

You could download an album for a few euros from Qobuz, load it into Roon, and try if that works or not. This would help narrowing down the problem zone

Or as was mentioned, if you can try running a cheap Ethernet cable from Core to endpoint temporarily, also to confirm or rule out the wifi. (Or maybe move the endpoint for testing)

1 Like

It’s also possible Qobuz is having a bad day.
This can vary by geographical region so it may be fine for some and not for others.
I have occasionally had Qobuz and Tidal load slowly for a short period of time and then later be fine.

You could also try setting your DNS to use Cloudflare if you’re not already.
Longshot but :woman_shrugging:



I have two identical streamers in my house. One is wired, the other is wireless, 5 ft from an Orbi mesh node. I also use Qobuz.

The wired endpoint always works. Once in awhile the wireless one has trouble loading from Qobuz.

I’d see if the problem goes away if you run an Ethernet cable to your streamer, even if just for a test.

my streamer is on wired ethernet and the core is on wireless - I too see these issues sometimes