Qobuz playback hanging on linux core

I am having the same issue of Qobuz hanging with a Linux core on Synology. When I reboot my core machine, Qobuz works again for a while through Roon (a day or two), then stops streaming. As others noted , Qobuz streaming is 100% functional outside of Roon.

I have signed out of Qobuz, cleared the Roon cache, etc.

When I try to play a Qobuz track in Roon and it hangs, my CPU usage goes up to 20%, nearly all of which is consumed by the process Broker:Media. This seems consistent with the notion that the root issue has to do with Roon losing credentials with Qobuz somewhere along the way (which is why clearing the cache seems to have been suggested).

I suspect @support is generally aware of the issue, but hopefully the note above about the specific process is helpful.

I tried streaming Qobuz a few times around 15:45 PST, and the stream would not start. I then successfully played local content.

However, the Broker:Media service was not gobbling up 20% CPU like it was last night (several times in a row). I did see the process active today, but only at ~1% CPU.


Additional information in case it helps:

When Qobuz streaming locks up with Roon, stopping and restarting the RoonServer process tree generally does not resolve the issue. However, a full reboot of the server does so reliably. After a full reboot of the Linux machine hosting RoonServer, Qobuz continues working for 1-2 days before failing in Roon (…still soldiers on without issue in the Qobuz app on the same network).

Hmmm…worked last night, but not today. ¯\(ツ)

I’ll try rebooting the core again.

Hey Jim, I think you’re experiencing something different than what was described in the other thread, so I split out your posts. The last time I enabled diagnostics the report never made it to our servers so I’m going to give it one more try. I’m about to head out for the weekend though so I’ll have another look on Monday, hang tight!

Thanks. After the reboot, Qobuz is working again. Based on prior experience, it will probably be up for a day or two. I can come back and post at time that it fails. It’s possible I broke the log reporting by rebooting to play music again?

Happy weekend.

Hey Jim, I’m seeing all sorts of network errors in your logs. Can you describe your networking setup in more detail? Specifically, what kind of router/switches are you using and how are all of your devices connected (wifi/ethernet)?

Thanks for following up. Qobuz streaming failed again yesterday afternoon (about 5pm PST). I rebooted the Synology Core, which restored glitch-free playback for the rest of the evening.

Here is the path to the core (all wired):

Comcast → Netgear CM1200 modem → Linksys Velop MX5300 (WiFi-6) parent node (3 nodes total in a 2500 sq ft house)–> Synology DS1515+ (Roon Core)

And the zones:

The primary RAAT zone is an RPi3 running RoPieee with a TP Link AC600 wifi dongle. There is another Velop node in the same room as the RPi3, so the WiFi signal should be very strong.

I have another RAAT zone (RPi2 on RoPieee) connected by ethernet to the core via an 8-port Linksys switch.

I have found that when the RPi3 zone fails to play Qobuz, the ethernet-connected RPi2 zone also fails to play. There are very rarely dropouts when streaming local content from the NAS. When Qobuz play fails through Roon, it always works through the Qobuz app on my iPad (streaming to the same RPi3 over AirPlay).

At 5:30 PST today, I tried to play a Qobuz album to both my RPi3 endpoint (WiFi), RPi2 (ethernet) and also to my MacBook (WiFi). All failed. I then successfully started a local copy of the same album to the RPi3 (WiFi) from the NAS.

Set Synology DNS to and disable IPv6, then reboot the Synology.


Thanks for the suggestion. I have just done this, and Qobuz through Roon has been restored for now.

Typically, rebooting the Synology has re-enabled Qobuz to work again for a few days. I’ll see if it sticks longer with your suggested network settings. Thanks again.

After a week, this still seems to be working. Thanks for the helpful advice.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.