Qobuz sample rate limit resets to default after Core reboot

Roon Core Machine

HP Spectre 360 running Roon Server on Windows 10

Networking Gear & Setup Details

Connected Audio Devices

Number of Tracks in Library

Description of Issue

I have stop/starts sometimes when playing Qobuz tracks above 96 kHz. It’s not a problem between the router and Roon endpoints because I downsample to 48kHz when streaming to Chromecast devices and to 96kHz for other endpoints.

My problem is maintaining “Settings/Services/Qobuz/Streaming Quality” at “24 Bit up to 96kHz”. That works fine as long as I don’t quit Roon Server, sign out from Windows or reboot the computer. When Roon Server restarts it goes back to the default of “24 Bit up to 192 kHz”. This can happen without my intervention with Windows Update.

Shouldn’t maximum sample rates set for Qobuz and TIDAL “stick” when Roon Server restarts?

Is this what you are seeing under settings: services: Qobuz: streaming plan?

If so that is dictated I believe by the service plan itself, not Roon.

I think you can change it while Roon Core is active to test it but it will default back to service plan on a new restart.

You should be able to limit the streaming under settings: audio: device setup for each device individually and that should stay intact after any restart.

I do limit the sample rate for my endpoint devices. That downsampling is displayed when I look at the signal path when playing a track.

The problem is before that at that top of the signal path (“Source”). That is determined by “Setting/Services/Qobuz/Streaming Quality”. Some Qobuz albums are only available at 192 kHz (for example, Beethoven Symphony No. 9 by Pittsburgh Symphony Orchestra released in 2021). I have playback problems if sample rates over 96 kHz aren’t reduced prior to any other conversion in the signal path.

It simply makes no sense to me that the Qobuz setting for streaming quality resets whenever Roon Server restarts.

But if you set the limits for your endpoints I don’t see the problem?
Or am I missing something??
Yes it might START out at 192 from Qobuz but if you set endpoint to 96 max, Roon should downsample that 192 to 96 which you should see in the signal path.

Yes, you are missing something. If the source is 192 kHz AND I downsample the endpoint to 48 kHz I still have a problem with tracks stopping and starting. If the top line in the signal path (“Source”) is at 96 kHz because of my Qobuz setting I have no problem. But that setting for Qobuz doesn’t stick and I don’t find that out until I have a playback problem.

Got it.
Then it sounds like it’s a case that your internet connection cannot handle the 192 sampling rate delivered by Qobuz.

Only answer I have ATM is if you restart then you need to change that max rate in settings.

Unless someone knows different or you can increase/ improve your internet connection to handle 192 native.

My internet service is 50 mbps, which should be enough. It’s probably network issues beyond my control causing the problem. Or it could be how Roon fetches from Qobuz.

Why have a setting for maximum sample rate for Qobuz if it resets every time Roon Server restarts? That doesn’t happen for any of the other settings. For me, it’s a useful setting. It should be fixed.

Personally I don’t say as I disagree with you but maybe that needs to be a feature request?

I just tested it and it does the same for myself.

It looks like a bug it should be set and forget.
@support from roon 1.7 this was supposed to be a permanent setting

Agree. It should not be reverting with a server reboot

So, is anyone from Roon watching this? Will the bug be fixed?

In the “Services” settings, you can choose the maximum stream for Qobuz.
To avoid some bugs in my system in high resolution, I limit the stream to 96Khz maximum.
This choice jumps regularly… almost at every reboot.
When it lags, I check. 192Khz !
The setting has jumped ! :face_with_raised_eyebrow:

(Roon server on Win10 LTSC).

This is a sort of known issue, there are other threads on this subject already.
I have moved it to an existing thread to keep all in one place for now.

Roon Core Machine

Debian 11 Docker Container

Networking Gear & Setup Details

Core connected to Ethernet. Firewalla Gold router.

Connected Audio Devices


Number of Tracks in Library

5000 tracks

Description of Issue

Since the 880 update the streaming quality setting for Qobuz keeps switching back to 24/192 from 16/44. I’ve mostly noticed it after the core is restarted. The highest setting causes issues for a couple of my Chromecast endpoints where they will start stuttering or drop out completely.

I think this was also noted by another member and is possibly a bug.

Happening to me too. Not a big deal, but I have to remember to change it back if I restart the core.

Hello All,

Thank you for the reports here, we have an active ticket regarding this behavior and it is in our development queue. As per policy, we cannot comment on a timeline of when the issue will be fixed, but we are aware of this and working on it. Thanks!

1 Like

Same bug on my side, even if my Roon core doesn’t reboot. You set a max streaming quality, click “OK”, and when you come back on this, it is on maximum Qobuz quality. Very annoying.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.