Qobuz through Roon skipping and stopping


(Tapatrick) #1

@support
Since setting up a trial Qobuz account through Roon and upgrading to Roon version 1.6 I have been having lots of intermittent stoppages, v-e-r-y slow starts to playing a track or album and lots of stoppages. Tidal selections are okay but even tidal is still slow to start - up to 1 minute before starting. Previous to 1.6 when I hit play it was pretty much instant. How do I go back to version 1.5?

I have been using tidal/roon for a couple of years with no problems and nothing else changed in my system. I have high bandwidth Virgin fibre internet and stream HD video no problem.

I’m on the verge of cancelling Qobuz.

My system is: Virgin router to a Aqvox 8 port network switch to NUC7 roonserver with 16gb Ram to a NUC7 Roon endpoint with 4gb Ram to a PS Audio Directstream Junior Dac.


(Noris) #3

Hi @Patrick_Bryson,

Thanks for contacting us and sorry to hear about your frustrations here. Can you please let me know the following:

  • Does this issue occur for just the Directream DAC or does it occur on other zones as well? If you have no other zones please try “System Output” as a test.
  • How are your DNS servers configured on the router? We have seen users have a better streaming experience in the past if they change their DNS servers from the ISP provided ones to Google DNS or Cloudflare DNS. Can you please give this a try and let me know if it helps?
  • Have you tried reinstalling the OS yet? I would make a Backup of your Roon database and then try to reinstall the ROCK OS via the WebUI.

Please let me know if any of my above suggestions help here.

Thanks,
Noris


(Tapatrick) #4

Thank you Noris I will check this out and try today


(Tapatrick) #5

@support
It’s taken me a while to find time to look into this. The same problems have been recurring though.

I swopped to another music server for roonserver with straight usb out to my DAC and the same issues. Incredibly slow starting when pressing play. I have used this server for years with Roon before version 1.6 with instant play back.

I cannot change the DNS servers as I have a virgin router which won’t allow this. I had the DNS settings already on the server pointing to the google ones.

Can you show me how to change back to version 1.5? Thanks as it can take up to 1-2 minutes for music to start especially with Qobuz which I am cancelling as it is too erratic with Roon.


(Noris) #6

Hello @Patrick_Bryson,

Thank you for providing that information. Downgrading Roon versions is not supported and this is because it can cause even further stability issues and databases are not backwards compatible.

With that said, I’m sure that we can narrow down the issue even further here. Can you please try to temporarily connect your NUC directly to the Virgin router to bypass the Aqvox switch? Even connecting this temporarily will give us a good data point to have.

Also, if you have not done so yet, I would try rebooting the Core, your endpoints and all of you networking gear to ensure that they are in a fresh state. Please let me know if that helps.

Thanks,
Noris


(Tapatrick) #7

Thanks Noris
Yes I have the second music server connected to the router directly with only usb out to DAC. And everything has been rebooted (many times)

This is not a small difference between v 1.6 and previous. I have not had anything like this through versions 1.2 to 1.5 over the last few years. Playback now is a Russian roulette of delays and reconnections and lags.


(Noris) #8

Hello @Patrick_Bryson,

Thanks for confirming that for me. I don’t think you ever specified this, but can you let me know what operating system you have running on the NUC?

Just to separate this issue further and to try to identify the root cause, would you by any chance have another PC around the house that you can use to temporarily host the Roon Core on and verify if the same issue occurs on it when making use of the same connections?

Switching Roon Cores is a fairly easy process and will give us some insight as to weather this issue could be caused by the current Core, the network or other factors and will be a good test to perform. Please let me know if this is possible.

Thanks,
Noris


(Tapatrick) #9

Thanks for your help Noris

See earlier post - I have already swopped to another music server, from the NUC running Audiolinux to an Antipodes Dxe running Antipodes OS. This means I have tried another roon core and still have same issues. Once play starts it can go smoothly for a while but will stop eventually.


(Noris) #10

Hi @Patrick_Bryson,

Thanks for trying another core. Can I please ask you to reproduce this issue and let me know the exact local time (e.g. 4:48PM) that this next occurs at? I’d like to enable diagnostics mode for your account to see if we can gather some more information that way. Once I have the timestamp, I can go ahead and enable this feature.

Thanks,
Noris


(Tapatrick) #11

I will hopefully be able to do this in the next few days…


(Tapatrick) #12

Seems more stable over past few days but haven’t been using it much. Only an hour or so during past few evenings. A good sign tho’ ! :sunglasses:


(Noris) #13

Hi @Patrick_Bryson,

Glad to hear it has been more stable in the past few days! If the issue re-occurs please note the exact local time it occurs at as outline in my last message.

Thanks,
Noris


(Tapatrick) #14

I will have more time at the weekend to see but something seems different and I know I haven’t changed any thing on my end.

I did read on other threads /forums of Qobuz and Tidal problems.


(Tapatrick) #15

At 18.54 yesterday/friday I had a problem. Wasn’t too long but similar to recent issues.


(Tapatrick) #16

@noris
… also 12.53 today/sunday, music stops with a delay in restarting.


(Tapatrick) #17

@noris
also stops after album 14.10, takes a minute to start playing again


(Tapatrick) #18

@noris
14.19 also stops again…
comes back itself at 14.21


(Tapatrick) #19

@noris
15.41 after a break of not listening I press play button again on the bottom bar nothing happens, I keep trying. The play button does not change to the pause button. Can’t get it to start.

Then I go to the queue, select the track and use ‘play from here’ option - it starts to seek the track and takes about 30 secs. This is a Qobuz track.


(Tapatrick) #20

since then…played for several hours without any problems…


(Noris) #21

Hello @Patrick_Bryson,

Thank you for listing those timestamps. I have taken a look at the received diagnostics package and as far as I can tell this is a networking issue somewhere along the line. I am seeing multiple issues here:

  1. You are receiving “sleeping in read” messages in your diagnostics. This means that the streaming media is not reaching the endpoint in time

  2. Your buffers from Qobuz are not being filled in time. This could indicate some network instability here. When this issue is occurring, are other devices on your network responding as expected? Are you able to successfully load web pages off of a PC connected to the same network?

  3. Your Roon Remotes are spontaneously disconnecting and re-connecting to the Core. This also indicates that the connection to the Core is not stable.

Here are the possible areas to check on:

  • You mentioned that this issue occurs even when you have a second music server connected directly to the router with the switch out of the mix.

  • This leads me to believe that your router is either having hardware issues or your ISP is having issues upstream.

  • I would check to see if your entire network goes down when this issue occurs. You can do this by running a continuous ping test to google from a PC or from a mobile device. Instructions on how to run this from a PC can be locate here.

  • Similarly, you can use a ping test to ping your Core from another PC and see if it still responds as expected. You can use similar instructions to the article I linked, except for putting in Google’s IP address you’ll want to put in the IP address of the Core. The Core IP address can be found on one of your Roon Remotes in Roon Settings -> General. It should be listed as 192.168.X.XYZ or similar and you can run the ping test in command prompt using ping -t 192.168.X.XYZ where X,Y,Z are the actual IP values.

Running these tests will give you some more information on where exactly the issue lies, since they will be happening outside of Roon. Once we can figure out if it’s the router going down or the network connection going down, then you can have some next steps here, e.g. replace the router or talk to the ISP to fix their connection. I do recall that you initially mentioned that HD video streaming works as expected but this does not give us enough evidence of stability since audio streaming requires better internet stability.

I look forward to hearing your thoughts on my above feedback.

Thanks,
Noris