Qobuz/TIDAL Skipping

The current Mac build (running on the same i7 Mac Mini I use as Roon server) is consistently skipping on both local and Qobuz tracks, not to mention the incessant scanning of my server (which has always been grotesquely inefficient, particularly compared to the same operation on JRiver MC.) FWIW, when Roon is running, the Qobuz dedicated app also skips constantly. Quit Roon and the Qobuz app plays tracks completely skip free. Looks like Roon needs to perform a little more system profiling to reduce system load and to make its network footprint more efficient. This situation is new to the current build and makes my Roon installation unusable. :cry: I was sorely embarrassed when I had a friend over this week to demonstrate how great Roon was and I had to turn it off because nothing would play without skipping every few seconds. (By the way, running Roon on a 1TB SSD, too.)

Hi @Bob_Lindstrom,

I have split your post into it’s own thread so we can better assist. For future reference, please post any new issues in it’s own support threads and not in existing threads.

Where exactly are you outputting the content to? Is to a DAC or to the Mac Mini’s speakers? Does “System Output” display the same behavior?

Are you using any other Apps on this Mac Mini which uses considerable amount of resources? Apps such as Photoshop/Illustrator/apps with a high CPU/GPU usage?

A post was split to a new topic: Qobuz Skipping on Mac Mini

Thanks, Noris!! I’ve been working on this myself. Here’s the answers to your questions (although I’ve partially “debugged” the issue to some extent.)

I’m using a late 2012 Mac Mini running only Roon core and client and dedicated to that purpose. No other apps running at the same time, although I sometimes run JRiver on this system but never along with Roon. Storage medium is a 1TB SSD. Mac is connected to an SMSL DAC via USB, and then to my Marantz prepro via RCA.

The steps I’ve taken since posting is to keep my Synology server on 24/7 (I previously was auto-shutting it off at midnight and then manually turning it on again when I need to use it because it functions only as a media server.) As a result of this, my Roon DB update doesn’t occur as soon as I turn on Roon, which I believe has remedied possible bandwidth conflict with Roon playback. (by the way, I’m always the only user accessing the Synology, so no bandwidth problem there…)

The Roon core is connected to the network via MoCA 2.5 adaptors (at both ends) to a gigabit switch, and then to the Mac Mini via ethernet cable. Previously, I connected via a wireless router used as an access point (though still hardwired to the Mac.) I swapped out the router for the switch to avoid any possible bottleneck there. (Although that connection still worked seamlessly with JRiver–even during JRiver DB scanning–and with Qobuz.)

I haven’t done a proper network throughput test, but the standard Speedtest.net indicates an online throughput of 170 Mbps which is the maximum of my Internet service. I’m thinking that should be sufficient to support Roon scanning and simultaneous audio playback.

These various changes have resulted in near perfect playback. However, I still get some glitches when playing music and browsing Roon which seem to be related to reads of the SSD-based DB. Hence, my continued thinking that some profiling of this process might be useful. However, it could also be something in my Mac config causing the conflict. If you have suggestions, I welcome them. (I’m primarily a Windows user.)

Thanks for your interest and for your help. I’m a Roon lifetime owner and enthusiast willing to do whatever is useful to contribute to the “common knowledge.” :slight_smile: (As a former PC- and Mac-based game developer I’m well aware of the development nightmare/challenge that multiple computer/networking configurations represent.)

Happy New Year!

Hi @Bob_Lindstrom,

Glad to hear that the changes you made have helped! Is any other app causing the SSD to have a heavy load when this issue occurs? Have you checked the SSD with a diskcheck yet?

So that you are aware, we have a Networking Best Practices Guide which provides some excellent suggestions regarding network setup. I can’t comment on the MoCA adapters since I have not usesd them, but we have had good reports of Mesh-style networks work great with Roon, such as Orbi and Eero.

If the Core does not meet our Minimum Requirements, this could also be a cause of the behavior you’re describing.

Hi Noris, thanks for checking in again!!!

The only things running on my Mac Mini Roon Core computer is the Roon client (other than any system apps that Apple shoves up our CPU…)

I did a diskcheck on the SSD a few days ago and it checked out fine. Damn, like you, I thought I might find something there. No luck.

I had already checked the network guide and did enable multicast routing on my ASUS router. I also verified the throughput on my MoCA adapters. No problems there, either. Plus, the i7-based Mac Mini easily surpasses the minimum reqs for a Roon core. :slight_smile:

With your help, my troubleshooting efforts have reduced playback glitches, but they still occur (albeit with much less frequency) and my professional instincts tell me that it’s some kind of conflict between Roon core scanning/access and the Roon client.

I can report, however, a behavior this week that I hadn’t previously seen. During a core scan of my Synology server, while streaming audio to the Mac Mini from this same server, the system would interrupt playback and “Nothing Playing” would appear in the bottom-screen activity bar. After a pause of several seconds, I estimate 10-20, the read-out would once again show what I was currently playing with the playback cursor in the position it was in prior to the error. I could click the Play icon and resume playback from that interrupted location. Go figure. My instinct (again with the “instinct,” right? :wink: ) was that this was caused when an interim write was being made to the SSD because the spinning Scan icon would stop animating–but that’s just my guess.



Hi Bob,

Thanks for checking the SSD.

That sounds like fairly strange behavior. Have you by any chance tried reinstalling Roon yet? Might be worth a check to see if a fresh database presents the same behavior, you can set your old database aside by doing the following:

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Restart/Reinstall the Roon App to generate a new Roon folder
  • Verify behavior on a fresh database for a few days
  • Restore old database from backup in step 1

Thanks. Will do.

1 Like

Hi Noris!
Significant progress. We’re pretty much “there” at this point. Thanks!!!

OK, I rebuilt the database as you suggested. In so doing, accidentally discovered something I did that apparently caused part of the problem. I initially configured the folders to scan individually. That is, I have separate folders for Classical, Jazz, Pop, etc. and I entered them individually in the setup. When Roon initiated a scan, it would scan all of the folders at once which, I suspect, was fairly inefficient. When I built the new database, I configured only the Music folder that contained all those subfolders. As I observed when rebuilding the DB, Roon launched only a single scan “thread” so the rebuild process went much faster (overnight rather than a day and a half or more for the initial “multithreaded” DB build.)

As a result, I conclude that the scan now takes less bandwidth and, therefore, the playback interruptions have been dramatically minimized. I still have them but they are brief and infrequent (but, to my eyes, clearly related to SSD or Qobuz-online access). Further, I still occasionally have that “Nothing Playing” interruption, but I’ll keep hammering on that because I think it has something to do with the Mac Mini’s ethernet connection.

So, let’s call this one closed. If I come across anything else, I’ll start another thread.

Thanks so much for your input. Appreciate it!!!


1 Like

Hi @Bob_Lindstrom,

Happy to hear about the improvements! I’m going to go ahead and mark this thread to close are you requested, but if you have further questions do let us know. Take care!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.