Qobuz tracks Still not playing

Core Machine (Operating system/System info/Roon build number)

Dedicated desktop pc
Win10 i5-9500t, 16GB ram, 256Gb hdd

Roon server 1.7 (build 571)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

wired ethernet to Xfinity router

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

USB to Topping D30

Description Of Issue


I have latest ver Roon server with 4 endpoints on a dedicated win10 pc and network. Qobuz tracks and albums will not play any longer. I can log in and view Qobuz splash page, but not play music from the service.

Every track from Qobuz will stall . Sometimes they may play after 5-10 minutes.

It plays fine in the Qobuz desktop app and also in a browser on same pc.

It seems there are a number of other users with the same issue recently. It would be great to have a resolution.

Things I have tried:
restart Roon server
rebuild database
restart router
use different router


1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.