Qobuz will not play or is deadly slow to start playing

Core Machine (Operating system/System info/Roon build number)

Wyred 4 Sound MS1 Music Server i7 4.2 GHz 7th gen, 16 GB DDR4 Ram with 2TB SSD running as the core. Using 11 inch iPad Pro running 13.3.1 as the remote. Using Roon version 1.7 Build 528 stable. Database size 6.0G.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Roon Core is connected via ethernet from a netgear 8 port switch to an AT&T cable modem. AT&T fiber internet service 1000.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

NAD Master Series M12, connected via coaxial interconnect from the MS1 Roon Core Server.

Description Of Issue

I just re-subscribed to Qobuz and logged into it via the Roon app. It takes forever to load the album selections, artwork is sometimes even longer. It takes a long time after I make each selection to get to finding an album I want to play. Then it will either not play at all when I Hit play now, or it takes forever and a day to load and start playing. Sometimes I get an error message that the content won’t load. When or if it does eventually start playing it will randomly stop mid-album and not start again. I don’t recall this ever being a problem in the past.

Yes. I have rebooted the cable modem, iPad, switch, MS1 and restarted Roon Server a couple of times but it is still having issues.
Running Qobuz directly from the iPad to the usb input on the M12 via the isn’t media dongle works fine.

DNS servers can be an issue with this kind of symptom…what are the network settings on the core machine? are you having the public DNS servers like or in your IP address DHCP service? or if fixed address add one of them.

Hi @Andrew_Chattaway,

Does the same issue occur if you play to System Output of a remote device instead of the NAD?

Thanks for getting back to me. That was an interesting question that I hadn’t tested so I compared playing through the MS1 to playing through a Naim Mu-so 2 in my office. Initially playing through the Mu-so was faster and more responsive. So I started looking at the audio settings on the MS1 and reset them to default.

Once I did this I tried switching back and forth between both players. The MS1 was more responsive initially, however playback through both slows or stops when jumping between different tracks. I wondered if the bit rate of the original file may be making a difference but no, it was the same performance.
I get the occasional error message about error loading the page, and please check the network connection but I know that is working fine.
I have also tried my iPhone as the remote and this makes no difference. Tracks stored on my MS1 server HD or Live Radio play almost immediately through either player.

I have been having exactly the same issue for the past couple of weeks. I’ve tried rebooting and restarting everything connected to my setup. I cleared the cache and restarted Roon server probably half a dozen times but no effect. Occasionally Qobuz will play but most of the time it just sits there looking like a track has loaded and nothing. I also raised a ticket in it but no solution yet.

Hi @Andrew_Chattaway,

Did you have a chance to try @wizardofoz’s suggestion above? In the past we’ve seen Google DNS and Cloudflare DNS help with streaming service performance and is definitely worth giving a shot.

I’m not sure I know how to change the DNS settings in my setup. When I look at the Roon core settings on my browser there is a regular IP address. I will read the links you sent and see what I can do.

I have been doing a bit of research online. I don’t understand everything I am reading but here is the scoop. I have ATT fiber going through an ATT BGW210 modem/router. It would seem by reading a few forums that ATT do not allow you change the DNS settings on this Unit. I did read something about using a private VPN but I don’t know how to set that up.

Hi @Andrew_Chattaway,

Since you can’t set up the alternate DNS on your router lets go with another option:

Do you have another machine that you can temporarily use as your Roon Core? If you use that machine as your Core does the same behavior occur? This will help us determine for sure whether or not it is a network issue or perhaps something on that Core specifically.


Yes, I can download Roon server to my Mac Mini and test it that way. I’ll give that a go and let you know the results.


1 Like

Thanks, @Andrew_Chattaway — Looking forward to the results of this test.

Ok, so I was able to try a few different things out:

  1. I downloaded the Roon Core software to my Mac Mini which is on the same network. I deauthorized the Wyred 4 Sound Music Server (MS) as the Core and selected the Mini. For some reason the Mini was not able to see any of my music files on the MS but I had a USB drive with some music files that I used for this experiment and connected that to the Mini.
  2. I logged into the Qobuz account on the Mini Roon player interface and my albums and music files appeared there as expected.
  3. I started the test by playing local audio files both to my Naim player and the NAD M12 via the MS. This worked fine as expected.
  4. I then moved to playing Qobuz files. Initially I notice a slight increase in access time whether I was playing to the Naim or the MS, however I started to get long gaps before music would play so I determined that using the Mini as the Core did not make any difference to the experience.
  5. I proceeded to switch back from the Mini to the MS, deauthorized the Mini and re-set the MS as the Core.
  6. After this I repeated the process as before with the Mini using the Mini as a remote and also my iPad. I still got the delay or no start of music from Qobuz.
  7. I decided then to try my iPhone as the remote. When using this the delays to start play were a little shorter but I did experience multiple long gaps or no plays with various randomly selected files not dissimilar as compared to the iPad and Mini.
  8. I then installed the Roon player onto my work PC to see if a windows based machine would be any different with playback of Qobuz. Alas I still came up against long delays, no playing at all or occasionally the files would play. The same experience as the Mini and iPad.
  9. Roon Radio with Qobuz is non-existent as it just fails to play any tracks.
  10. I can stream Qobuz directly from their app, but it kinda defeats the object of integration with Roon and my local library of music.

I hope we can get to the bottom of this issue. thanks.

@Andrew_Chattaway perhaps try to add the DNS settings to your MacMini in system prefs under network and advanced then select DNS. it will show the selected DNS entries that your router has assigned but when you go to add a new one it will like wipe out what is there so make a note of the current one(s) so you can add them back. add on your router first probably something like and then and or
apply and see how that works for you.

Hi @Andrew_Chattaway,

I appreciate the thorough testing here. Based on the results of your testing, it sounds like the network communication is most likely the issue here since this is happening with all devices on the network. To confirm, I’m hoping you might be able to try this:

  • Switch back to the Mac or Windows Core machine
  • Use hotspot / USB tethering to access a mobile network

Does the same issue occur here? While a mobile network is definitely not ideal, it will help show us how things behave when you’re on a different network completely.

this is what I have discovered so far:

  1. Try the alternative settings suggested by wizardofoz - I changed the Core back to the Mac Mini and went to the network settings and successfully changed it I also changed the same settings for my remote devices (iPhone and iPad) to the same DNS. This did not make any difference to the main issue.

  2. I switched back the Core to the MS1 and got things back up and running there. This of course did not have it’s DNS settings changed. I can’t access those for that inidividual unit to adjust them. However I kept the iPad and iPhone on I was able to get some tracks to play with the following issues:
    a. What I have found is that when I initiate Roon and select Qobuz, pick an album at random (sample rate does not make any difference) and select ‘Play Now’ nothing happens.
    b. If I repeat that process but instead of selecting ‘Play Now’ but use the individual Play indicator next to the track it will play on most occasions.
    c. If I hit skip to the next track from the Play Bar at the bottom of the screen then it stops play most of the time.
    d. If I select Add Album then try skipping between tracks it stops.
    e. If I let the Album continue to play it stops after about four to five tracks. Most times it will start playing again if I hit the individual track Play indicator.
    f. If I pick another album after using the individual track Play indicators, then select Play Now it stops.
    g. If I pick another album to try using the Recommended section to the right and use either the Play Now or the individual track Play indicators it stops.
    h. Have seen a message that Qobuz is loading slowly and may be a connection issue. This makes no sense to me.
    i. Roon Live Radio works without issue.
    j. Accessing my local library on the MS1 has no issue.
    k. It can take a while for it to load the albums when either selecting Overview or Qobuz.

  3. I have a very fast reliable internet connection, usually between 850-950 Mbps. There should be no issue at all to stream even hi-res music.

  4. I have no issue streaming video sources, running multiple video and audio conference calls as I work from home.

  5. Streaming Qobuz from their app directly works fine and response time is pretty quick from play to actually hearing music.

  6. I am able to stream this to devices over air-play but of course this limits my resolution to CD quality only, defeating the object of the integration and lossless path.

  7. Unfortunately I live in a high-rise so my cell data reception is not really strong enough to test for tethering over a mobile data network so it may not be a good result. I will give it a go and see if I can make it work.

  1. I switched the Roon Core over to my PC and connected it to my phones hotspot for data. I got it to show the Qobuz albums but I could not get it to play anything at all.
  2. I closed Roon and started the Qobuz app to play directly from that. It was ble to stream at CD quality and maintain the download to continue playing without a problem.
  3. I reconnected the PC back to the ethernet and my home connection. I was able to get Qobuz to play in the Roon app now but ran into exactly the same issues as I have mentioned in my earlier post today. I even got a Qobuz is loading slowly message again and that it may be a connection issue. I am certain it is not an issue with my internet connection speed.
    It seems to me there is something not communicating properly between Roon and Qobuz when trying to play Qobuz integrated. Qobuz is working fine in their native app. There also seem to be issues in the way in which you select the music album source from within Roon, using the Play now button or the individual track play indicators, or when tring to select from Recommended albums. These appear to be the common issues of not being able to get Qobuz to play whether it is using the MS1, Mac Mini or PC as the Core. I really don’t know what the issue but I don’t know what else to test from my end.



1 Like


I am also having the same issue on two different systems on two separate networks in different parts of the UK; Manchester and Leeds.

My main Manchester setup is Roon core installed on an Innous Zen mk2. Connected to a Chord Qutest via USB.

When I try and play a track streamed from Qobuz I get the loading graphic on the bottom of the remote app (on iPad Pro 2018) and eventually with get a “Qobuz is running slowly” message appear. Sometimes the track will play after about 15 or more minutes.

Streaming using the iPad app on the same network works fine.

Have a Tidal account as well and this has no issues at all.

The Innuos is connected by CAT6 copper to a Ethernet port on the ASUS router. No VPN or anything fancy set up.

I have tried:

  1. Restarting the Roon core
  2. Restarting the Innous
  3. Restarting the router
  4. Logging out of Qobuz on the Roon core and then logging back in again.
  5. Turning off IPv6 on the router and just using IPv4
  6. Using public DNS addresses ( & which have worked for me just fine previously
  7. Speedtest.net reports a downstream of 60Mbps with an up of 20Mbps

As I said previously. I have a friend who is in Leeds and experiencing exactly the same issue. He also uses Tidal as well and that has no issues.

Both setups have worked with no issues up until a couple of day’s ago.

So I’d rule out any local network issue and this this is somewhere beyond the broadband connections and could be to do with Roon/Qobuz peering?

Any ideas as to how to troubleshoot further?

Hope it gets resolved soon.

Thanks and stay safe.


You are not using a vpn setup to your company or something like that are you!

I have not been using my VPN connection to my work.

1 Like