Quad files no longer recoginzed as 4.0 but as "Other" [Ticket In]

Core Machine (Operating system/System info/Roon build number)

NUC 7I7BNKE with Rock 1.0 227

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Laptop WIN 10 latest build via HDMI to receiver (Stereo)
Media PC Origen AE S16T BluCinema linked via HDMI to Oppo 205 (Surround)
Denon AVR 4520 via AirPlay (Stereo)
OPPO 205 RAAT analogue to Denon AVR 4520 (Stereo)
All PC,s and laptops have the Latest Roon version 610
Description Of Issue
since the latest update Roon no longer recognizes Quad files as 4.0 but as “Other”.

During playback the down-sampling doesn’t work any longer despite the Signal path showing that it does.

The Down-sampling as mentioned in your Knowledge Base therefore is no longer working.
"Channel Mapping

The multi-channel world is a graveyard of false-starts and obsolete technologies, plus a lot of video/movie specific schemes that aren’t very relevant in an audio-only environment like Roon.

Most musical content produced recently is either in either 2.0, 5.0 or 5.1. There is a small amount of 7.1, too, and a small amount of Quadrophonic content. Compared to these four formats, practically everything else qualifies as exotic in an audio/music context.

Channel mapping for 2.0, 5.0, 5.1, and 7.1 is straightforward, since each larger layout simply adds channels to the previous one. In these cases, Roon matches up the channels from the source material with the channels on the output device and fills any unused channels with silence.

Quadrophonic content is handled slightly differently:

When playing Quad content to a 5.1 channel layout, the rear channels from the content will be mapped to the corresponding surround channels in the 5.1 layout.
When playing Quad content to a 7.1 channel layout, the RL and RR channels in the Quad content will be mapped onto the RL and RR channels in the 7.1 layout"

When playing to a Stereo zone the Surround channels of the Quad files are not audible.
when playing to a 7.1 zone the Surround channels are no longer mapped to the Surround back channels as described in your Knowledge base.
This only concerns Quad eg. 4.0.
The other Surround formats are still working fine.


is there anybody outhere…?

It’s the weekend…

Oops… could have figured that out myself… :pensive:

Hi @Frank_Nickel,

Thanks for the report! I’d like to get this over to the team for a closer look, can I please ask that you send me an album that is affected by this behavior via private message (click my name -> message)?

Hello Noris,

is there any update on this? do you need more information?

Hi @Frank_Nickel,

I’m going to check in with QA on this one, I appreciate your patience until I hear back from them!

After waiting two and a half months one should expect some answer on this, don’t you think?
And please not one of the usual standards.

Hello @Frank_Nickel,

Thank you for your patience here. I took a look at our internal tracker today, and I can see that your ticket is still in our queue.

Hi @Frank_Nickel,

Thanks for your patience here while I checked again with the team on this one.

We have been able to reproduce this behavior earlier in testing once, but since performing a force album rescan and reanalyze, we have not been able to reproduce this behavior.

Can I please ask that you try to right-click the album -> Edit -> and perform an album rescan and reanalyze and let us know if this helps?

Hello Noris,

Thank you for your reply.

I tried this on the Quad version of Bitches Brew from Miles Davis. The re-scan and reanalyzing helps to correct the tagging. So the album is now tagged as “Quad” again.I will do the same with the rest of the Quad albums.
However the Channel-mapping still isn’t working correctly as mentioned in my first post, thus the Surround channels are still not audible when mapping to a stereo output.

For what it’s worth: I also rebooted the Core, but that didn’t help either.

Hi @Frank_Nickel,

Thanks for letting me know that the album rescan sorted out the issue with the files showing up as other!

Can you provide some more details on what exactly is not working here?
I was able to play the China Grove sample track you sent down-mixed to a stereo zone.

What settings in DSP are you using to reproduce the behavior?
What are the exact symptoms you are seeing?

Hello Noris,

actually I don;t know how to describe it better than in my first post. If you look at the Signal path, than It looks like the surround file gets channel mapped to Stereo. But the surround channels are not mixed to the front speakers, thus not audible.
By the way, I did not send a sample so I don’t know who did.
The best examples to hear are files with discrete surround channels where Instruments are seated to other than the front. These instruments are not audible when they get downsampled to a stereo output.
“Pharo’s dance” from Miles Davis Quad version of “Bitches Brew” is a perfect example. On the beginning of the track the instruments switch from back to front. At the moment they go to the back channels they are not audible any longer.
All my files are flac files with different Sample- and bitrates. This effect occurs on all surround files and on all Stereo outputs listed above.
I don’t use DSP settings.
On all Stereo outputs the Multi-channel Mixing is set to “Downmix as needed”

None of the settings have been changed between the updates of Roon.
I hope that clarifies it.

Hello Noris,

after all the hassle of the latest major update to 1.8 the issue with non audible Surround channels on Stereo devices is still not fixed.
I have waited patently and want to ask you to take this finally into account and get a solution!
And please no more “we will look into this” or “be patient” as my patience is running out.
So will someone finally do something about it, please?

This is annoying. Already ripped Quadio by Doobie Brothers. And I can’t play it through Roon. My 100$ Sony Blu-ray can play 4 channel audio so why can’t my Roon setup?

Would anybody please bother to look into this?

Hey @Frank_Nickel,

Thank you so much for following up on your post from two weeks ago :pray:. I’m sorry we’ve missed it for this long :pleading_face: . Using the @support helped a lot, as our entire team was notified.

Our team will follow up with any updates we have on this :pray:

Hey @Sebastian_Ptak,

I’m sorry to hear you’re experiencing something similar. And sorry for the delay…

If you’d like our team to take a closer look and help troubleshoot, would you please create a post in the #support category? That way, this issue will get the attention it needs.

Thanks in advance :pray:

Thanks @noris and @beka.

To all fans of surround music, here is my answer to @noris:


, so to sum up:

  1. In the audio path I see mapping 4.0 to 5.1 layout
  2. My system plays so well in terms of imaging, that I was 100% sure that my central speaker is playing vocals :slight_smile:

Right now I confirm. My central channel is totally silent. The message in audio path is confusing.

@Frank_Nickel maybe you have the same situation? I had to put my ear really near the central channel to confirm that is dead silent while playing my Quad albums (Doobie Brothers in this particular case).