Random stops in playback since latest update

Roon Core Machine

Mac mini M1, 2020 8gb ram

Networking Gear & Setup Details

Hutton CGN3 —> AirPort Extreme —> Netgear GS305 connected only via Ethernet

Connected Audio Devices


Number of Tracks in Library


Description of Issue

Since the latest update last week I get random stop in playback. Nothing has changed in my setup. I use HQPlayer so I initially thought that could of be the source of the issue, but I get to same results when using Roon Ready in the untraRendu.

Update: This morning I turned on my DAC and changed the app to RoonReady in the ultraRendu and hit shuffle play on my iPad at 10am and let it play until 6:30pm with no random stopping. I decided to change app to HQPlayer NAA 4.2.0 on the ultraRendu and launched HQPlayer Desktop 4.17.2. Hit shuffle play on my iPad at 6:45pm and playback stopped at 6:55pm (after 10 seconds into second song) and message appeared - Roon lost control of playback device - or something to those words. To me this confirms its a Roon / HQPlayer issue. @jussi_laako @support

Any errors in HQPlayer log file? Where is the content stored?

How do I find this log file? My music library is on a LaCie d2 Professional 10TB External Hard Drive Desktop HDD - USB-C attached to the MacMini. @jussi_laako @support

It is documented in “Troubleshooting” section of the manual.

On Windows “%LOCALAPPDATA%\HQPlayer”, on macOS/Linux “~/.hqplayer”

I had this issue with my opticalRendu. Enabled flow control and limited my ethernet ports to 100M on my switch…all better. I literally tried everything else prior and nothing worked. My switch was overloading the rendu.

Just earlier, playback was fine for around ten minutes and then just stopped.

There is a read timeout 2.

We are looking into this problem. I have not been able to reproduce the problem. But if you can email me a log file and some details about the setup and content source, it would help.

Hi, @jussi_laako I just sent you an email to support@signalyst.com

i am having the same issue, constant crashing. i can’t even make it thru a song without roon crashing and restarting. it’s a major drag! i have the same computer as the first person fwiw but with 16gb ram

Any update on this? I basically can’t use HQP. kinda of a waste of money at the moment @jussi_laako @support. I’m not sure who is interested from Roon as I’ve had zero contact since my OP.

Any possibility that for example the HDD spins down during playback? HDD spin down is disabled in Mac power settings?

Did you try playing those tracks with standalone HQPlayer?

Hello @Todd ,

Does the issue only happen when the UltraRendu is used? If you try to output to your Mac Mini Core System Output zone, do you notice an error there as well?

Hi Noris,

I just removed the ultraRendu out of the chain and have my Mac mini connected directly to my DAC and launched HQP and hit shuffle in Roon and 1 minute into the 3rd song it stopped and said Roon lost contact with the device. I have had no issues at all with RoonReady having also stopping playback randomly (it may of been a mistake on my part earlier as I’ve had multiple 7-8 hours shuffle mode listening with no random stopping) only with using NAA and HQPlayer does this happen. @noris @jussi_laako

So it’s not only with NAA?

But are there errors in HQPlayer log file? Like read timeout? So far such cases seem to happen when data is not coming in properly from Roon that causes busy-loop prevention timeout.

Good news. Tonight was the first time since the latest Roon update that I have launched HQP. No issues with random stopping so far. FYI I’m using the ultraRendu back in the chain.

I spoke too soon. The random stopping started around 1 pm today. Unfortunately, the easiest thing is I’m just not going to use HQP anymore and use Audirvāna more than I have in the past. Too bad because I love SQ it provides over RoonReady. @noris @jussi_laako

Or just use HQPlayer standalone?

No. I’m sorry I’m not going to go down that road.

Hi @jussi_laako, fingers crossed, but I installed 4.18.1 yesterday and everything is working fine so far. Thanks.