Rapid clicking, no audio, S.M.S.L. IDea DAC, iPad

I bought an S.M.S.L. iDea DAC so I could listen to a Roon on my iPad Pro. The DAC seems to work fine with other music and video apps but works only sporadically with Roon. Usually, when I open Roon the DAC emits a popping sound in my headphone, and when I try to play music I hear only rapid clicking, seemingly at the same volume regardless of the actual volume setting in Roon and on the DAC. Sometimes I can get it to work by fiddling around in audio settings, but I’m not sure what I’ve done to make it work. When it does work it sounds great, and upsampling to 705.6 or 768 kHz works well. But i’d Like some consistency. When it’s working I can stop and start music without messing up the connection, though if I’m in another app when the music stops it seems to start clicking again when I switch back to Roon and select new music. It seems most likely to work if I get sound in another app before I switch to Roon. If it’s clicking in Roon the app can become unresponsive. Sometimes it simply produces no sound, but the interface is still responsive. If it clicks in Roon other apps will also have no audio.

I would hate to have to send the DAC back for a refund. I like it a lot when it works.

Hello @Steven_Goff — Thanks for sharing this report with us, it’s greatly appreciated!

I did a little searching on this device, and it looks like there are some others who are reporting similar behavior with this DAC, as seen here. Is the behavior described by these users similar to what you’re experiencing?

To narrow down the cause of this behavior a bit, have you tried using the SMSL iDea DAC with another device besides the iPad Pro? Also, is the iPad Pro completely up to date?


I’ve experienced the same with my iPhone and a regular iPad. I haven’t tried other sources, though I’ll try it with my Mac. Again, it works fine with all other music and video apps. The only problem is with Roon, although if it clicks with Roon it will keep doing so until I remove it, even if I close Roon. Unlike with other apps, the sound pops when I start Roon. If it clicks with Roon then Roon is unresponsive to touch. The light on the DAC glows magenta, indicating that it is receiving high resolution audio, but it only clicks. Sometimes there is no sound but the app remains responsive to touch. And sometime it works. I can usually tell that it will work by the distinctive pop I hear when it connects. That pop sounds different than the one when it won’t work. It seems that the problem is with the initial handshake between Roon and the DAC.

I’ve tried various configuration, turning on and off upsampling, crossfade, EQ, MQA decoding, etc. Although it is difficult to tell, none of that seems to matter.

By the way, I run ROCK on a NUC.

I knew about the problems some experienced using this DAC with Android devices, but not any problems with iOS devices.

Hi @Steven_Goff — Thanks for the update, I appreciate the additional insight here!

Can you please verify the following for me:

  • Have you tried rebooting the Core, remote device, any relevant networking devices, and the DAC? Did the experience change any after doing so?
  • Is this occurring with local files, music streamed from TIDAL, or both?
  • Since it sometimes works, but not others, are there any differences in the content you’re playing? Different file types or qualities?

Sometimes I can get it to work by fiddling around in audio settings, but I’m not sure what I’ve done to make it work.

  • Can you expand on the above a bit? What types of settings did you change?


I may have to amend what I said about fooling around with audio settings. I do know that if it is working with Roon it will stop working if I go into the audio settings for the iPad, even I just look at the settings without changing anything. It will then often freeze Roon, and I have to unplug the DAC, quit Roon, start another music or video app, and start that app playing before plugging the DAC back in. Then it will work with other apps and sometimes with Roon. It may take starting Roon with it unplugged to get it to work. It’s something about establishing the USB connection.

I’ll reboot and restart the ROCK, my router, and my access point to see if that matters.

Edit: rebooting the ROCK did nothing. Rebooting my router and access point did nothing, as far as I can tell.

Hi @Steven_Goff — Thanks for the additional information.

Do you know which version of the Apple Lightning CCK you’re using for this? There’s a USB 2.0 and a USB 3.0 version. Passing through high res audio with the USB 2.0 version could present difficulties as the USB 3.0 version is able to pass more power from the device to the connect peripheral.


As I edited my previous post, rebooting my devices changed nothing. I purposely got the Apple 3.0 camera connector. The DAC works fine with other apps. It is only when I introduce Roon into the mix that problems arise. None of my iOS devices warns that the DAC exceeds power specs. The camera connector allows charging via a second Lightning connector; charging while using the DAC results in no changed behavior. A test of the DAC suggests that it draws little power. I have not been able to find specs from Apple about how much power can be drawn for peripherals.

To answer one of your other questions, it happens with music stored on my NAS and it happens with Tidal. The source doesn’t seem to matter. Other apps work fine without regard to the source, whether streaming from my NAS or from the internet.

I’ll check again whether limiting Roon to 48 or 96 kHz makes a difference.

Edit: Limiting output to 48 kHz didn’t make a difference.

Hey @Steven_Goff — Thank you for the update!

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here. However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please attempt to play to the iPad’s output without the DAC being connected, and just playing to the iPad’s speakers? This way we can rule out the behavior being linked to the connection from Roon to your iPad.

Once you’ve tested the above, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.

Thank you,

Thanks so much, dylan. I can confirm that each of these devices (iPad, iPad Pro, and iPhone 6) work fine using the integrated speaker and the regular headphone jack. My routine trying to get the DAC to work usually involves listening to the speaker to confirm that Roon is working. And I just confirmed this on the iPad by playing something with the iPad’s speaker.

Hi @Steven_Goff — Thanks for confirming that for me.

For next steps, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.


Hi, Dylan. I reproduced the problem a few times. First, at 12:48 PM Pacific time I got no sound from Roon with the DAC plugged in. I was able then to use the play and stop buttons and navigate in Roon. I then opened YouTube and was able to start a video and then plug in the DAC, which took over from the speaker and played correctly. I then returned to Roon, started a song, and plugged in the DAC at 12:49. This time I heard rapid clicking and Roon was unresponsive to touch. I unplugged the DAC and regained control of Roon and played the song through the speaker. BPlugging in the DAC at 12:50 resulted again in clicking and loss of control of Roon until I unplugged the DAC. Each time the light on the DAC indicated that it was receiving ultra-high resolution audio. Same results at 1:02 and 1:04.

Edit: I just got it to work at 1:07 or so by fiddling around in the interface, looking at settings for the iPad, plugging in the DAC and starting a song. It’s playing now at 1:12.

As usual, when the audio stopped and I was in another app, the clicking started again. This happened at about 1:18 PM. Switching to Roon the app is frozen and clicking continues until the DAC is disconnected.

So the routine is, if I get no sound from the DAC the Roon interface is still responsive to touch. If I get clicking, the Roon interface is frozen until I disconnect the DAC. If the DAC is properly playing music I can use the interface, though going into the iPad audio settings seems to interrupt the DAC and cause it to stop working. The same happens if the music stops when I’m in another app and when a telephone call intrudes.

Hi @Steven_Goff

Thanks! Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.


Thanks, Dylan. I got a failure on my iPad Pro at about 4:17, with clicking. I got the DAC to play using YouTube, returned to Roon (without unplugging) and it started playing fine at about 4:19. It played fine until I entered device setup for the iPad Pro, and stopped at that point. Clicking thereafter until I unplugged the DAC. Then I got it working again in YouTube, switched to Roon without unplugging the DAC, and it played fine again. But when I stopped the music and switched to Safari to type this the clicking started again. Again when I got the DAC to work in YouTube, stopped the video, switched to Roon, and started music the DAC played fine.

So I seem to have a repeatable pattern.

Funny, but when I stopped listening in Roon with the DAC plugged in and started watching a YouTube video it started clicking in YouTube, and I had to unplug the DAC and plug it back in to get it to work in YouTube.

Hello @Steven_Goff,

After consulting with the tech team, they have asked that you try the following steps

  1. In the “Device Setup” page for the iPad zone, what do you have the “Volume Control” configured as? For the best performance, this should be set to “Fixed Volume”. Please make sure to click the “Save” button after changing this setting.
  2. Make sure that outside of the Roon app on your iPad, you have the volume set for the SMSL DAC to it’s maximum possible level in the iOS settings.
  3. In the “Device Setup” page for the iPad zone, set the “Resync Delay” to “500ms”.

Let me know if this changes anything for you!


Thanks, John. I’m not sure what you meant about setting audio at maximum for the DAC in iOS, since I don’t know of a universal setting for audio. I’m assuming that you want me to have audio at 100 whenever the headphones/DAC are plugged in, which is how I have it set. I’ve made the other suggested changes.

I don’t think these changes made much of a difference.

I still have to get audio playing in another app before I start Roon. Otherwise I get no sound or clicking. If I start audio in another app, stop playback, and switch to Roon, I usually get the DAC to work.

If the DAC is working in Roon it stops working and starts clicking if I go into the iPad’s audio settings, even if I don’t change anything.

If the DAC is working in Roon and I’m using another app when the music stops it starts clicking. I can avoid this by turning on radio. If the music is still playing I can switch back to Roon and select new music to play. If I’m in Roon when the music stops it still works.

If the DAC is working in Roon and I stop the music and switch to another app, the DAC clicks in the other app. I have to unplug it any time it clicks in order to get it to work again. Switching from Roon to another app always results in clicking in the other app.

Any further suggestion here? The problem persists.