Raspberry 3B, Allo DAC 2.1. KALI, DietPi/Roonbridge

#1

Have a Raspberry 3B with an Allo DAC 2.1, KALI Reclocker, Dietpi, and Roonbridge installed. The issue is the device does not show up in RoonServer under Audio, if click on About from within Roonserver the device is listed and running the latest version of Roonbridge.

I have reinstalled both RoonServer and DietPi/Roonbridge with the same result. I can ping the device and SSH just fine. I even insstalled Volumio and that worked fine.

Any suggestions as I have exhausted all my efforts.

Thanks

(Mr Fix It ) #2

You only need roon bridge on the dietpi software builds … don’t manually install, and don’t install server…you can and should install ALSA utils too IIRC

I think maybe without ALSA there won’t be any audio devices - and of corse you need to let it update to the latest build (142) and also setup the Piano 2.1 in the Audio devices

(Rene Bouwmeester) #3

Have you selected the correct sound board in dietpi-config > audio options?

When SSH-ing in, what is the output of ‘aplay -l’?

#4

Yes, I only have Roonbridge installed via the detpi GUI/interface. I renstalled RoonServer on my NAS as a troubleshooting measure. I will veriify ALSA utils isinstalled.

I have the correct soundcard selected, here is the output of aplay-l:

root@DietPi:~# aplay -l
aplay: device_list:268: no soundcards found…

I assume that is the problem even though I have selected and installed the driver/card.

#5

…according to dietpi and I have ALSA installed?

Have the latest version installed:

(Rene Bouwmeester) #6

When you say Volumio worked fine – do you mean you actually had sound? (That would eliminate assembly or hardware errors).

For now, can you check if the line

dtoverlay=allo-piano-dac-plus-pcm512x-audio

is present in /boot/config.txt?

(Type ‘nano /boot/config.txt’ at the prompt to open the file in the nano editor. You can add the line at the bottom if it is missing).

#7

Yes, in Volumio worked great and I was able to select the correct DAC.

Yes that line is in /boot/config.txt, last line/entry;

dtoverlay=allo-piano-dac-plus-pcm512x-audio

Thanks

(Rene Bouwmeester) #8

Hmmm… Pretty much out of ideas: driver should load, but hardware is not found. The fact that it is working in Volumio is puzzling. I’m not familiar with the Allo products – perhaps @Dan_Knight or @ALLO_audio_boards can share some wisdom here?

1 Like
(Tony Reimann) #9

I also have ffmpeg installed on my system

#10

Out of curiosity I went back in and installed the Piano DAC 2.0 (I have the 2.1) and now the soundcard shows up and the device is in RoonServer.

root@DietPi:~# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PianoDAC [PianoDAC], device 0: Piano DAC HiFi pcm512x-hifi-0 []
Subdevices: 1/1
Subdevice #0: subdevice #0

So, I reinstalled the correct driver for the Piano DAC 2.1 and no soundcard listed and not in RoonServer.

I assume there is an issue w/ DietPi or the driver specific to the Piano DAC 2.1?

Here is the DAC I have:
https://www.allo.com/sparky/piano-dac-2-1.html

The driver I installed that does not work:

Thanks

(Tony Reimann) #11

I am using the piano dac 2.1 and the dac plus driver (ie the one you can’t get to work) in dietpi and it works no problem…

#12

Tony,

Are you using KALI as well (I have that attached) and which SBC (RPI or Sparky)? I am out of options…

As I mentioned previously, this configuration works fine with Volumio, correct driver and DSP setting within Volumio.

Thanks

(Tony Reimann) #13

Yep using kali as well. A long shot but are you certain you have the piano 2.1 with the 4 rca outs and not the standard piano?

#14

Yes, 4 RCA outs and Piano 2.1 printed on the PCB :slight_smile:

Are you using a RPI or Allo Sparky?

(Tony Reimann) #15

Currently running sparky. I have a spare pi so can try it tomorrow to see if it makes a difference. It shouldnt but…

#16

I have a Vana player that includes the Sparky, Piano 2.1 DAC, KALI, and that works fine for me as well.

I had a spare RPI3 and just ordered the Piano 2.1 and KALI, so may be an issue with this configuration and curious what you come up with…

Thanks

#17

This morning I swapped out the RPI and same issue, will shoot Dan a message and see if he can provide any insight.

1 Like
(Dan Knight) #18

Hi,

It appears the Piano 2.1 driver isn’t available yet on the RPi. For now, you’ll need to select the Piano 1 DAC as the sound card.

I’ll bring @allo.com on this, see if we can get the driver added to RPi overlay on Git and patch for DietPi v143:

root@DietPi:~# ls -lha /boot/overlays | grep allo
-rwxr-xr-x 1 root root 1011 Jan 21 19:08 allo-piano-dac-pcm512x-audio.dtbo
root@DietPi:~# uname -a
Linux DietPi 4.4.43-v7+ #948 SMP Sun Jan 15 22:20:07 GMT 2017 armv7l GNU/Linux
(Janis) #19

I have same issue.
The 2.1 doesn’t work on RPI with in the audio card setup listed 2.1 driver. Does not show up in Roon.
However, works with basic Allo driver.

Janis

1 Like
(Andre / ALLO / CMO) #20

yes correct… its in the works.
regards
Andre

1 Like