Raspberry 3B, Allo DAC 2.1. KALI, DietPi/Roonbridge

#21

Any ETA/plans on the 384kHz kernel for the Allo Sparky SBC DietPi image?

Thanks

(Andre / ALLO / CMO) #22

hello
Sparky does not support 384Khz.
this can only be achieved with the RPI
regards
Andre

#23

Thanks for the reply.

(Dan Knight) #24

@Janis @ALLO_audio_boards
We’ve compiled the DietPi kernel, which includes the correct driver and firmware for Allo Piano 2.1 DAC (many thanks to Allo for their support).
This should vastly improve sound quality for RPi + Allo Piano 2.1 DAC users. Also resolves subwoofer output and modes.

Will be installed by default on RPi for DietPi v143, although, can be installed now by:


Using sound card:
dietpi-config > audio options > sound card > allo-piano-dac-plus-pcm512x-audio

1 Like
(Mr Fix It ) #25

[quote=“Dan_Knight, post:24, topic:18607”]
This should vastly improve sound quality for RPi + Allo Piano 2.1 DAC users. Also resolves subwoofer output and modes.

Will be installed by default on RPi for DietPi v143, although, can be installed now by:
[/quote]Will this all help the Sparky build or is RPi only

#26

Thanks Dan!

1 Like
(Dan Knight) #27

RPi only. The Sparky kernel has the driver and firmware already built in.

Roon endpoint - ethernet input and I2S (HDMI connector) output
(Andre / ALLO / CMO) #28

thank you sir!

(Mr Fix It ) #29

So how does one access things like the sub out crossover setting on the 2.1?

#30

I checked via alsamixer and there is an option for low pass and subwoofer…

(Janis) #31

@Dan_Knight

THX!!!

Just updated & tested it:

  1. Now there is sound from Piano 2.1
  2. But this Piano 2.1 driver is only supporting up to 192kHz, while basic Piano is supporting up to 384kHz (quite a difference in DSD to PCM down converting)
  3. Can you tell where is EQ and xover management?

Janis

(Janis) #32

so, three settings in alsamixer?

  • Lowpass (60-200)
  • Subwoofer volume (0-100)
  • Subwoofer mode (2.0, 2.1, 2.2)

Anythings else?

Janis

(Dan Knight) #33

Yep that is all the additional controls for subwoofer on Piano 2.1.

But this Piano 2.1 driver is only supporting up to 192kHz, while basic Piano is supporting up to 384kHz (quite a difference in DSD to PCM down converting)

I havn’t been successful in integrating 384KHz support on our new RPi kernel yet. Still working on it. So its 192KHz max at the moment.

(Faizal Yusmal) #34

Thanks for the update to 143 guys.

Seems like in 2.1 mode I can’t get Roon volume controls in “Use Device Controls” option. It just plays full volume all the time. (Didn’t blow anything up fortunately. Just some pissed off neighbours at 1am.)

Also tried reducing Master Volume in alsa mixer. Didn’t seem to make a difference either. Stopped short of testing DSP Volume option at that point before I do blow up something and went back to Piano Dac option.

I needed an to crossover at 50Hz so as of now it is still an RCA splitter from the 2 main LR output on the Piano 2.1 to the mains and subs. Hopefully the dual mono option will be an option in the near future so I can utilise both the Main and Subs out concurrently. And perhaps crossover down to 40Hz.

(Amit Khare) #35

Hi ,

I have installed the Allo provide Dietpi release with Roon bridge but still have not figured out how to control the volume.

the volume is very low at 43% on alsa mixer. Using the volume control on Roon remote sometimes stops the left channel. Any help will be appreciated.

Thanks
Amit

(Ged) #36

I would post this in a fresh thread, may not get noticed here.

(Stefan) #37

Well known problem, I suffer the same. One advice was to define the endpoint using the DSP volume. Sort of a dissapointing solution since you loose the enhanced signal path then.

by now I do control the volumes (speakers (1.DAC outs) aswell as the sub (2.DAC outs) and the crossover using a small util firing some amixer commands to the pi.
Works ok and since then I never lost a channel and I could prevent setting the DAC into DSPvolume mode which results in a loss of the enhanced signal path when lowering the volume.

By now I do even believe it’s a Kali issue, since my other allo dac (w/o kali) never showed such issues.

If you’re on windows I could let you have the util … if on a mac . .sorry no idea, living in an apple-free household :wink:

(Amit Khare) #38

Hi Stefan,

Let me know the utility, I familiar with alsa command line and linux. So I can as well write a shell script for it.
I am away from my system till the weekend so will try all the options.

Thanks,
Amit

(Stefan) #39

start with
amixer -c 1 ‘controls’ for the complete list of control the piano2.1 offers

amixer -c 1 sget Master will show you if left and right channels are still synced, but that’s pretty useless since you get 2 values while you need to know 3 till 4 in the end.
so you better use
amixer -c 1 sget Digital (which is the primary dac output mostly connected to left and right speakers
and
amixer -c 1 sget Subwoofer (for the second DAC outs.

In case you need 2.1 mode you must copy some files from allo onto the dac I bet.
amixer -c 1 sget ‘Subwoofer mode’ should show “2.1” and also let you configure it that way using
amixer -c 1 sset ‘Subwoofer mode’ ‘2.1’

I personally recommend using Digital and Subwoofer against Master.
The ideal thing is to once set up these 2 to your needs and then ensure to apply the offset upon each change of Master if one can’t resist to touch that one.

(Amit Khare) #40

Excellent.
Thanks very much, Stefan. I am travelling, so would try these, after the weekend. I have been struggling, so this is the light at end of the tunnel.
Cheers.