Raspberry Pi 1/8" headphone end-point?

Which end-point software supports the built-in 1/8 headphone jack on the Raspberry Pi?

This may be sacrilege, but I’m trying to find RAAT-compatible software on the Raspberry Pi that will output a simple 44.1Khz/16bit output on the built-in 1/8" audio jack. This is for a “Lo-Fi” application.

Separately, I have a HiFi-Berry with a Digi+ board, but I’d like to set up an endpoint with an even cheaper hardware setup that doesn’t require the higher fidelity.

Hi @Chris_Lewicki!

I am not aware of software that will do this. But, another approach for a low cost end point would be to use a Raspberry Pi Zero W and a very low-cost DAC. Then, use a RCA to female 1/8” cable. (This assumes that the output device is easy to drive and requires no real amplification.)

I use the HiFiBerry DAC that outputs to 1/8” for some powered speakers, but I am not certain it is available any more.

1 Like

Hi,

unless I have misunderstood your requirement, the audio does come out of the built in 1/8" jack on a PI running Roon Bridge/Diet-Pi software I believe. You may have to enable it in settings and check that it isn’t muted and the volume is turned up, but I’m sure it is there (and lo-fi).
You may need to set Roon to limit the Pi to 16/44 in Roon settings as the Pi Dac may not be capable of anything higher and you will likely get silence if anything higher is sent.

The headphone socket on the pi is pretty unlistenable as it has too much interference. You can buy a hat with headphone socket for.not much such as.the justboom DAC.

Thanks; I did not realize that (feel a bit stupid about it in fact).

1 Like

I haven’t got to the step of trying to make audio come of the 1/8 jack though, as every software install asks me what HAT I am using (there is never an option for “none”).

So back to my initial question - which RAAT-capable install should I use to suffer the noisy quality of the internal 1/8" audio-out?

I don’t recall ever seeing the analogue out being availble as an audio choice in Roon remote for any of my pi’s and I have mixed Ropieee and dietpi. Without a hat you
might not see it on the network at all in Roon. I know Ropieee is digital only so that’s out of your choices.

Perhaps a standard Pi Linux load, then download and install the Linux Roon Bridge in the regular way?

I was able to make this work satisfactorily with DietPi + RoonBridge

After setting up DietPi, the brief steps were:

  • apt-get update
  • apt-get install ffmpeg
  • apt-get install libasound2

Via dietpi-software

  • RoonBridge
  • ALSA: linux sound system

I had originally neglected to install ALSA from dietpi-software (ffmpeg + libasound2 satisfied the requirements for the command line installer - roonbridge-installer-linuxarmv7hf.sh). However, the RoonBridge was not visible on the network, despite showing no errors in the logs, and successfully advertising itself. Suspecting that it wasn’t seeing the Pi audio interfaces correctly, I installed ALSA via the DietPi software interface, and now it works. It advertises both the analog (bcm2835) and HDMI (bcm2835 IEC958/HDMI) ALSA outputs to Roon.

I did not need to do anything special in Roon to configure it - it plays CD quality, HD FLAC and DSD files without complaint or problem.

I also enabled “PSU noise reduction” in dietpi-config audio options, which puts the CPU into powersave mode and disables the HDMI output.

The audio sounds “fine” - consumer grade 44.1KHz/16bit. Didn’t notice any difference with PSU noise reduction in my brief testing through Apple headphones.

Also added shairport via dietpi-software and that works fine with this configuration as well. It seems happy to play sound from both inputs simultaneously without conflict (a feature or bug, depending on your tastes).

It seems the AirPlay input is a little lower in volume than the Roon input, but haven’t investigated that yet.

3 Likes

Consider Chromecast Audio