RE: Upgrade process from Core 1.8 Legacy to 2.0?

Hi,

I run Roon remote on my Ipad and use Nucleus. I got the same issue as a lot of other Roon users have in the last a few days with updating to 2.0. My Roon remote updated to 2.0 but my Nucleus is stuck at 1.8. As a result, the remote can’t connect to the Nucleus. I was trying to use your post “Roon 1.8 <-> 2.0 Migration FAQ” to solve the issue but I got lost. It seems the steps below are the ones to solve my issue per the post (I just copied these from the post and paste them here). Can you please let me know if I am correct? I am not tech savvy so the first step gets me stuck. I tried to read the instructions link but still couldn’t figure it out. Could you please send me a detailed step by step instructions to solve my problem? I really appreciate your help.

RoonOS Core 2.0 (Nucleus / ROCK)

The names below in red are case-sensitive, capitalization matters

  1. Go to the /Data/ share (instructions) and create a folder called branches

  2. Download the following file: roon_2-0 (It should be named roon_2-0 and saved with no file extension)

  3. Copy the file into the branches folder previously created

  4. Rename the file to roon (instructions on how to rename files: Windows / MacOS)

  5. In the Web Interface, click “Reinstall” under Operating System

Hi chenggang,

Is this the step giving you issues? If so, it is asking for you to use another PC, either Windows or Mac. Using the file manager of that PC to open up the Nucleus Data location and create a folder called branches (all lower case).

I have pulled the related instructions on how to access the Data Directory below. (from the link in line 1).
Since you are running a Nucleus you would use Nucleus in place of ROCK.

So for Windows the line would read:

  1. Windows - In Windows Explorer, type \\Nucleus\

if you had a Nucleus Plus then it would be

  1. Windows - In Windows Explorer, type \\Nucleusplus\

and finally, you can use the IP of the Nucleus instead (IP chosen randomly, you would need to use your devices IP)

  1. Windows - In Windows Explorer, type \\192.168.1.10\

Accessing Roon OS’s Data Directory

With ROCK running on your network, you can access Roon OS’s /Data directory like any other SMB share.

  1. Windows - In Windows Explorer, type \\ROCK\

  2. MacOS - In Finder, click Go, then Connect To Server. Then type smb://ROCK/ and connect as a Guest

I hope this helps.

Cheers.

You need either a PC or Mac to access this directory on the Nucleus. Do you have either?

Hi, thank you very much for reaching out to me. Your instructions helps me get to the “data” folder. I have a PC but I am stuck in the first step from the guide. I got to Data directory from my PC following your instructions, but I could not find “share” folder to create “branches” folder. The post says " Go to the /Data/ share (instructions) and create a folder called branches." But there is no “share” folder in “data” folder. All I can find in “data” folder are Codecs, MachineSettings, RAATServer, RoonGoer, RoonOS, RoonServer, and Storage folders. So I created the “share” folder myself within the “data” folder and then create “branches” folder? After finishing all other steps, I was able to update the Roon Nucleus to 2.0. Then when I tried to connect to it from my Roon remote on Ipad, I was asked to login. Below are the pages I got. What should I do? Thanks.



Click on Unauthorize. Then it should connect.

PS: Again one big bug because it seems that you only have ONE Nucleus, right ?

Yes. I only have one Nucleus. Thanks a lot for the help.

Finally made it work. Thank you so much for everyone who helped me!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.