Recognizing Roon Bridge on MacOS Mojave

I’m in the process of trouble-shooting Roon Bridge on MacOS Mojave not showing up.

I’ve created a simple test with two new MacBook Pros side-by-side on the same private Wifi. One running Core, the second running Bridge. Cleaned Library folders, disabled MacOS firewall, rebooted, tried safe mode, etc - Bridge isn’t found.

“About Roon” shows Bridge has an affinity with the loopback interface. Is this a hint Bridge is binding only to the loopback interface (and not the Wifi interface)?


tcp4 0 0 localhost.9004 . LISTEN

Hi @Northrock,

Can you elaborate on your current networking setup? What type of router is in use? Is there any other networking hardware in use? Is there any change if you use Ethernet instead of WiFi?

I first tried the connection over ethernet via unmanaged NetGear switches. To simplify a test / search for a baseline, I disabled ethernet and connected both computers to an Apple Airport Extreme.

Is there merit believing the Bridge is binding only to the loopback interface? Is there a way to influence / hardcode that? Or should we be looking more broadly?

The two systems work fine together as Remote and Core, screen/file sharing, etc.

Hi @Northrock,

The loopback address will appear if you’re viewing this from the UI on the same machine that RoonBridge is installed on, so that is to be expected.

If you use this device as a remote for playback instead of RoonBridge do things work as expected for you?

Thanks for confirming this.

Yes, the system I am trying to run Bridge on works well as a Remote to the Core.

Thanks for confirming, @Northrock.

Since things are working okay with Roon in a remote configuration, we know that the Core machine is able to communicate with the other Mac, so it seems like something else is going on here.

Can you try once more disabling the Firewall on the RoonBridge Mac device? Once you’ve done so is there any change to what you see?

Can you share a screenshot of Settings | Audio?

Both systems on Wifi > disabled firewalls > stopped Core, Remote and Bridge > started Bridge > Core > Remote > took screenshot (no change from earlier).


On a related note, I have an iPhone enabled as an endpoint (shown in the screenshot). I can play Roon on the iPhone, but I cannot play the iPhone from another remote - it shows up under Audio but not as an endpoint to play to (this is not important but I thought I could in a previous test, maybe I’m mistaken).


  • Newly minted lifetime member

Hi @Northrock,

By default, mobile devices are set as Private Zones. Private Zones cannot be played to by other remotes, but you can change this in Device Setup.

Regarding RoonBridge, here’s what I’d like to try:

On this Mac, uninstall all Roon software, reboot, and install only RoonBridge. After doing this is the Core machine able to see RoonBridge?

Thanks, I remember now, that’s how I got it working earlier. Disabled private and the iPhone is working as an endpoint on the same wifi network as Core and Bridge.


Over to the Bridge system - firewall remains off > stopped Remote and Bridge > deleted Roon folders from Library and RAAT cache folder > Uninstalled Roon > rebooted > started Bridge. Neither the Core system or the iPhone can see the Bridge under Preferences > Settings.

Hi @Northrock,

Moving forward, I was hoping you could use the directions found here and send us over a set of logs using a shared Dropbox link. We will need logs from your RoonBridge device. Please note that we will need the logs from the RoonBridge folder and not Roon or RoonServer if those are there.

Thanks Dylan. PM sent with link to a set of RoonBridge logs.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.