Recovering from failed update [Resolved]

I am running Roon on Windows 10 Pro. The update failed with the following message:

I closed and then tried to re-open Roon and it failed to open. I looked at the c:\users[user name]\AppData\Local\Roon\Application\Roon.exe install location and the update renamed Roon.exe to Roon.exe_old, but unsusccessfully installed the newer version and left everything in an unknown state. I just needed to rename Roon.exe_old to Roon.exe to get it back to 1.3.

I tried installing the latest RoonInstaller64.exe and that didn’t run at all:

I guess I should wait a little longer before trying to upgrade.

Can you reboot your machine. After that download latest build from website and install it on top on of the existing one ( you don’t need to uninstall anything, your DB will not be erased during this procedure).

I get the same error as before:


This error doesn’t specify why app is failing to start. But basically this is related to windows environment. This might be graphic card driver or out-of-date/disabled .NET Framework.

Try to install/update those two and let us know.

I upgraded my graphics card drivers to the latest and I had .NET 4.7.1 installed already.
I rebooted and tried again with the same problem.

I’ll wait with update…

0xc000007b can be interpreted as STATUS_INVALID_IMAGE_FORMAT. That could be because of running an x64 executable on an x32 Windows or because of file corruption. In my experience (used to support Windows kernel developers), the latter is the more likely.

(Another possibility is that Roon was trying to install a kernel driver, and said driver binary wasn’t properly signed. But I don’t think Roon installs a kernel driver.)

Good suggestion, though I don’t think this is a case here since user was running x64 previously ( basing on the screenshot in the first post), but it worth trying x84. @Bathyteuthis would you mind to try to install 32 bit version of Roon ?

I tried installing Roon 32-bit and had the same error. I’ve been upgraded a few versions without issues since May. The only difference I can think of is that I upgraded to the latest Windows 10 version a couple weeks ago.



I have a windows 10 VM that I checkpointed at Win 10 v1607, Build 14393.1914.
I was able to install RoonInstaller64.exe that I copied from my desktop. I’ll revert to the checkpoint and update Win 10 to see if I can replicate the problem.

Good to know, keep us updated.

1 Like

I upgraded Win 10 on the VM to v 1709 build 16299.125 which is the same version on my desktop and was able to successfully run RoonInstaller64.exe (copied from my desktop)

Is there a way to configure the installer to output a log file? Or is one being created somewhere in my user profile folders or temp folder?

Every time you start the app it creates new log file which is located here C:\Users\Your_username\AppData\Local\Roon\Logs. You should try and look there, though there is a chance that app fails too early to create a log file. In this case I would also recommend to check the Event Viewer.

It appears the installer fails before the log file gets written. I didn’t see anything in the Event Viewer logs from Roon. I’m leaning toward rebuilding the machine sometime tomorrow.


If the installer fails before it can write a log, and since you saw the code STATUS_INVALID_IMAGE_FORMAT, it may be the installer cannot be loaded for some reason. Refer to for suggestions; Process Monitor is probably the place to start, followed by using WinDbg to (try to) load the installer.

Maybe, however, the installer is failing in loading a DLL. So maybe the Dependency Walker is the first thing to try.

That’s very useful info. I used depends and it looks like I am missing the file
I’m missing the comctl32.dll from Win 10 v??? build 14393.953.

I found this web page with info on fixing missing/corrupt system files:

I tried using dism.exe and sfc.exe to repair and was unsuccessful. I’m not going to bother trying to manually fix it since there are probably other things missing so I’ll just rebuild from scratch.

Thanks for the help.

I rebuilt the machine and successfully installed Roon 1.4.

This topic was automatically closed after 31 hours. New replies are no longer allowed.