Red triangle warning. Metadata improver paused

Roon Core Machine

Roon Rock Intel NUC10i7 8gb RAM

Networking Gear & Setup Details

Talk Talk ISP modem/router. Ethernet network Cisco 2960 unmanaged switch. Ethernet to ROCK, Ethernet to endpoints.

Connected Audio Devices

Devialet Expert Pro 440. By Ethernet.
Soncoz DAC by USB3

Number of Tracks in Library

14923 tracks

Description of Issue

Red warning triangle. Metadata improver paused.

Rebooted the Rock core, rebooted ISP modem/router. Restarted Roon remote on IPad.

Take a look at the ‘Resolve Networking Troubles’ on this page. It might help. I’d start by checking your DNS, and set it to either (Google) or (Cloudflare).

Tried changing the DNS server settings to cloud fare. I did try this when I had metadata issues before and it made no difference, and it’s the same this time. Still have the red triangle warning.

I’m having no issues anywhere else in the network and Roon is working as normal, just the red triangle won’t go away no matter what.

It’s probably not going to help, but try instead of Cloudflare. Once you’ve done that, reboot the core.

If that doesn’t help, and you’ve disabled IPv6 on your router, and checked you’re not running a VPN, firewall or antivirus software, you’ll have to wait for support to show up as I’m out of ideas :frowning:

By the way, I didn’t ask, are you running the latest version or Roon on your core? I’m assuming so.

The core is a Roon Rock running on an Intel NUC. It’s not using a VPN, the core is running the latest version of Rock software, there is no anti virus. Changing the DNS server settings has not made any difference.

The NUC Rock has been running the core without issue for the last four months. My storage files are on an external 1TB M.2 NVME SSD in a small USB3 caddy which is connected to the NUC USB C port.

This afternoon I shut down the core and removed the external SSD to back it up onto another disk. Since I restarted the core after the backup the metadata warning has been present.

I checked the library maintenance to see if there were any files that needed cleanup, but there were no files to clean up.

Not sure if any of the backup tasks are relavent to the metadata error I have now.

post the screen shot of the rock web gui page please

where are you changing the DNS address?

Try rebooting from scratch

Stop everything, unplug . Network Everything

Then progressively restart each component in turn waiting until each component has started fully. Patience is a virtue :heart_eyes:

This is normally because you are not properly connected to Mother Roon

wizardofozMr Fix It


post the screen shot of the rock web gui page please

where are you changing the DNS address?

Changing the DNS address in the ISP router DNS settings from Automatic to manual. Tried both and

Ok. I tried that, shut everything on the network down.

Re-started the ISP Modem/Router by powering off completely.

Waited for the modem/router to restart before starting the ethernet switch.

Waited for the switch to fully re-start and then started the ROCK.

Waited for the ROCK to boot before starting the Ipad remote.

Started ROON on the remote, red triangle still present.

Click on the red triangle and get this message.

UPDATE: since trying all of the above with no success. I went back to the ROCK GUI and instead of rebooting the core I selected ‘Restart’ ‘Stop’ and then restart roon software.

The red triangle warning has gone.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.