Release 2024.01.1


That was an interesting day yesterday with the 2024.01 release. Not particularly the way I wanted to start the year. So first of all: sorry for that.

Most people have been able to recover from it, but I’ve released a 2024.01.1 release that ‘properly’ solves the issues.

Does this mean that everything is all well and good now? Unfortunately not entirely. Those people that have a Pi3 architecture and installed yesterday from scratch (so reflashing their unit) are stuck: they need to reflash again. So to be exact: this is the Pi3, Zero W 2, Usbridge, PecanPi and PecanPi+ devices. Again, only if you reflashed: in all other cases you’re fine.

I advise everyone (yeah I see the joke here ;-)) to upgrade to this version. If your unit is still reporting that a 2024.01 update is available, please reboot it first.

Here’s the changelog:

  • NEW: add button to visit Plexamp webpage
  • NEW: provide ‘Airplay 1 only’ option
  • ENHANCEMENT: heavily reduced image download size (~50%) [for now Pi4 only]
  • ENHANCEMENT: download new update, even if there’s already a previous update downloaded
  • ENHANCEMENT: update Linux kernel
  • ENHANCEMENT: update Plexamp component
  • ENHANCEMENT: update HQPlayer NAA component
  • ENHANCEMENT: update UPnP player component



Thank you, Harry. I appreciate all that you do.


Not cool this morning!
Tried to update Ropieee and unfortunately I didn’t read the thread related to the issue.
My screen is stuck on the “wrapping up installation” for the longest.


Thanks Harry,

I did the upgrades to 2024.01.1. All worked fine.

Thank you for all the hard work, Frank.

1 Like

Sorry, my stupid english doesn’t me allow to understand completely what you wrote. Briefly, having ropieee on a Zero 2w, this release is also for my device or not? And if yes, how to upgrade?
Sorry again…

Is it XL right now?

You have a Flirc or OSMC dongle?

Are you replying to me? If yes, yes it’s XL and i have no flirc and no dongle, only pi zero 2w.

Yes. I have a FLIRC.

Thanks for the quick response.

All good :+1:t3:

Appreciate your fast response and dedication to your product.


Then you’re save and you can update.

Hi there

Just upgraded a Pi4 to 2024.01.0 before reading about the issue - but got i back on track on a 2024.01.1 by re-flashing it, so all is good here.

On top of that I have a Pi4 and Pi3 that I just rebooted to trigger those to get the 2024.01.1 update, but both of them stille report the following:

Pi4: Update 2024.01.0 [1269] downloaded and available for your device!
Pi3: … well, it does not yet state any update available?

I would expect that both should state “… 2024.01.1 …”. What am I missing here? Do I just need to be patient for the devices to download the 2024.01.1 update?

Thanks & kind regards

1 Like

Hi Jens,

Can you send me feedback?
If you don’t have a Flirc or OSMC dongle you can go ahead and install the update.

1 Like

Hi Harry

Sure, here’s the feedback:
Pi4: 2d602c8514fa2be2
Pi3: 5de00446e70b67f9

Ok, thanks.


Both units are fine. The Pi3 is still waiting (update is available, but it can take a few hours).
If you reboot your Pi4 once again the message about the update to 2024.01 will be gone.



Ok. I can confirm that neither of the units now report information about an update. I’ll wait for tomorrow to see if the upgrade information about 2024.01.1 will be available by then.


1 Like

Thanks for the update. Installed on both Pi4 devices running RopieeeXL and everything is fine. Remote on my primary Pi device is working now too.


1 Like

Thanks Harry. All good here.

1 Like

Thanks for all your efforts Harry.

I’ve upgraded 4 to 2024.01.1 all with different configs and all successfully.

  • Raspberry Pi 4 Model B Rev 1.5 with DigiAMP+ HAT and Official 7" LCD
  • Raspberry Pi 4 Model B Rev 1.5 with USB and Waveshare 5" DSI LCD (unsupported)
  • Raspberry Pi 4 Model B Rev 1.4 with USB
  • Raspberry Pi 3 Model B Rev 1.2 with USB
1 Like


All devices updated to 2024.01.1 now - thanks for you support :+1:

Kind regards

1 Like

I’ve got three units which are sitting on:

“Update 2024.01.0 [1268] downloaded and available for your device”

I’ve rebooted all these units but they’re not picking up the 2024.01.1 update. Should the reboot force the unit to see the new available update?