Release RoPieee 2022.02.1

It’s only a week since the previous release, but I made a promise :wink:

So here’s 2022.02.1, a relatively small release with the following changes:

  • IMPROV: update base packages
  • IMPROV: fix potential issue with 384k on Hifiberry DAC+ HAT’s
  • NEW: provide advanced option to disable low power icon
  • NEW: support for HifiBerry Amp100 HAT
  • NEW: the Alarm Clock extension is back


Regards Harry


updated smoothly my two devices.

@spockfish I have gone through the update several times and it still says there is an update to install.
feedback sent 1024f63945436f6d

Music plays but the display is blinking on and off and has an incomplete display of information.

The screen keeps turning on a nd off even when no music is playing. showing the above screen.

I recently re-flashed and changed the SD card in this unit.

You’ll not hear this lot streaming. Shame I say. Not typjcal Creation material more akin to Sarah. Lovely stiff.


There’s a time limit on the update process itself, and your unit took more. Hence the update fails.
It shouldn’t really take that long. Combined with the screen issue…

So can you reflash? And see what the unit does after that?

1 Like

I had no upgrade notification so I rebooted. And there it was.

1 Like

Updated 2 devices
The Device with Display works well
The second device shows in the advanced tab that screen

Can you send feedback?

After restarting the ropieee the same issue
Have a look at the board type
Raspberry Pi 3 Model B Rev 1.2
Is this the problem ?

The other is a 3B+ Rev1.3

@Hans-Peter_Suss Can you send me feedback? You can find that option on the ‘advanced’ tab.

This is the advanced tab

oh sh… duh. of course.

Hmmm… that’s a chicken and egg problem. I need to think about another way to get the feedback over here.

I’ve just tried to update my RPi, same version, no luck. Have tried several reboots but each time there’s a long period of fast flashing green light, then just the red light and it has dropped off the network (WiFi). Unfortunately I don’t think there’s any way to give you any useful information about this, @spockfish . I’ll try the previous version again when I have a chance, but for now am reverting to old Ropieee (as I have the SD card easily to hand).

Hi @Hans-Peter_Suss ,

I’ve installed a ‘rescue script’ that, after a reboot, sends feedback from your unit after 15 minutes.

So please do the following:

  • reboot/restart your device. It will pull in the rescue script
  • when it’s up and running go to the web interface, and go to the ‘advanced’ tab (which obviously won’t work). Make sure you do this before the unit is up for 15 minutes.
  • inform me of the time you did this.
  • after 15 minutes the unit sends me the feedback from your unit so I can have a look.


But what do you mean with ‘same version, no luck’.
It came back but with the same version and you got the notification “update available”?

Start it now

It’s up now

Sorry, realise I wasn’t clear. So, I migrated this device to the original release version of RopieeeNG. Worked perfectly. Then got an update message, ran the update and it got as far as the “finishing up” message. However, it never finished and instead fell off the network and hasn’t been seem since. Reboots have the behaviour described. Could potentially connect via cable to try that, if definitely helpful, but it’s really awkward for a variety of reasons.