Release RoPieee 2022.05.1

Hi,

Just put out a patch release that fixes 2 regressions from the 2022.05 release:

  • FIX: WiFi on the Zero 2 W not working anymore
  • FIX: NTP fallback (NTP over HTTPS) does not work after latest update

Enjoy and have a great weekend!

7 Likes

That’s sorted out my Zero 2W connection issues over wifi. Connection defo seems more robust than using the old pre-Pi Zero Ropieee which had the occasional dropout over wifi (which was still totally useable). Not had so much as a blip in my limited listening so far even with 24bit 192k files.

Thanks for sorting so quickly and for your general work on this Harry. I’ll be sure to keep my small monthly donation via Patreon running for a while longer yet!

2 Likes

Q: Do the latest versions of Ropieee still run in RAM, allowing hard power off?

Hello –

Fired up my Pi 4 with RoPieee XL 2022.5 and noticed there was an update to 2022.05.1. I applied it and now my WiFi signal is significantly weaker. RoPieee XL would not connect to my WiFi. Multiple reboots and same thing – seems to get stuck in final stages of booting. Brought the Pi to another room with the wireless router and suddenly it connected. I took it back to its original room and location and no-go. Rebooted router and no-go. I moved the Pi’s location to another part of the same room and then it connected. Ran a ping loop and the response time is pretty steady at 2ms, but there are bouts of 14-15ms then back to 2ms. Previously it was a rock solid 2ms. (Running a dedicated 5GHz SSID).

The original location has been working fabulously and suddenly not so much after the upgrade. I’d like to roll back from 2022.05.1 to 2022.05 just to see if the issues remains or improves with that previous rev. How can I download 2022.05 to flash and compare to 2022.05.1?

Also – here’s the unique identifier: af4fe01f9d2660e5

Thanks and keep up the awesome work, @spockfish !!

Richard

@spockfish
Hi Harry,
Thank you for the new release.
But haven’t you said a while ago that from then on, updates would be done automatically?
But I still have to do them manually. Not that this is a big issue, but I just want to know if I am doing something wrong.
Kind regards, Frank.

It is an option (‘Auto Update’) that you need to enable on the ‘advanced’ tab.

Thanks

But the option is enabled.
The update Chanel is “Stable”.
Perhaps I have to reboot the RPI after it knows an update is available.
I’ll try that next time.
Thank you for the quick response.

Have you enabled a reboot interval?

Because that is required for the auto update to work.

I knew that I did something wrong!
That is the reason. I’ll put a reboot interval.
Kind regards, Frank.

In my case, manual reboots did not trigger the update — is it only activated upon scheduled reboot?

Also, for some strange reason the Alarm Clock got very confused and started up at 02:45am on a Saturday even though the display shows the correct date / time and the alarm is still set to weekdays 06:45. I just checked the settings of the extension in Roon, and the time zone seems correct (PDT). I am not sure what is going on. 4bda29c06aa509c9 in case the issue is interesting or indicative of some other problem.

Thanks Harry as always.

Yes it is. This is because the update itself takes considerable time and sometimes you just want to ‘quickly reboot’. Hence the connection with a scheduled reboot.

Maybe the user should be asked about it.

Thanks

In my case I was simply being lazy—it is faster to trigger 7 reboots than to navigate to 7 web gui and manually trigger the updates. Definitely an edge case, and not really a problem at all.

1 Like

One possibility would be to change the option to “Auto Update After Reboot”. If someone wants a quick reboot, simply turn that option off. And, if on, any reboot will complete the update process.

Update to my post above…

It turns out that even though it is pingable and shows up as a wireless connected device on my router, it is not available as a ZONE in Roon. I’m going to try manually re-flashing to 2022.5.1 and see if maybe it is just a borked update process.

Reinstalled 2022.5.1 and web interface and ping were a-OK. Not showing up in Roon, however. Started poking around a bit and found it. For some reason that device/zone became DISABLED and was not showing up in my ZONE selection list. There were no hardware changes and that’s never happened to me with a minor upgrade via OTA before, but after looking at Roon SETTINGS/AUDIO, there it was. Feeling a bit like a dumba**.

Time for tunes and a cocktail!! :smiley:

3 Likes

I could observe the same issue after upgrading to 2022.05.1 as well, took a while to figure it out. :sweat_smile:

Hi, I have four RopieeeXL endpoints on my network. All are running on Pi 4 4 GB devices. Three of the four automatically upgraded to 2022.05.1. However, one of them seems to be stuck on 2022.04. Since the are all the same hardware, I would think all four should update. Is there a reason why the fourth Pi 4 won’t update?

I’ve tried rebooting, but the message to upgrade does not come up.

Thanks!

I have two RPi4’s. The one that stays connected and on 24/7 was showing the available update when I went into the RoPieeeXL program. The other one, that does not stay connected and on, took a couple hours after I connected it to see the update.

Thanks…all four on my network are on and connected all the time…so weird!

My infrastructure has a hard time when an update becomes available.
So yeah, it can take a few hours before things show up.

If that still didn’t happen could you send me feedback of that unit? So I can have a look?

Thanks