Release RoPieee 2022.05

It’s that time again… a new release!

Stuff all over the place, but 2 things stand out:

XL services were not working properly with HAT’s that support hardware volume control. This slipped through last time, but that’s now fixed. And a long standing wish from quite some users… the possibility to name the XL services.

Here’s the complete changelog:

  • NEW: support for the Mediatek MT7612U Wireless adapter
  • NEW: make XL service names configurable
  • IMPROV: update base packages
  • IMPROV: add fallback for naming of external WiFi adapters (USB)
  • IMPROV: bump Linux kernel
  • IMPROV: increase ‘phone home’ interval
  • FIX: ‘fancy name’ of XL services don’t follow hostname change
  • FIX: XL services do not follow hardware mixer setting

As always, enjoy!


This I think is now fixed…

Thank you for your ongoing effort to improve RoPieee!


Because never said from my side:
Thank you spockfish for Ropieee, with which I’d never a problem and used at the moment for three endpoints.

I have updated my perfectly working ropiie 4.017 by flashing the new ISO. The “new” ropiie 2022.05 got another IP and appears properly in the “About” section of Roon but not as Audio device.
(ROCK, Windows, everything on 1.8 (943), done all kind of rebooting, web interface works etc.)

Have you enabled it in the ‘Audio’ section?

The ropiie doesn’t appear at all in the “Settings/Audio” Section of Roon, so I cannot enable it. But it appears in the “Settings/About” section.

Have you tried restarting your Roon server?

Yes, I said all that in the intial post: Visibel in “about”, not visibile in “audio”, all system updated, rebooted (Nuc and Roon and Raspi etc.)

Can you send me feedback (it’s on the advanced tab)?

Just to be sure: you have audio enabled? So either a HAT configured or an USB DAC connected (and powered on)?

1 Like

As Harry explained to me, this seems to be a bug in the HifiBerry HAT Digi2 Pro:

My Raspberry Pi 3 Model B Plus Rev 1.3 with Ropieee 2022.04 rebooted and updated automatically to .5. This has never happened before, I have always had to push the update button to do it.

Furthermore, Ropieee disappared from Roon, it is not visible in Audio, nor in About settings. I have restarted Core and have reinstalled Roon bridge, still nothing. HAT is Allo Digione Signatute. Feedback: 3f5b8c2717f610e9.

AirPlay to Ropieee works ok.

Has anyone tested support for Multi channel procedural audio routing?
This function hasn’t been working via my Motu Mk5 Lite on previous Ropiee releases.
The Motu is class compliant and works perfectly on Ubuntu/Roon Bridge.

1 Like

Evening all, just been updating my Pi Zero 2W from old Ropieee to NG. I’ve got it running so I can adjust the setup pages through the browser via usb ethernet and then added the WiFi details. It connects via WiFi as I can see it on the mesh router page, but for some reason it generates a null ip address and I can’t therefore access it via the browser nor see it in Roon. What really obvious and stupid thing am I doing wrong?? I’ve got 5 Ropieee end points set up and they are fantastic, but this was is thwarting me!

This is fantastic Harry thanks.
Great to see the configurable service names!
Another donation made for this feature alone :wink:

1 Like

Anybody got a 4.0x ISO somewhere they could share somehow? This worked with my HAT Digi2 Pro fine on my Raspi 4.

@spockfish I’m having the same problem as @bassman with my Pi Zero 2W. I just did the upgrade but can’t access it via the web browser.

Can you send me feedback? You can find that option on the ‘advanced’ tab.



Anyone else experiencing an issue where there’s white noise overlaying track when going from example 16/44 to 24/96 tracks in a playlist.

Seems to have started with either the latest Ropieee or Roon update. I have a Stack Audio Link II, which has an older version of Ropieee XL that works perfectly fine, no such issue.

Tried re-flashing latest ISO of Ropieee, tried different board/cards, same thing. Tried VitOS (out of frustration) on same Raspberry Pi board and it works fine, no issue. So seems to be isolated to Ropieee.

Edit: - Feedback Log f35ff68f4167bad8

Harry, feedback is 00089d46a7c86810


It seems that the WiFi interface is not coming up.
Configuration looks fine. Could be related to a firmware update… Looking into this.

Regards Harry

1 Like