Release RoPieee 2022.06.4

Hi there! Just updated to this build yesterday, and I must have been behind as after the update went through I had to manually install the latest version of RoPieee on my SD card. A few (hopefully basic) questions as I want to be sure I did everything correct:

  1. Why did it have me manually update now? Should I have done this a while ago? As of yesterday I was running Software Version: 4.020 and today (after the manual update) I am running “RoPieee 2022.06.4 (0458)”. Does that seem correct?

  2. I am noticing on the ‘Information’ page that I no longer have the ‘USB FW Version’ row. Does that seem correct? I am running a Schiit Modius DAC via the USB Port on my Raspberry Pi4 V1.2. I know there used to be updates every now and then associated with that row–is this now just built into the general updates?

  3. The light on my Pi is still blinking. Not the power light, the update light. It’s a steady blink, nothing rapid. Is there an update going on in the background?

  4. With all this said, everything seems to be running great–I’m always a little nervous with these manual uploads. When streaming via Roon my Pi’s temperature is between 60 and 63 (Celsius). Does that seem ok? I believe it was similar prior to the manual update, but just figured I would verify that.

Hi Brendon,

RoPieee has a new architecture: I used to use an existing Linux distribution that I highly tweaked. This was a maintenance burden however, so I rewrote the hole thing. This new version is a custom built, minimal Linux appliance. All nice and shiny, but it meant a single, manual update. From now on you will get updates via the UI as you were used to.

Yeah… this feature got lost in translation :wink: But jokes aside, I haven’t seen PI 4 firmware updates for the controller chip. I’ll add a TODO to my list though to check the status on this and if we need this feature still.

There is no update led, the steady blink means RoPieee ‘is up and running and everything is fine’.

Yep, you’re good to go and in the safe zone wrt temperature.



I have now updated both RPi4’s with no issues.

@spockfish I have just updated a Raspberry Pi 4 Model B Rev 1.4 to 2022.06.4 (0458) from 2022.03 (126). This device was previously connected by native Raspberry Pi wifi and was working perfectly. After the upgrade Roon does not see this device using either wifi or ethernet. Using both wifi and ethernet I can see the device in the Ropieee devices list and can ping it on my network (reply time: 1ms avg for wifi, < 1ms for ethernet) so at first guess I do not believe it is my network. I have rebooted both my Roon core (a NUC 10 running Version 1.8 build 988) and the Raspberry Pi numerous times with both wifi and ethernet connections enabled. Roon still does not see the device.

Any suggestions?

Maybe you need to reflash the card. Something could have gotten corrupted.

@Jim_F I reflashed the card as part of the upgrade.

Are you sure? That’s not part of the normal upgrade process. I’m talking about downloading the file to your computer and using Etcher to flash the card. Then put the card back in the RPi.

@Jim_F I clicked on this link:

and it updated the client to a different version (I unfortunately do not recall what that was. Possibly 2020.04.x? I’m not sure). Roon could not find the end point with that version either so, recalling there were some wifi issues with earlier releases, I downloaded 2020.06.4 from and flashed it to my SD card using Etcher and re-installed on the RPi. That upgrade seemed to complete correctly and, as stated, I can see that client in my network and devices list (it is the studio device):

I have also done this on several previous occasions when I think things might have become corrupted and Roon has so far always found the device using both ethernet and wifi.

So I am not sure what is happening this time.

OK, we will have to wait for Harry to respond.

Can you double check in the Roon app - settings / audio that the device is enabled?

Can you send me feedback?

Harry thank You for creating such a wonderful solution for us all. I have four of these in my world are they are brilliant!

It’s always those people who have never created anything who are the loudest. Those who can do and those who can’t are just users

@spockfish feedback sent - 22ccfc119bbb1979


So you don’t have a HAT configured and I also don’t see an USB DAC attached (and powered on).
Hence no audio output and a ‘no show’ in Roon.


1 Like

@spockfish So that is embarrassing in a public forum! You are correct Harry: no HAT and no DAC, so no show in Roon.

I have this device connected via USB to a McIntosh amp with integrated DAC and forgot to turn the amp on after I upgraded the Roon bridge. :grimacing:

Of course, it works perfectly now that I have re-acquainted myself with the amp’s power switch. Many apologies for wasting your time, Harry.


Haha! No worries. Glad you sorted it out and can enjoy some music.

Regards Harry

1 Like

Hi there!

I installed a new router and went to the Ropieee page. It directed me to download and install a new version, which was 2022.6.4. Prior, I was using what looks like (in Roon) version 1.8, build 943.

I flashed using Balena and this seemed to go ok, although my Mac said the disk was not readable. I inserted into my Rpi, and now the green light blinks every second but Roon says that there was an error checking for an update. If I try to play using the Rpi, it no longer shows up as an endpoint via ethernet or in Roon (except for airplay). I’m sure I did something wrong, but any help would be most appreciated!!



You’re mixing up 2 things: the Roon version (1.8) and RoPieee’s version (2022.06.4). Those are independant.

That’s correct, your Mac can’t read RoPieee’s disk format.

Roon’s message about the update is totally not related to RoPieee. Have you checked RoPieee’s webpage?

The flashing green led means that your RoPieee unit is back on working.

Not having a sound is probably because you did not enable the device (zone) in Roon’s audio settings. Remember, you reflashed so Roon does not ‘know’ this device yet.

Good luck!


Harry, thanks. A reboot of the Hifiberry solved everything, along with re-enabling RoPieeee in Roon. So, sigh, user error.

Sorry to take your time and thanks for all you do!!!


Most people post about problems they are having, nothing wrong with that all a community to help.

I thought I’d post a smooth and successful installation of 2022.06.4 on a PI4 in to a miniDSP Flex. Really easy installation and it all worked first time. Thank you Harry, donation in the post.