Release RoPieee 2023.04.1


Can you send me feedback?
So after you plugged in the ethernet cable and you have connection:

do not reboot but send me feedback.


unfortunately, now the issue is gone so far. I will observe the topic and will send you the requested feedback as soon as the problem will appear again.

Thank you for your support!
Best regards!

Hi Harry, just some cosmetic issue, one of my PI4 (with Allo HAT) shows this funny status, which shows the previous version too, althought it had been updated correctly…If I look from the other PI4, this does not show, only two correct entries.

Hello Harry,
this morning the issue was back again.
I just plugged in the Ethernet cable and sent you the feedback logs (ID: 166c0df7a4b16c01) without any configuration change or reboot.

For WLAN re-activation it is necessary to do a change on the Network-Wireless page, which results in a configuration write e.g. disable and re-enable the Wireless.

I hope this helps you to narrow down the root cause.

Many thanks an best regards!

Weird. What actually happens is that your wireless connection disconnects on a regular basis. So not only during the night, but straight from the start.

Could you test with a different network?

I’ve had an issue with last couple of upgrades (to 2023.04 and 2023.04.1) in that it fails to complete the upgrade on WiFi. After the restart it fails to connect back to the previously configured WiFi SSID, necessitating connecting to Ethernet and powering off & on. The upgrade then finishes, the Ethernet can be disconnected and the Pi rebooted.

I suspect it may be something to do with the WiFi channels and country/region code (AU/NZ)

Feedback 1e9a0582cd25303c

Just got round to updating not done it in a while. Love the new zone switching for the remote screen, well done Harry.


It has nothing to do with the WiFi channels…

The unit reports a failure writing to the SD card, which results in the network configuration not saved. Strange thing is that when you do this manually it works…

I also see a ‘undervoltage’ message a few times.

Hi Harry,
got a PI3 with Display to install another ROPIEEE display for another room.
Download the latest PI3 ROPIEEE version, etched it on the SD-card, booted and installed ROPIEEE 2023.4.1 [2023.04.1 (0932) [stable]
It worked so far and the now black ROPIEEE logo appeared.

Then I set the Room Name in that PI3, booted again - but unfortunately no connection to ROON?? [I have a PI4 running with Display and that works very well…] The display says CONNECTION FAILURE - but roon IS RUNNING and the Control Extension is of course installed (as works with my other PI4 Display)

Please have a look what happens here when you find time to:

The zone name must match exactly what the setting in ropieee is.

I know, it was copy/paste. Did that with my other PI4 Display and worked right away. No special signs in it just “Music Room”…

Did you enable / pair in Roon extensions?

ehemm, yep had only ONE display enabled, guess that was it…

Yep, works!!!

Thanks for the helping hands!! :wink:

1 Like

I was able to connect to a different network, which is also switched off over night.
The same behaviour. In the morning, there is no WLAN connection available.
Please have a look to the log feedback I sent you (ID f202042a6988afa3).
Best regards!

I have several PI4 and all with this 945 version running well. And I have a PI3 with Display which I also updated to the current 932.
If I click on devives of the PI4s, I ONLY see the PI4 devices, not the PI3.
When I click on devices on the PI3 I see all PI3 + PI4 devices (??) - is this normal??
They are all on the very same network…

In general it is not normal :wink: This functionality however, depends on multicast DNS which is not always 100% reliable because of network topology etc.

Keep also in mind that what you see on the devices tab is not realtime: it is updated every 5 minutes. This means that, depending on a reboot or something like that, it can take a few minutes before devices show up.


OK Harry, that was it, not it is visible after some time!

1 Like

Hello harry,

since two days I went back to 2023.02.1 an with this version the RoPieee setup again works fine with my Network configuration. The WLAN is switched of in the night and in the next morning the RoPieee system is back again on WLAN.
Unfortunately with 2023.04.1 the re-connection in the following morning will not happen.

Best regards