Remote connection issues

Was there ever a definitive diagnosis of this issue? I was reluctant to start another thread, if this has been solved.

I recently installed a new core on an [2011] iMac. I was initially concerned the iMac was not up to the task but it ran fine for about 4 weeks with a local hard drive music library of about 50GB. Remotes connect on a local network of eero access points. I had two [2017] iPad Pros and an [2016] Android phone as remotes and all was well. I could use 2-3 music zones.

My partner came back after a trip and I set up her iPhone 6 as a remote, to demo Roon’s amazing abilities. Soon after, all remote connections stopped working. It is difficult not to associate the two events! I restarted the iMac and its Roon core and one iPad Pro connected remotely, for a short while, but then stopped again.

Any suggestions? I have another machine that I could use for the core, if there is a chance it needs more power.

I am seeing this too, after Roon ran fine for about 3 weeks. None of my remotes [iPads, Android phone, iPhone] are connecting. I have a Roon core running on an iMac or a Windows 10 Lenovo machine. The core machines will play music OK.

Having remote control is pretty darned important!

This is exactly how I was using the iMac: nothing else to do. Roon uses 5-20% of CPU and 800MB of RAM, so the Mac is not being taxed. I installed the core on a more recent PC for comparison and it has the same issues.

All machines are on the same subnet and all have good wifi access.

  • This is Roon 1.6 [build 416) on an iMac (10,1) with MacOS 10.12.6
    Remotes are:
  • 2017 10.5" iPad Pro
  • 2017 12.9" iPad Pro
  • OnePlus 3 Android phone
  • iPhone 6
  • Lenovo X1 [Windows10] tablet

Hi @Lee_Hammond,

I have moved your posts into this thread so that I can better assist you here. Starting off, I would confirm that Roon is added as an exception to your Mac and Windows Firewalls, link to Mac Firewall instructions can be found here and Windows Firewall can be found here. The path to Roon.exe and RAATServer.exe on Windows can be found by navigating to the Database Location/Application path. If you are using any antivirus firewalls, I would also add these exceptions there.

Next, let’s take a look at the way that the Cores are connected. Are they using WiFi or Ethernet to the Eero’s? Is there any change if you connect the Core to the Eero via Ethernet? Are the remotes on the same subnet as the Core and not by any chance connected to a “guest network” of sorts? What if you try connecting both the iMac and the PC to the Eero via Ethernet and use one of the computers as a Core and the other as a Remote, does the connection remain stable in that way?

Thanks for the reply. No firewalls were in operation, so I figured it it had to be a wifi or bandwidth issue.

I connected the iMac, with the Roon core, directly to a switch by ethernet cable, together with a PC acting as remote, also by ethernet cable. Core connection was fine. Next, I connected them to an eero, again both with cables. Connection was instantaneous. I next removed the PC remote cable and connected to the eero by wifi; and it is working fine now.

All remotes are now working again. It is a bit puzzling [to me] that they had been working as installed and then they stopped! Anyway, with the iMac connected by cable, all remotes can see the core again.

Thanks for the assistance and suggestions.

Hi @Lee_Hammond,

Thanks for the update here and glad to hear that the issue is resolved (even if the solution was a bit puzzling). I am not quite sure what triggered the different behavior but it seems that after getting the new IP address that the Core is now properly communicating. If you have any further issue please do reach out to us again, I will go ahead and mark this thread as [solved] for the time being. Thanks!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.