"Remote Connection: Waiting for Remote Core" after update to One UI 2 Android 10 + Security Patch Jul-2020 Release 1

Core Machine (Operating system/System info/Roon build number)

Version 1.0 (build 227) stable; Version 1.7 (build 610) stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
NUC7i7BNH roon rock on Ethernet to TPLink Router. Router to TPLink AP500 (WiFi used for remotes only)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Sonos Connectors (3)–Ethernet to USB to DACs to Audio devices
NUC roon rock USB direct to DAC also

Description Of Issue

My Samsung Galaxy Tab A 10.5 (model: SM-T590) Android 10 was working as a remote without any issues. The tablet updated itself to One UI 2 Android 10 with latest security software version Jul-2020 Release 1, Android security patch level 1 July 2020.

Now the tablet hangs on "Remote Connection: Waiting for Remote Core. . . . " The tablet can access everything else on the LAN and Internet.

I uninstalled and reinstalled the roon labs remote application, and the tablet still hangs trying make the Remote Connection. What else changed? Nothing else changed.

Both my old Moto G mobile device and Windows 7 desktop OS can remote access and use roon without issues.

All network switches, the router, Wi-Fi access points, and core server were “cold” booted. The Android roon labs remote application was uninstalled and reinstalled several times, ending with the same hanging "Remote Connection Waiting for Remote Core . . . " issue.

The core shows the SM-T590 Tablet A, but the Tablet cannot connect remotely


Hello @racingdriver, and thanks for your report! On the waiting for your core screen, you should have a “help” option that will allow you to enter the core’s IP address. Could you please try the core’s IP, or enter and see if that helps get you connected?

Hello nuwriy
On the Tablet and in roon I managed to navigate to the dialog box that would allow me to provide the IP address. The application searched for a long time. So, I killed the application and restarted. The application connected the remote to the core.

I decided to exit the application and try again. The roon application on the Tablet hung again, “Remote Connection Waiting form Remote Core . . . .” Selected “Select a different core” and the application hung “Looking for you Roon Core.” Selected “Help” and received the same dialog box for the IP address, entered the address again, and it hung “Looking for your Roon Core.”

Went through the same process, but entered the address. The remote application discovered the ROCK with a connect button. Selecting the Connect button worked and I connected to the ROCK. I was able to control the roon functions.

Exited the application again. The application hung again, but after a minute it connected. For comparison I tried connecting with my Moto G (ancient) using the same WiFi spectrum . . . no issues, because it connects immediately.

I am 3 feet from the access point with both the Moto G3 and the Tablet A devices, and don’t know what to make of it. :slight_smile: Odd.



Now, I am having the same connectivity issue on the Moto G remote also . . . “Looking for your Roon Core.”

The Moto G works on 2.5Ghz and the Tablet A works on a 2.5/5Ghz channels.

Now, sometimes when I try connecting to the ROCK I must navigate to the dialog box that allows me to enter an address. Occasionally, the connection is relatively quick.

What next?


Hello @racingdriver, and thanks for testing that! I’m glad that 255 worked for you! Roon relies on a working multicast network for the devices to communicate with the Core. If multicast isn’t working properly on this network with this device, standard discovery isn’t going to work. We continue to investigate how we can improve discovery functionality in Roon to make it easier for environments like this to function, but the immediate solution would be to investigate what is causing multicast traffic to not work properly on the network with this device.

Thanks, Nuwriy.
Ah ha! Multicast makes a lot of sense for a streaming audio and video distribution to multiple recipients simultaneously. I suspect that it reduces sync/latency issues, when distributing to multiple nodes, aka roon endpoints. I have three endpoints.

I am open to testing and providing logs.


I just checked the TP-Link TL-R600VPN documentation, and it does not appear to support multicast.
Well at this point there is not a setting for enabling.

Hello @racingdriver, I took a look online as well for this router and came to the same conclusion. We’re looking to make improvements to this aspect of the program in the future, but for now, I’d use the 255 workaround.

Thx :grinning:

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.