Remote connectivity issues - Samsung Tablet & Phone [Resolved]

I finally purchased the $119 Roon program and had my Roon system up and running perfectly. It consisted of Roon Bridge installed on my Rasberry Pi 3 and Roon Server installed on my Windows 10 laptop. I didn’t listen to it for a couple of weeks due to spring gardening and spring house cleaning that was way overdue. When I turned everything on this AM for a listening session my Roon Remote app on my Galaxytab 3 tablet could not find the Roon server. I tried a couple of reboots on both the tablet and the laptop to no avail. Any idea what happened and how to fix it.

Hi @William_Saimond ---- Thank you for the report and sharing your observations with us. Sorry to hear of the troubles.

To help aide in my evaluation of this behavior you are reporting may I kindly ask you to please provide me with the following:

  1. Can you confirm that all devices are up to date with the latest build?

  2. Have you tried reinstalling the remote application on the Galaxy tablet?

  3. Have you tried power cycling any of your networking hardware yet?

  4. If you have Roon remote installed on any other devices are they experiencing the same behavior?


All devices are up to date with the latest build.
I reinstalled the Roon Remote app on my Samsung GalxyTab 4 tablet twice.
I did a hard start on my modem router.
I have the same problem using Roon Remote on my Samsung cell phone.

I also uninstalled and reinstalled Roon Server on my laptop and reinstalled Roon Bridge on my Rasberry Pi 3.

Hi @William_Saimond ----- Thank you for taking the time to answer my questions, the insight is greatly appreciated!

Moving forward, can you provide me with the details of your network configuration/topology as well as providing insight into any networking hardware you are implementing. I want to have a clear understanding of what the chain of communication looks and the links that comprise that chain.


Can you give me a lot more detail as to exactly what you are looking for and where on my windows 10 laptop I can access it?

Just found out that my Windows 10 on my laptop was updated to version 1607 a couple of days ago. could this be the problem?

Hi @William_Saimond ---- Sorry for the confusion, please allow me to elaborate.

When I asked about your network configuration/topology I am looking to better understand of how your devices are communicating across your network. What is using Wifi? What is using hardwired connection? A very basic example would resemble something like this:

Router - > Wifi - > Roon Core - > USB - > DAC

Your networking hardware would make up the links, these device would include: router(s), switches, repeaters, extenders, powerline adaptors.

Moving forward, we have seen issues with automated Windows updates in the past and while I can’t confirm that this is the case here it is indeed a plausible theory. Before we start looking into rolling the update back, can you confirm that the Win10 laptop has no active firewalls or antivirus application in place. If it does, can you please temporarily bring them down and see if there is a change in behavior?


Modem/Router - > Wifi -> Roon Server on Windows 10 laptop - > Roon Bridge on Rasberry Pi 3 - > USB - > Meridian Explorer 2 DAC


Modem/Router - > Ethernet - > Rasberry Pi 3

I have all my firewalls turned off for now which did not correct the problem

Oh, I forgot, the Ethernet to the Rasberry Pi 3 is thru an ethernet switch.

One suggestion would be to verify that the phone/tablet is still on the same network subnet as the laptop.

1 Like

Thank you for providing the requested information @William_Saimond, the feedback is appreciated!

I am going to piggyback on Daniel’s (@Rugby :thumbsup:) suggestion, in regard to confirming that the devices are indeed on the same subnet as the laptop hosting your Roon core. You can load an application like Fing on to one of those devices (phone or tablet) to scan your network in order to look for other devices that it can see, it will also show the device hosting the application in the process.


Hi Eric, I fixed the problem by uninstalling, then reinstalling Roon Server on my updated Windows 10 laptop. Somehow the automatic Windows 10 update must have corrupted the Roon Server application.
Thanks so much for your help. I’m really pleased how swiftly you jumped in to help.

1 Like