Remote connects/disconnects (iPhone 7 / iPad pro) after switching core machines [Resolved]

Hi everyone… this my first post, so apologies for newbie/idiotic questions when they appear, which they will…

Switched Core yesterday from mac mini (mid’11) to MB pro (mid’15), installed Bridge on Mac mini. Everything perfect except remote apps (iPhone 7 / iPad pro) keep dropping out…

Have done the basics (as suggested in troubleshooting & trawling the community but no luck)

Advice very welcome…thank you!

1 Like

Hi @PatrickS ----- Thank you for the report and sharing your feedback with us!

Moving forward, to help us get a better understanding as to why the mentioned remotes are having stability issues in your setup. May I very kindly ask you for the following:

  • You had mentioned that you have performed some troubleshooting exercises based on information you’ve come across on the community site. In the interest of not repeating anything you may have tried already :innocent:, could you please provide some insight into what tests you have already performed.

  • Please confirm if one (or both) of the following tests, trigger a change with your remotes:

TEST #1:

  1. Shut down your Core
  2. Open Roon on your Remote
    (Tip: If you are using a phone, make sure you keep it awake)
  3. Roon should be on the “Searching For Core” screen
  4. Start up the Core

TEST #2:

  1. Start up your Core
  2. Open Roon on your Remote
    (Tip: If you are using a phone, make sure you keep it awake)
  3. Kill the Roon app
    (Tip: If you are using Android please go to Settings > Apps > Roon > Force Stop)
  4. Restart Roon on on your Remote


Hi Eric, thanks for getting back to me.

Test 1 didn’t resolve the issue
Test 2 did sort of, but frequent disconnect persists

Core (latest version) installed on MB Pro (mid '15, 2.2g i7, 16gb, 250g flash)
approx 13k tracks (ext hd 512g flash)

Remote installed on ip7/ipad pro

Bridge installed on Mac mini (mid '11) for streaming to stereo

Remote deleted and reinstalled several times, no luck.

That’s all i have for you, would be good to have further ideas… enjoying the Roon experience very much, great job, thanks!


Hi @PatrickS ---- Thank you for the providing the requested feedback and giving the proposed tests a go. Having a sense of what you’ve tried thus far is very helpful.

Ok so you’ve tried to reinstall the application on both remote devices already, that’s a good first step :thumbsup: The two tests mentioned above involve rebooting the device hosting your core, but since noticing this behavior have you tried rebooting your networking hardware as well? This would include your router and any other pertinent devices (switches, etc).

Furthermore, when the devices do disconnect from the core, if you were to manually enter the IP address of the core machine on them, do they re-establish a connection?

Lastly, can you please provide me with the details of your network configuration/topology, being sure to provide insight into any network hardware you are currently implementing. I want to have a clear understanding of how your devices are communicating and the tools being utilized to make these connections possible. Also, are you making use of any firewalls or antivirus applications currently in your setup?


Hi Eric,

Remote is working fine now. Here’s what I did:

  • general reboot of everything (laptop, mini, router, remotes)

  • firewall is on but permissions allowed for all ROON, Bridge Helper, RAATServer

Thanks for your help, all good


1 Like