Remote Control not working anymore

Thank you @spockfish for the amazing work! What you did with RoPieee is truly amazing.

I have an issue with the remote control.
At some point I managed to make it work for a brief instant, then never again.
I have been tearing my hair out ever since, with no luck…
I tried with both Flirc (1st gen) and OSMC.

I double/triple-checked:

  • the remote control batteries are ok
  • the remote control work on my computer
  • Flirc is configured for “Media keys”
  • Extension is up and running on RPi,
  • Extension is enabled on roon core server
  • rp_remote_control_zone matches exactly the zone name
  • I tried to change zone name to other names
  • I rebooted RPi several times
  • I rebooted roon core several times
  • I re-flashed the RPi twice
  • I checked that my roon core is up to date (version 1.7, build 610 stable, on Ubuntu 20.04)
  • RoPiee is up to date (2.573 / version 1.7, build 571 stable)
    …but it still doesn’t work.

I sent you feedback:

  • Feedback with Flirc: 40b3865042ff7d42
  • Feedback with OSMC: bbe64e5b316f57a5

Is there a way for me to debug that myself?
Where/how can I get logs from /usr/bin/node /opt/RoPieee/remotectl/app.js ?


I eventually had it work! (For now… :crossed_fingers:t2:)
I don’t know if that’s the real reason but what seems to do the trick was replacing the power adapter (old one was 2.4A, new one is 3A).
In case @spockfish wants to have a look, here is a feedback when it does work: a2a567f67a05bf62