Remote control (Roon on MBPro) doesn't work [Resolved]

I have Core on an iMac that’s wired to the LAN. On my MBPro I have Roon installed as a remote. It’s connected by a strong WiFi to the LAN. Roon on my MBPro shows the database (I can browse the albums) but I cnnot control the core as RoonRemote complains about a missing AudioDevice. Simultaneously the core plays music nicely with no complaint.

That shouldd be easy to tackle, please help.

Both machines are on OS 10.11.6

I should add that Apple’s Firewall is enabled in both machines and Roon etc is allowed to accept incoming connection. Equally, in Little Snitch, both are set up to allow outgoing connections.

Can you post a screenshot of your Settings > Audio tab on the MBPro?

Are you clicking the Zone Picker on the bottom right of the screen, next to the volume icon, on the MBPro and selecting the correct Zone?

Cheers, Greg

Here is a screenshot of the audio settings on the remote Roon.
The other one is the bottom of the main window where there is no volume control and no zone button.

Are you allowing RAATServer through your firewall?

Cheers, Greg

Yes, as I said, on both machines, everything is open for Raatserver and RAAT

Ok, let’s flag @support for help.

Cheers, Greg

1 Like

Hi @WKW ---- Thank you for the report and my apologies for the troubles here. May I kindly ask you to verify the following for me to help aide in my understanding of this issue.

  1. My assumption is that you have not always had this problem controlling your Roon core on your iMAC from your MBP. Have there been any changes to your setup since you made this observation?

  2. Have you tested with a wired connection to the LAN on the MBP?

  3. Have you tried reinstalling the remote application on the MBP?

  4. If you were to (temporarily, as a test) make the MBP act the core and have the iMac act as a remote, are you able to control the MB core?


(1) Yes it worked before even though I don’t remember the date of the last time it worked. One change may have been the supplemental Security Update (2016-003) that Apple issued. Of course on and off there is new software being installed or removed.

(2) I did now and it is the same symptoms as with WiFi. It connects to the core and I can browse the library, it even suggests discoveries, but I dont see what’s playing and there is the ‘stupid’ question for selecting a zone.

(3) I did, even after uninstalling all related files and .prefs

(4) Sorry, I don’t want to do this because I don’t want to get into a completely new install of everyhing on my main machine.

Hi @WKW ---- Thank you for the follow up and taking the time to answer my questions. Both are appreciated. Before I ask to gather some logs from you, I would kindly like to ask you to verify something for me.

The iMac you are trying to control from your MBP, does it have a DAC or any other device attached to it that you are trying to use for playback OR are you trying to play out of it’s internal sound card?


Hi Eric,

the sound card setup is the following:

Roon reading from iTunes media>music folder

Dirac Audio Processor stereo (set as Zone)
Devialet AIR3
into Devialet 800

I have this setup now for more than a year and Roon remote has worked with it. Let me add that Roon for iOS doesn’t work either.

Hi, seeing the flood of new posts, I am glad to report that my MBP does now recognize the core on my desktop (both running Roon 2.3). It may have been that private zone was enabled on the core, or maybe not. Anyway it works.

Anyway, my iOS iPad doesn’t work yet at all even with the latest app. I hope there’ll be a solution soon.

OK, solved finally. On the iPd I hd to sign in to the account again.

At present having fun with 2.3