Remote on Android can't find ROCK

Core Machine (Operating system/System info/Roon build number)
latest ROCK

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
FIOS router. Ethernet connection to ROCK

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

Too often my remote on Android cannot find my Roon core (ROCK). It gives various errors from simply searching forever to saying it must be on the same wifi network.

I believe this is likely a Roon client issue for the following reasons:

  1. It happened on two different android tablets
  2. All my apple devices (phone, computer) work perfectly
  3. When it “cannot find” or “has no wifi connectivity” the very same device, can find the ROCK admin web page via the browser. So this proves the error message is wrong.

The device in question is a brand new Amazon Fire 8 bought expressly to be a remote.

Other device was an old verizon tablet no longer supported.


When it can’t find the core, try using the IP address option, and use the following IP:

That has resolved the issue for some.

Hi @Just_Me,

You can try the IP address option @Rugby mentioned, but just so that you are aware, using ISP-provided routers is not recommended as mentioned in our Networking Best Practices Guide as we have often seen ISP equipment not pass multicast traffic through properly.

to both support and Rugby.

  1. Thanks for the suggestion
  2. I take it this is somewhat common?
  3. Many of us have no choice as to ISP provided equipment since the TV guide is tied to it, and if we hack it, support vanishes
  4. Iphones and macs, not to mention windows machines, have no issue. So i exonerate the router. Since browsers can find it easily, i exonerate the android device itself’s wifi performance.

so that leaves the big question:
5. “what do i do with the IP address you suggest?” - enter it exactly it where? I see no screen or facility to do so.

thanks in advance,


Hi @Just_Me,

Navigating to the WebUI doesn’t necessarily mean that multicast works as expected on your Android devices. These are two different types of communication, so it is still possible that there is a multicast issue somewhere along the line.

You can try entering the IP Address of the Core or ` after pressing “Help” on the “Choose your Core” screen.

I’ll try that. The core always seems to be blah.163 seems better to just enter that.

This needs to happen every time or will it cache and remember?


Hi @Just_me,

I’m not entirely sure since I haven’t had to use this work-around before. The more important thing to note here is if this workaround does indeed work, then it could point us in the right direction towards finding the root cause.

Do let me know if it works (even once), as this would be a great data point to have.

Will do. In the spirit of watched pots not boiling, it is currently behaving itself…

But when i catch it I’ll be sure to report back.


I’ve had to use the workaround once. The device has been more than rock solid every since. (pun intended).

On android or iOS?

Android. However, others on the forums who use iOS have used it as well.

I had two incidents where my android roon remote failed to find the ROCK. The first time i put in Didn’t work, but honestly i was rushed. The 2nd time i used 255.x4. This appeared to work, but then, sometimes it just works anyway after a small, or huge, delay. I will continue to report back. Even odder, it began by saying “you must be connected to a network”. Meanwhile Silk is loading pages and Outlook emails – so obviously it WAS connected to a wifi network. Still looks like a Roon remote for android networking bug either internal or in how it communicates with the android stack.

Hi @Just_Me,

If you force-quit the Roon app and re-start it without putting in the IP address, is there any change in behavior?

I’ll try to test it, but i doubt we will learn anything. The reason is 1) its inconsistent so it wont prove much, and 2) once it locks onto a server it tends to be fine, until , well, i dont know what the trigger is. but it will work fine for hours. But I’ll test the hard start this morning. In fact I will:

a) try it before hard-restart of the app (not of the android)
b) after


OK, i tested it.

  1. woke android, connected immediately to Roon
  2. “right swiped” roon to close it on android
  3. Restarted Roon remote from home page
  4. asked “lost connection, connect to a new roon server?”
  5. Yes
  6. Found ROCK
  7. Connected reasonably quickly

So i’m not sure what that proves give that a) it worked before restart and b) it worked after restart, albeit finding a “new” core.


Hi @Just_Me,

Thanks for doing that test, but I don’t think I’ll provide the necessary info. The test I was referring to was:

  • Next time you are in the state where the Roon App can’t discover the Core automatically, please try force-closing and opening the Roon app again (without specifying the manual IP). If you reboot just the Roon app, does that help you get out of this state and connected to the Core again?

I’m confused. Be specific on how to force close. I thought i did.

As to whether its useful, i agree. But i did exactly what you asked. Ask the wrong thing, get the wrong result :slight_smile:

So, you want me to wait until it mis-behaves and do exactly what? Exactly what I already did, but from a state of trouble? I do that all the time. Sometimes it works, sometimes not.

be specific so you get what you hope for.


Hi @Just_Me,

To clarify the test here :slight_smile:

  1. Wait for the issue to re-occur when you can’t access the Roon Core via the Android Roon app

  2. Exit out of the Android Roon app and force quit it, Amazon provides these instructions on how to force-quit an app:

To close apps, select the square icon in the bottom of the screen to show all open apps. Select the ‘X’ in the top right of each one to close.

  1. Open the Android Roon app once more

  2. Verify if you still have issues connecting with the Android App being the only variable that as changed

I was not aware you previously tried this. Have you been making sure to force-quit the app and start it again, or have you just been going to the home screen and opening it once more (without quitting it initially)?

yes to all. That’s exactly what i did. Swipe right and click the “X” are the same function. I often have to force quit it several times and maybe cycle the android. I can continue to try this now that i have forced it to 255.x4.

Again this NEVER EVER happens on MacOS (X.11,12,13), iOS (latest) or windows 10.

And other android apps work fine. (Firefox, Silk, Outlook)


OK. It did it again. I had put in “” as the Ip address, and all was well for a while. Eventually it simply would not find the Roon core. Force-quit. No good. Put in 255x4 zgain. No good. Went to settings and changed to a different SSID (AP, on the same subnet/router/DHCP pool). With that it worked normally. I will add that nearly every time i wake up the android remote, the Roon remote app says “no WiFi connection, you must connect to the same network as your Roon core”. Then, after 20 seconds or so it suddenly connects. Again, i emphasize this NEVER happens with other apps on the same android device. Hope this info is helpful.