Remotes cannot connect to core [resolved, bad network]

I’ve been using Roon for about 6 months without trouble on a headless mac mini (core) and controlled by an iPad mini and MBA. Sometime around the time my iPad prompted me to upgrade roon (on the mac mini core, if memory serves) I lost the ability to connect to the mac mini. I’ve tried all the troubleshooting I could think of which included going from room server to the full version of room (1.3) on the mac mini and re-establishing it as the core (full version so I could at least play music by sharing screen from my MBA). I’ve also up dated my MBA and iPad to room 1.3 but neither of the remote devices can locate my remote library on the Mac mini. Everything is on the same wireless network (eero) and it is working just fine (I can connect and share screen between MBA and mac mini over the network). Below are the current specs for my system. Any help is much appreciated.

Core/server: Headless Mac mini (late 2012) 2.3 Ghz Core i7 8GB RAM running El Capitan and Roon 1.3 (build 204) stable (64 bit)

MBA: 11 in (early 2015) 2.2 Ghz i7 8GB RAM running El Capitan and Roon 1.3 (build 204) stable (64 bit)

iPadmini (recent vintage); current OS and latest version of Roon from app store

Still looking for help here. After reading another post I tried to ping my core machine from my MBA remote. I get timeouts, host down, and 0% packages received messages. When I do the same with the IP address of the router all is good (all packets received). So, I guess this will help with the diagnosis?

Hi @Adam_Renslo ---- Thank you for providing the details of your setup and sharing this most recent observation with us. My apologies for the wait.

From your report you mention that everything is on the “same wireless network”. May I very kindly ask you to please expand on this description a bit further by providing the specific details of your network configuration / topology. If you are able to provide some insight into any networking hardware you are implementing, that would be useful as well.

Looking forward to your feedback!



I’m not sure about the technical details but we have a cable model that connects to an eero wifi router. All the computers on this system are on the wifi network, not hard wired. I have internet access on all machines and can share screen between my MBA and the core Mac mini. However, as noted in my previous post, when I used the network utility on my MBA to ping the IP address of the core mac mini there was no packets transferred. So, this seem to be consistent with my inability to connect to the core machine.

Hi @Adam_Renslo ---- Thank you for the follow up and taking the time to answer my questions.

So there are no other networking device at play here, correct? Examples of these types of devices would be switches, repeaters, extenders, power line adaptors.

Moving forward, can you verify the following for me:

  1. There are definitely no firewalls or antivirus application active in your setup, correct? If there are, could you please bring them down, temporarily of course, and confirm if there are any changes in behavior amongst your remote devices.

  2. Now while this may seem elementary, can you confirm that your core is set to accept connections from remotes? (Path: Settings - > Setup).

  3. Have you tried power cycling all of your equipment to re-establish the “handshake” between your device, router included?

  4. During your troubleshooting of this behavior have you at any point tried a hardwired connection between your Core (MacMini) and your router? If so was the experience any different or was it the same?



Thanks for the suggestions.

I can confirm there are no other networking devices involved, no active firewall, and the core is set up to accept connections from remotes.

I have power cycled everything except the router so that is something I will try tonight, and if necessary also hard wiring the router to core.

1 Like

Hi @Adam_Renslo ---- Thank you for following up with me and taking the time to answer my questions. Both are very appreciated! Let me know how the testing goes, looking forward to your feedback!


If you cant ping the core machine, then the Core machine is either not turned on or the machine is not accessible on the network. Pinging operates at the operating system level and your feedback tells me that your machine has no access to the network.

Obviously, if there is no connectivity, Roon can’t connect.

There is another possibility: you are pinging the wrong host/IP.

1 Like

Thanks Danny. I can connect my MBA to the core and control it over the wifi network (and play music etc) so it is definitely on the network. I’m pretty sure I was pinging the right IP address, found in network > advanced >TCP/IP of the core machine.

Is it not strange that I can control the core from my MBA over wifi but Roon remote on the same MBA cannot connect to the same core over the same network?

ok there is one other possibility… firewall. I know you said there isn’t one, but pinging is something all the OSs do… but it can be blocked by a firewall.

I need clarification here… what do you mean by “control the core” and what do you mean by “cannot connect to the same core”?

my guess is that “cannot connect to the same core” means Roon for MacOS does not show the Core in that first screen where you select which Core to connect to.

I dont know about the former statement.

Sorry, let me clarify. I can use screen sharing on my MacBookAir (MBA) to view the screen of my headless Mac mini, which is running the core and is also where my digital music files reside. So, I can share screens and “control” the mac mini over the wifi network. However, if I start Roon from the same MBA it just “searches for remote libraries” without finding them. Hope this helps.

Are you running Roon on the Mac or RoonServer? If Roon, are you sure you have server sharing on? Maybe it got flipped off?

“accept connections from remotes” is on. Is that what you mean or is there a separate server sharing setting?

Tonight I tried pinging the core and this time packets were received. So, I launched Roon on the MBA and sure enough it connected to the core. Unfortunately, I had not changed anything so I do not know why it worked this time. Unfortunately my iPad still does not connect. It brings up a ‘choose your core’ screen but only shows the MBA, which is not my core. Interestingly, if I say I want to connect to the MBA (even though I don’t really) I get the “get more authorizations” page and it lists the Mac mini under devices I might want to unauthorized(!). So, on this page it seems Roon remote on the iPad recognizes the mac mini is there but I just can’t connect to it as a core. I’m going to try power cycling my router now as suggested by Eric.

1 Like

The issue appears to have been related to in/stability of my wifi network. I did not originally think this could be the case since I had good internet connectivity on all machines throughout. However, using network utilities to ping between various machines helped me to see which connections were stable, marginal, or not working at all. After cycling the router and then cycling wifi on/off on the MBA I was able to reliably ping between machines and at that stage the remotes (MBA and iPad) connected with the core. For the past 24 hrs at least I seem to have stable connectivity. Thank you Eric and Danny for your help. The network utility was really helpful in seeing what was actually going on with my wifi network.

1 Like