Remotes have trouble connecting to core (resubmitting trouble ticket)

This is the same issue from December 2019. I have added an iPhone remote which appears to connect more reliably than the android remote.

Core Machine (Operating system/System info/Roon build number)

Roon core: Mac mini (macos 10.13.6), Roon v1.7 build 571. I’ve also tried running the core on a Windows 10 Dell XPS 13 laptop connected to wifi. Trouble occurs with both cores.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Internet via Xfinity Arris SVG2482AC operating in bridge mode connected to an Orbi RBR40 wifi router. The house has one Orbi satellite at the opposite end of the house. Roon core and roon remotes don’t connect to the satellite. Roon core and remotes are on the same subnet and have static IP addresses.
The core is usually connected via ethernet to a plug in wifi adapter, but the trouble persists even when I connect the core directly to the orbi router. The orbi router doesn’t have any multicast settings or anything that might seem relevant. There are no security features (firewalls, blocked services, etc) running on the mac mini, orbi router, or windows laptop.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

No audio issues

Description Of Issue

Roon remotes often lose connection to the Roon core. I primarily use an Android Pixel 2 for one remote and a windows 10 laptop for another remote. Both have had connectivity problems, but the android seems worse. Sometimes everything is fine. Maybe 50% of the time, the android remote won’t connect to the core within a few seconds of opening the app. It will immediately connect if I toggle the core’s “accept connections from remotes” setting. If I don’t do anything the android seems to connect on its own after a few to several minutes.
I took packet captures during the loss of connection, the several minutes of attempted reconnection, and the eventual successful connection. I have the roon logs during this same time. I can send those along if they will help.

Hello @adam_tuxbury, and thanks for your report! My apologies that this issue has resurfaced, but I’m happy to help! I’d like to enable diagnostics for your account and submit a report to our QA team for investigation. I’m going to enable those diagnostics now and I’ll be back with their feedback!

1 Like

Have you seen this in the knowledge base?

Netgear Orbi Routers

If you’re making use of an Orbi router, we recommend unchecking Disable IGMP Proxying in your router’s settings. This setting can interfere with the ability for Roon Remotes to connect to the Roon Core.

1 Like

Thanks for the note. I had seen that. I thought it was the solution but the remotes are still having troubles.

Hello, here’s another symptom that might be important. The affected remote is connected to the core even though it keeps displaying the “Waiting for Remote Core” error.
When one of the remotes shows “Waiting for Remote Core”, I can use a different remote to connect and to successfully transfer a zone to the device that cannot connect. The remote that can’t connect will be playing music while still displaying the “Waiting for remote core” error.

Hello @adam_tuxbury, thanks for the new info! I’ll update the ticket.

I chose a less congested 5GHz wifi channel a few days ago. As soon as I made the change the remotes connected very quickly and reliably. It seems an improbable root cause. Could the protocol be that sensitive to interference?

Thanks for this update @adam_tuxbury, I passed to the team so we can confirm and get more info. Thanks!

@adam_tuxbury My orbi’s have been a drama with roon. If this raises its head again stick a switch between your orbi and your core. So connect your internet to the switch, then connect core and orbi to the switch. I was having all your problems, this resolved all of them (however I have no technical explanation as to why - still waiting on Netgear to answer this one…

1 Like

You can read of some of my travels here…

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.