Remotes no longer connect, only fix is to toggle "Accept connections from remotes" on and off

Core Machine (Operating system/System info/Roon build number)

Mac 5,1 running High Sierra Roon 1.7 build 521

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Wired, Google Wifi, Sonos 1s and 5s

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Sonos 1s and 5s
Description Of Issue

My Roon setup worked for years just fine with this system, until recently updating the core computer to High Sierra and doing a fresh install. I’ve got everything installed from scratch and it works as expected, but I can only connect remotes just after Roon starts up. If I attempt to connect a remote after a few minutes it can’t see the core. If I toggle “Accept connections from remotes” in setup I can again connect to the core, but only for short time.

I’m not doing anything fancy here and this exact setup ran perfectly on Sierra until this clean upgrade.


Hi @Joe_Kearney,

Is there any change if you temporarily disable any firewall or antivirus on the Core?

What kind of remote devices are you using? Is it happening for all remotes?

Firewall is off and no anti-virus…it’s a base High Sierra install. I’m using an Android with the Roon software install. That’s the only remote I’ve got so yes, all remotes :slight_smile:

Hi @Joe_Kearney,

Is there any change in behavior if you re-install Roon and try temporarily running with a fresh database?

  • Make a Backup of your current Roon Database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon”
  • Rename the “Roon” folder to “Roon_old”
  • Restart/Reinstall the Roon App to generate a new Roon folder

Just tried this, getting the same result as before. Once I start Roon I can connect with a remote for about 5 minutes. After that, I have to repeat the process I outlined above to reconnect a remote.

Any other suggestions? As a reminder all that changed was an OS upgrade on the core computer. The network and remotes are unchanged.

Hi @Joe_Kearney,

If you click on the “Help” button that appears, are you able to manually type the IP address of your Core or to connect to it that way?

Hi! So I tried this and it actually worked (entering the IP of the Roon host). Most of my clients still don’t connect automatically as they used to - any thoughts?

Hi @Joe_Kearney,

If your Roon clients are not able to automatically connect, but you are able to connect via specifying the IP address, this could indicate a multicast issue in your router. Have you confirmed that you’re using the latest firmware version on the router? Have you rebooted the router recently?

Just to close the loop on this, the clients automatically connect again. Whatever updates might have happened since our last post here must’ve contained some magic sauce. Nothing changed on my side.

1 Like

Happy to hear that there was some change here that helped @Joe_Kearney!
If you encounter further issues, just let us know and we can take a look.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.