Remotes won't connect to Core

Core Machine (Operating system/System info/Roon build number)

QNAP NAS 1.7 (build 571) stable QPKG-Version : 2019-06-09

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Core connected via Ethernet using Powerline adapters, other devices connected via WiFi using Google WiFi.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue

When opening any device as a Remote (I have tried Windows 10 x64 app, plus Android app on a mobile phone and a tablet), the app sees the Core as available in the Choose your Roon Core screen and it shows as Ready, with the correct system details shown. When I click Connect I’m prompted for my password, however after doing this I am taken to the Authorizations screen with an option to Unauthorize the NAS Core. I do not see the ‘Oops, I meant to run as a Remote control’ option which is mentioned on some previous threads for similar issues.

I’ve restarted the QNAP NAS, and also after restart stopped and then started the Roon Server app, but the issue persists. The only thing that’s changed is the QNAP firmware was updated to latest version (4.4.3) yesterday, however I didn’t test Roon after doing the update.

Hi , it’s a problem with the QNAP App. See below. The update needs to be done manually in the QNAP App Centre after you download the updated Roon App.

1 Like

Hi @Kev_Penny,

After updating the QNAP package (as mentioned above) is there any change?


Fix for recurring authorization prompt

Hi both, thanks for the advice. I have updated the QNAP package and it’s made no difference, I think it’s a slightly different issue - previously I would often get prompted for credentials (as the updated package is described for), but then after authentication it would work fine.

My issue is that after authentication it takes me to the Authorizations page instead and all I can do is unauthorize (which I’m happy to try, as long as I know how to re-authorize afterwards).

Hi @Kev_Penny,
Please try to click the “unauthorize” button on the Authorization page and your QNAP core should get authorized again afterwards. (Don’t worry, you can’t loose any authorizations by clicking the “unauthorize” button.)


Thanks @crieke, that seems to have worked.


Good to hear.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.