Removing IPv6 DHCP in my mesh network router greatly improved my Roon experience

Hi! I have a TP-Link Deco M5 mesh network in my home and have been using Roon a 6 months now. My NUC-ROCK is connected to one of the ethernet ports of the main mesh node. I’ve always had a “meh” experience with it. I just thought it was just the way it is with Roon. But this weekend, I switched from router mode to bridge mode in the ISP-provided modem/router and used the Deco as a router. I have previously configured the Deco as access points, delegating the routing duties to the ISP modem/router. I did this to take advantage of the Deco’s routing features, like parental control. I was miffed to find out that it was a worse experience with Roon. I played around with the settings of the router and turned off IPv6 DHCP. And holy smokes, it was night and day! No more losing connection to my NUC ROCK, albums are gapless form start to finish, no more “cannot login to Qobuz or Tidal” messages, and search and displaying of artists and albums are snappier. Everything just improved! I’m having a great time and have been playing music almost nonstop!

So I don’t know if this is a just mesh thing or even just a TP-Link thing. And I really don’t know if it’s indeed an IPv6 thing. I didn’t check if IPv6 DHCP was turned on in the ISP-provided modem/router, but I suspect it was. Now that it’s in bridge mode, this is moot. Maybe the Roon team can comment here. I read somewhere that IPv6 is included in the Roon build and that it shouldn’t break Roon. In my experience, it seems to do so.

To you guys having the same problems that I did, with the constant lost of connection to the Core and slow remote experience, I would suggest trying turning off IPv6 in your routers if you don’t need IPv6. Again, I just thought the problems I was having were inherent to the Roon experience. I sincerely apologize for the few posts I made complaining about these in this forum. It seems like it was my network’s fault all along.

1 Like

@Felix_P could you have a look?

Thanks for this reference to Arthur’s experience. My TP-Link archer AX1500 WiFi 6 ist in Bridge Mode. The LAN-settings are as follows (do not understand the technical details). Yet as I have no NAS or Internet-Streaming involved (except the downstream to the Bluesoud node 2i) the problems seem to sit in the core itself (using my own library on the same SSD). The communication between the App and the Core theoretically ist the only “network-operation” which could contribute to the skipping.

Here are my ping times to NUC-ROCK with IPv6 on:

And here’s without. I’m still getting 100+ ms round-trip times. But no timeouts.

something is very bad about your network if you are getting 100ms+ pings on LAN

the IPV6 thing may have just been another symptom

Does the path between the ROCK device and your router to the outside world include any wifi via that mesh?

Hi @danny Thanks for your reply.

No, the setup was the modem was connected to TP-Link Deco M5 main node/router, which was then connected to the NUC-ROCK via ethernet. But…

You’re absolutely right. The latency I was experiencing was coming from the crowded wireless backhaul of the mesh system. I changed my mesh system to the highly recommended Asus ZenWiFi XT8 with its dedicated wireless backhaul. It fixed the latency issues. But even with this new mesh, I was still getting drops when playing to my wireless endpoints that need a hop in the mesh network. All my other wireless devices like smart TVs, security cameras, and a couple of Volumio raspberry pi streamers using the integrated Tidal and Qobuz sections worked just fine even with the hop. Somehow the Core cannot hang on to a stable connection to the Roon endpoint. This led to me to a couple of conclusions: a) a mesh setup, at least in my house, cannot keep up with the network demands of Roon; b) if I want a seamless Roon experience, I have to wire my house. Which is what I did. Two out of my four endpoints are now wired. While the remaining two are wirelessly connected to a wired access point/mesh node. Ever since I did this, I’ve experienced just one playback drop, surprisingly in one of the wired endpoints. It’s been great so far. But wow, Roon is very exacting of network setups! I don’t know if it’s just not compatible with mesh networks or just my mesh network. Maybe there’s something the support and dev teams can investigate here so that they can make adjustments or recommendations? Thanks again.

1 Like

Any further conclusion about IPv6? Unrelated?

I’ve since found out that my ISP is not IPv6 yet, so I just turn that off. But it might be unrelated.

Not sure if this helps and it may be my case only or unrelated, but Roon and both native Qobuz and Qobuz through BlueOS have a big delay (5s to 7s) in loading on Windows if ipv6 is enabled.

Are you on Comcast?

Nope, WOW

We don’t need assistance figuring out the problem in the other thread. We know what the issue is.

However, this is good information to have. Qobuz uses Akamai as a CDN, and Akamai uses IPV6. TIDAL’s CDN does not. My guess is that IPV6 will get sorted out as more and more of the internet starts to use it. In the meanwhile, I would disable it.

Another personal anecdote, my kids’ play on a Minecraft server I set up. Latency goes way up with IPV6, to the point where they notice in gameplay with their friends. Turning off IPv6 fixed it.


Yes, I have ipv6 disabled as well.