[Resolved] ROCK failing to connect - Network error: Please check your internet connection

Core Machine

ROCK on Intel NUC 10i7FNH, 250GB SSD, 16GB DD4 RAM (1C697AA24A5D) FW 1.0 (build 227) stable 10.0.0.9, Version 1.8 (build 778) stable

Network Details

Netgear Orbi mesh system RBK50 router. 3*satellites. Roon Core and the music store (Naim Core with ~1000 albums ripped) both use ethernet into one satellite, which in turn is connected by ethernet to the router. The other two satellites, which each have Roon endpoints attached, use wifi to/from the router.

Audio Devices

3*sMS-200 streamers: one connected into a Soekris1321 DAC, and two into Mojo Audio Mv2SE DACs for other audio systems. All these are USB DACs.

Description of Issue

Since starting with Roon, I have had perpetual connection problems. Adding extra satellites onto what was a powerful Mesh wifi didn’t solve the problems - Roon was still unstable and would periodically lose the connection to the Naim Core. I hoped to solve some of the problems by changing the original Windows i5 PC running Roon Core over to a dedicated ROCK NUC; that didn’t help much. For the next attempt at a solution, I laid an ethernet cable from the satellite with the Roon and Naim Core units direct to the router; that didn’t help much either, though the system was marginally more stable. I could sort of live with the instability (needing frequently to reconnect to the Roon Core) because when Roon works - admittedly not that often - audio quality is good and the album information is useful.

The problem now is that on my Roon Remotes, it takes me to a screen showing “Choose your Roon Core…”; identifies the NUC by name; offers a green “Ready” option; but if I press the “Connect” hot-button, it takes me to a Roon login page. If I insert my account details (why should I need to do this?!), it produces the error message of the title of this post. This is so on an iPad running iOS14.5 or a Samsung Galaxy Note10+ running Android 11 (in other words, both devices have been updated). I’ve tried cycling the Roon Core NUC off/on, and also the iPad and phone, but none of this makes any difference - I can’t get beyond the login page. Every other device of all types in my home network is fine, and I can log in to my Roon account from my PC - which is how I am typing this. Essentially now, Roon completely fails to connect or do anything at all. Just to get back to the previous level of instability would seem like a triumph now…

I bought a lifetime subscription to Roon a few months ago. I am now regretting that a great deal.

Steve

Hey @Stephen_Wright1!

Apologies for the delay! Our team’s queue is longer than typical at the moment, but we’re working to get back to everyone as quickly as we can.

That sounds like a frustrating escalation of symptoms! Are you still seeing this issue today?

If you are, it may be your router that’s the issue. Our Networking Best Practices article suggests that Netgear Orbi Routers should have IGMP Proxying disabled in your router’s settings. In these specific devices, this setting can interfere with the ability for Roon Remotes to connect to the Roon Core.

Please let us know if this helps or if we need to dig a bit further.

Hi Kirsten

Thank you for your reply. I’m away from home from late last week and for some weeks to come, so I can’t test your proposal. At the point when I left home, Roon as a system was not working at all. The Orbi’s diagnostics were showing that the Rock machine was connected, and Roon was showing that too, but Roon would not allow me to sign in to access music on the store. I could sign in to the account just to check its parameters, but in sum whenever I tried to do the sign-in to access music, it would give the error message.

A year or so ago I changed IGMP Proxying in order to ensure connectivity, to a completely different device (as it happens, an app-connected wood-burning stove!). TBH, I cannot remember what was the status of the switch after that exercise.

I cannot do anything until I return home. Can I suggest that we park the issue till then, I’ll check the IGMP situation, try flipping it to off if it’s on etc? I’ll write to you, and we can take it from there to see if it’s possible to make Roon work in my set-up. Obviously, having just bought a lifetime sub, I’m reluctant to abandon Roon (which sounds good when working), but its level of functionality is so poor I’ll soon have no choice.

Since I have had so very many connectivity problems with Roon over the last three years, I tend to be a bit intolerant when it throws another hissy fit! What’s is most irritating is that Roon is the only software I run which has this level of connection problem. Is that related to complexities with RAAT? I sort-of appreciate that WiFi is less robust than wired, though just about every other software I know of does run perfectly well using it. The Orbi is a highly-rated mesh device. After setting up a temporary Ethernet cable between the router and the satellite with the Rock and music store in order to attempt get round the problem, Roon’s performance went dramatically downhill before completely failing. It sometimes seems it’s so temperamental that I’ll never get it stable. Let’s hope!!!

Thanks again. I’ll be back in touch in due course.

Steve

Sent from my iPad

On 18 May 2021, at 21:26, Kirsten via Roon Labs Community community@roonlabs.com wrote:

Hi Kirsten

Can I take up this discussion again please (I’m finally back home after some major surgery)? I – still - do not have any connectivity whatsoever to Roon on my home network.

In your email of 18th May below, you suggested that Netgear Orbi routers should have “IGMP Proxying disabled”. I wasn’t certain about this, because the “Roon Networking Best Practices” link you gave stated that “If you’re making use of an Orbi router, we recommend unchecking Disable IGMP Proxying in your router’s settings. This setting can interfere with the ability for Roon Remotes to connect to the Roon Core” – i.e. it should not be disabled. In any event, I’ve tried it both ways.

For information, the Orbi network uses the same SSID and credentials, and the same IP range, throughout. I’ve also obviously looked at the browser interface. That is showing that the Roon Core (an Intel NUC10i7FNH) is attached, as is the music store (a Naim Core). To reiterate, the NUC and the Naim are both connected by ethernet to one of the three Orbi mesh satellites, and that particular satellite is now (temporarily) connected by ethernet for the backhaul to the Orbi router as well (i.e. this satellite connection to the router is cabled, not wifi). Devices that I would want to play music from – a series of three SOtM streamers – are connected in one case to the router itself (by wifi), or for two of them to other Orbi satellites, which use wifi to the router.

It may well be that the issue, as you highlighted in the email, is the connection from my Roon Remotes to the Roon Core. I use two Roon Remotes – a Samsung Galaxy S10+ and an Apple iPad Air 4th Generation. Both are therefore relatively recent devices, reasonably powerful, and they are up to date in both OS and applications. The behaviour of the two with respect to this Roon connection problem is a bit different:

• Samsung Galaxy. Please see the Android screenshot above. The phone simply hangs like this – it never finds the Roon Core;
• Apple iPad. Please see the two Apple screenshots above. The first of these seems to indicates that the iPad has found the NUC machine (the indication is green, “Ready”). When I click on Connect, I get a Login screen bujt if I put in my credentials, I get the “Network error” that you can see on this image. The same login credentials on a browser take me straight into my account without any hesitation at all.

I’ve tried this a number of times, and cycling bits of the kit.

Can you help me find a way round these connection problems please? At present, Roon is completely unusable. Given that I bought the lifetime subscription, this is really not acceptable! Roon is the only software which doesn’t work on my network – another audio streaming application is fine. It seems ironic as well that Roon suggests ethernet is more stable than wifi, but mine has failed since adding the ethernet cable from the router to the satellite concerned.

Thanks, and looking forward to hearing from you.

Steve



@Stephen_Wright1 My goodness! I’m glad to hear that you’re back from surgery and (presumably) recovering comfortably! I’ll be following up with you early next week!

@Stephen_Wright1 Can you take a screenshot of your Web UI? You should be able to reach it from the page where it asks to choose your Roon Core. In the bottom right-hand corner, choose the Configure Roon OS link.

Also, let’s take a look at the DNS address on your Core. Can you switch to a Google or Cloudflare DNS address and see if that fixes the connection problem? Make sure you choose the IPv4 format.

Hi Kirsten

You’ll need to be patient with me - some of this stuff is beyond my comfort zone or even a discomfort one. Apologies therefore if I’m being dim.

For the screen I get when I click on “Configure Roon OS devices on your network”, see the attached. Is this what you want? That screen just sits there for ever, in other words, the Roon Remote (my phone) doesn’t manage to connect.

For the DNS address on my (Roon) Core, I have a static IP address on my system (as it happens, 10.0.0.9). The MAC address - which I assume is completely irrelevant to you - is 1C:69:7A:A2:4A:5D. Then, there’s another MAC address shown but that’s just the one for the Orbi satellite that the Roon Core is attached to, so that’s not relevant either. There is a static IP address for the router (192.168.1.10 on Subnet mask 255.255.255.0). I use OpenDNS for IPv4 on 208.67.222.222 and 208.67.220.220. IPv6 is enabled, also through OpenDNS on 2620.119.35.35.0.0.0.0 and 2620.119.53.53.0.0.0.0.

I suspect I’m not answering your question!!! What should I actually be telling you, or doing?

Thanks.

Steve

Hi @Stephen_Wright1
Thanks for all those details - very helpful.
It appears that the IP configurations are probably a big part of the problem. Let’s start by ditching the static addresses on both the ROCK and on the Orbi router, unless there’s a compelling reason for setting that up (I’m not being able to come up with one offhand unless there’s stuff going on elsewhere)

For the ROCK, it’s pretty simple to reset the network settings. Here are step by step instructions.

For your router, you may need to check your user’s guide to reset that.

Let me know if anything changes once the addresses are dynamic again. If you still can’t connect, please take those same screenshots again and we’ll go from there.

OK, Kirsten, maybe getting somewhere now.

I changed the static IP address on the NUC for a dynamic one using the step by step instructions you outlined (i.e. I did this on the NUC itself). Connectivity immediately came back, on both the Samsung and the iPad. I then checked the web interface for the Orbi, and that was showing the NUC having the same address as before (10.0.0.9), even after doing a “Refresh”. I checked the process for creating a static address within the Orbi’s web interface, and took off all of the static addresses (that included the NUC and the three SOtMs too). It was then that I noticed that both the NUC and another device (a solar inverter…) had the same IP address of 10.0.0.9. Connectivity kept on flipping in and out, on both Roon Remotes. I tried to force the inverter off to 10.0.0.21 using the Orbi web interface, though it resolutely stays on 10.0.0.9. Then a Refresh took the NUC to 10.0.0.2 - and, miraculously, it seems now to be holding the connection to both Samsung and iPad. For reasons which totally pass me by, the Orbi has decided to allocate 10.0.0.9 to both the inverter (2.4G) and, now, a Google Chromecast (5G). If you’ve any idea why Orbi wants so promiscuously to hand out 10.0.0.9 (there are no other simultaneous allocation then I’d be interested (something to do with 2,4G vs 5G?) - I assume there is more than a good chance that the Chromecast will misperform at some point… At the moment, my focus is on achieving stability with Roon, and there seems a chance that this has occurred now.

Being realistic/pessimistic, I have been here before in that Roon has decided to work for a while, maybe some weeks, before deciding not to. So, I’m not hoisting the victory flag just yet.

Nevertheless, thank you very much indeed for your help on this. I’ll either report to you in a couple of weeks that it is all stable… or I’ll shout at you beforehand if it’s not.

Steve

1 Like

Hi @Stephen_Wright1 I’m happy to hear from you either way, although I’m sure that reporting will feel better than shouting for both of us!

I’m not an expert on Orbi’s obviously, but one thing we use when IP addresses are being unfriendly are DNS addresses from Google or Cloudflare - you can do a search for them - they’re easy to find. You may want to use one of those for the Chromecast, for example. (I’m guessing here, of course - those are not my products. If that doesn’t work, I’d try Orbi’s tech support)

Pardon me for jumping in, but in an earlier message, you said that you had “a static IP address for the router (192.168.1.10 on Subnet mask 255.255.255.0)”. Is this the Orbi router in the base unit, or some other router that you have in your network?

It’s just that, according to the Orbi manual, by default the router in the Orbi base unit is supposed to have a default address of 192.168.1.1., and also run a DHCP server handing out addresses in that address range. So, what’s handing out addresses in the 10.0.0.1 range?

1 Like

Hi Geoff - no problem for jumping in, the more the merrier. I just wanted to get a very long-standing problem sorted.

Your implication is right. I have FTTH broadband. The fibre modem has, putting it delicately, rubbish wifi. My house is an old one, with heavy masonry walls and multiple levels. In order to get decent wifi throughout the property, including to the attic where the Naim Core music store is, I decided to upgrade the wifi and get the Orbi - at the time, pretty much state-of-the-art in terms of mesh wifi strength. So, the fibre modem hands off to the Orbi, which controls all the connections within the house, whether ethernet from the router to a device or wifi/ethernet off the three Orbi satellites. It gives out the addresses in the 10.0.0.x range. When the system was set up, the guy who did that probably also set the 192.168.1.10 address. Because the whole mesh wifi system simply worked, I never thought twice about it. And, TBH, I wasn’t considering that the perpetual problems I had with Roon somehow concerned the environment outward from the Orbi to the internet - I was supposing it was just the inward connections.

When Kirsten sent her ‘use dynamic addresses’ email , I was happy to do that on the connection from the Orbi to e.g. the Roon Core/NUC, but was a bit reluctant to mess with the address for the network as a whole (the 192.168.1.10), since I could see a possibility of something going wrong and pulling the whole network down. First things first, and the dynamic address for the Roon Core seems to have done the trick. If it hadn’t, I might have been tempted to go further.

For information, the Orbi is today showing different addresses for the inverter and Chromecast (which has to be good i.e. they’re not both 10.0.0.9). And the Roon Core is still sitting happily on its own address of 10.0.0.2, which is also good in that certainly there appears to be a stable connection.

Thanks to both of you!

Steve

OK, then what might be the case is that the router in your FTTH modem uses the 192.168.1.x range, and therefore your guy changed the defaults on your Orbi router to the 10.0.0.x range. I’m assuming that the only devices in the 192.168.1.x addresses are the FTTH modem/router and the Orbi base unit router.

I hope you’re not using both address ranges in your home network? If you are then these are in effect two subnets. Roon does NOT operate across different subnets.

Reading the Orbi manual, it appears that you can set reserved IP addresses in the Orbi for your devices (i.e. the DHCP server will always assign the same address to the same device each time the address lease is renewed). See page 73 of the manual that I linked to in my previous message.

Using reserved addresses is best practice. Too easy to get things wrong with giving individual devices static addresses.

I think you’re pretty much right in what you say. I do not use both address ranges (isn’t that double-NAT or something like?). All devices are hung off the Orbi on 10.0.0.x.

I don’t fully understand the difference between “reserved” and “static” addresses. Up until yesterday, I did have a static address for the Roon Core (and, as I mentioned, the three streamers) - that is, I assigned specific IP addresses, using the web interface of the router to do so. Removing that Roon static address in favour of a dynamic one seems to have resulted in the system working and therefore Roon connecting normally and in a stable fashion (so far, at least).

If I’m missing something, do tell! And thanks again.

Steve

I think that this was in fact assigning “reserved” addresses, rather than “static” addresses. Static addresses are normally set up in the device itself, rather than in the router.

But if the function to assign a static address to a device exists in your router, then you need to make sure that you make the address one that is outside of the address range used by the router’s DHCP server. Otherwise there’s the danger that the static address also gets used by the DHCP server, and you end up with two devices having the same address.

That’s why the recommendation is to steer clear of using static addresses in favour of using reserved addresses to achieve the goal of making sure that a device always gets the same address (because you’ve told the DHCP server to reserve a particular address for a particular device).

Thanks very much @Geoff_Coupe for your input here - your help is always valuable and valued.

@Stephen_Wright1, I’m going to mark this post as solved, but feel free to continue your discussion!

Hi both

Naively, I was assuming that an IP address specifically reserved in the Orbi would not then be subsequently allocated to another devices by the DHCP process. I know now… As it happens, for any device on my network, I’ve never used anything other than the router to assign an address - i.e. I’ve never as such used a “static” address. Thank you to Geoff for helping me to understand the point here about static/reserved!

The Roon setup seems still to be working fine, and I am fully aware that IP addresses are definitely associated with the failures I was experiencing. So, e.g., if it goes belly-up again, I can explore how to get round that, including putting the Roon Core out of the normal IP range so that there is no interference with other devices. Let’s hope it stays stable and I don’t need to mess with it at all.

Thanks again to both of you.

Steve

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.