[resolved] Tubular Bells Issues

I’ve reported this problem before here: Identification problems (very long post)

I’m not sure if it ever got fixed, but the problem is back. Look at this screenshot:

You can see that I’ve tried to edit the track names to “Part One” and “Part Two” just for testing but Roon refuses to accept the change and insists on keeping the track title “2009 Stereo Remix, Pt. 2”. No matter what I do, I can’t change that. Here’s another edition of the album where I tried to manually edit all four tracks, but only tracks 1, 3 and 4 are editable and track 2 sitll refuses to change. FYI, neither of these albums has any 2009 remix tracks.

I have the same problem with the two track version. I can rename track one but not track two. When I go to re-edit my changes have been saved. Odd.

Same here with track 2. No idea where “2009 Stereo Remix, Part 2” comes from…

Exactly the same with mine,
And yet, when you select that track this is what you see…

@mike @jeremiah https://dev.roonlabs.com/portal/issues/11480

Will someone at Roon please look at and fix this issue!

This is the third time I’ve reported this issue in the past, and the problem still persists. The first time was here:
Identification problems (very long post) in May 2015 and the second time was here: in January 2016: Tubular Bells Issues. Another six months has passed and the problem still exists, so I thought I’d take another stab at it.

I currently only have two versions of Tubular Bells on my system. Here’s the file listing for both:

In each case the track titles in the metadata for each track is identical to the file names except where certain characters are replaced with underscores in the file name.

Here is how the two versions look in Roon:

FYI, the 2009 remix version of the album is no longer even on my system. And here is how it looks in the track editor:

It goes without saying that the metadata in the tracks is correct, but Roon seems to be ignoring the metadata and doing what it wants. Indeed, I’ve tried renaming the track something totally random, and Roon still insists on calling it “2009 Stereo Remix, Part Two”. And look at the crazy time they list for the total time: 1:12:08 for both editions. That’s longer than the total time of the tracks on either one.

Can we please finally get to the bottom of this Roon?

Hi Robert,

I’ve moved your post into your existing topic so the history is mostly together (the original topic is more general in its nature.

Looking at the ticket that @Joel referenced @Brian was digging deeper into to.

I’ll also leave a fog for @Mike so he can follow up on this.

Hi @rbienstock. Although my post above seems to suggest otherwise, I’ve actually only been working for Roon for two weeks(!) and I have the pleasure of fixing this irritating issue that affects both our libraries. I can’t put a timescale on the fix (if it was easy, it would probably have been done by now), but I can tell you that I’m actively looking at it.


Thanks Joel. These metadata issues must be the worst for Roon – they cause a high degree of customer irritation, but are usually attributable to causes out of Roon’s control. Glad that someone is now on board who’s working on this.

1 Like

I believe that the Tubular Bells issue should be fixed.

Please let me know if it’s not @rbienstock @pwright92 @jvall @HerbertGoat

Looks ok now. Needed to do a several re-scans though.

Thanks for that @Joel it does indeed seem to be fixed.

Also, I’ve noticed the Ten Years After first album which was being mis-identified as being Cricklewood Green is now being correctly identified correctly titled Ten Years After.

Perhaps just a coincidence, but thanks anyway.