Restore backup failed after update to Build 1169

Hey @Hans_N,

Thanks for giving that a try. To be clear, you first disabled the backup path before removing the drives, correct?

With that, I would also test out disabling your watched folder on your two other external drives as well to test if the same issue occurs. You could take it a step further and clean up you library after disabling the watched folders, but then you’d have to re-add you library back onto your core, which can be tedious (as you know firsthand :upside_down_face:)

An additional log set would be good to review! Please use the directions found here and send over a set of logs to our File Uploader.

Hello @benjamin
I tried to disable my watched (internal storage) folder containing my music before restart, and this time actually it did NOT go in to endless restarts. But after that when I enable my watched folder, the remote lost connection to the server which started the endless restart again :frowning:

How do I disable the backup path? I have not set up a scheduled backup at the moment as I can not make use of any backup as things are now.

I just tried disabling the watched folder, then doing a clean, enable the folder again (doing a rescan) and then restart. Same thing happens, looping restart, but now it restarts every 16 seconds, not every 21 seconds.

I have uploaded two set of log files: one before the clean up sequence (restart every 21 seconds) and one after (restart every 16 seconds).

Thank you very much for looking in to this. It is much appreciated! I look forward hearing what you find.

Hey @Hans_N,

This points to the issue potentially being related to the internal storage drive on the NUC. As a next step, please reinstall the OS via the webUI of your NUC.

If that doesn’t help, we’ll want to consider reinstalling ROCK from an external drive.

Do you by chance have another internal drive you could test? You’d need to format it via webUI, but that’s an easy click.

Let me know, Hans! :+1:

Thanks @Benjamin - I did a reinstall from the webUI, but unfortunately it goes directly into the restart loop every 21 seconds.

Unfortunately I have no spare internal drives (but I could buy one). Can you please explain to me:

  • Do you suspect my internal system drive or my watched folder drive to be faulty?
  • Does Roon 2 have special hardware requirements (compared to Roon 1.8) when it comes to internal drives? With my existing internal drives I can run 1.8 with no problem, restore and reboot, which makes me reluctant to think that a new drive will solve the problem. Also I can run Roon 2, restore and reboot, if I only use Qobuz (and no watched folder) and I can run Roon 2 after scanning my watched folder - until I reboot (then I have to reset my database and do a new rescan).

Did you have a chance to look into my log files?

Thanks for helping!

EDIT: tried to do a new install of Roon from USB stick following these instructions:

The web-interface showed that Roon core was running fine. But the remote on my Mac crashed every time I tried to start it, even after a clean install of the remote.

Reinstall from the webinterface and things were running agin. This time I did not add Qobuz but did add/scan my watched folder, everything running fine until the test: hitting the restart button on the web-interface brings it into endless restarting (now every 16 seconds). Only solution from here is to reset the database, and scanning my musicfiles once again.

Hey @Hans_N,

Based on the issues you’ve been experiencing, it does sound like you could be running into your internal music store SSD slowly starting to fail. If you haven’t yet, I would make sure to get a copy of your library saved to another location.

That said, if you perform the above, and again disable your internal storage, but set up your library on a different drive, do you still run into this issue? If not, then it may be time to replace the SSD.

Do you restart your core often? I’d be curious how things run if you didn’t try to restart so shortly after, and let things run for a few hours.

Our team reviewed your logs a few different times. We’re seeing a large amount of Critical traces but we cannot yet verify if they are related to your internal music storage SSD.