Restore backup failed after update to Build 1169

Roon Core Machine

Roon Rock (build 1169) on Intel NUC NUC8I7BEH i7. 16 GB Ram
Connected to router by ethernet
Samsung SSD 970 EVO Plus 250GB for OS
Samsung SSD 860 EVO 2TB for music
SanDisk Ultra Fit 128GB USB 3.1 flashdrive for backup

Everything is backed up to Synology NAS

Networking Gear & Setup Details

Asus AX86U router

Connected Audio Devices

Not relevant for the problem

Number of Tracks in Library

27.000 tracks, more than 2.600 albums on NUC harddisk.
Also Qobuz subscription.

Description of Issue

This morning I updated to Roon build 1169 (I did not install the faulty 1167 before that). After that my remotes could not connect to the core.

I stopped the Roon Server, renamed the RoonServer to RoonServer-old, and started the server again. Now my remotes can connect to the server, BUT when I try to restore my backups it reports “Restore failed. Please check your backup folder and try again.” I tried several different backups from back in time but same problem.

So now I’m stuck. Any help would be appreciated very much.

UPDATE: I tried one of my backups of my Roon Backup. But a backup from back in July 2022 was succesfull. But this is the old database version (1). So it was updating the database (to version 2), and after that my remote can not find the Core. Deleting the Bits file as suggested some other place does not help.

I have local backups of my backup, and cloud backup of the backup. All this a couple of years back.

I’m stuck and do not know how I will be able to restore one of my backups, hopefully one of the newer ones.

If this is not possible PLEASE make it possible to revert back to the Roon version 1, for which I have working backups.

UPDATE 2: Installed Roon Core on my Macbook. My most recent backup failed again. My backup from July 2022 succeeded, but Roon crashes in the proces converting the database to Roon ver. 2.

So it seems, that the problem is, that I do not have a working backup from ver. 2 and that Roon ver. 2 can not handle backups from ver. 1. I REALLY hope that Roon will make this, or reversion back to Roon ver 1, possible!!!

AND the question is, despite making all precautions, why do I end up with (ver. 2) backups, that do not work and without knowing it?

Is there anything I can/should do to get help with this problem? I miss my Roon library!

If you could install Roon 1.8 Legacy, then maybe your old backup will work. Going back to Roon 1.8 Legacy might be difficult at this point, but I think there is a workaround to do it. If you were able to get everythink working on Roon 1.8 Legacy, you could then upgrade to Roon 2.0 if you want.

Hi Jim,
Thanks for helping!

I did successfully downgrade to 1.8 Legacy on my Rock using these instructions
I also installed the 1.8 Legacy remote on my Macbook. Unfortunately when opening the 1.8 Remote and selecting my Rock Core now 1.8) it tells me, that “This version of Roon is not compatible with your database” :frowning:

Will Roon let you restore your backup? That should fix that if it will let you.

Seems like you are caught between a rock and a hard place. Would starting from scratch be a monumental task?

Or, maybe use your browser to go here and restore a database…

Is there a way I can restore my back-up without being able to use my remote? I’m stuck in the window “This version of Roon is not compatible with your database”

If you by “starting from scratch” mean, that I cannot restore one of my many backups (1.8 or 2.0), this would be kind of a disaster for me, as I have tons of manual edits, tags, favorites etc. in my database. That would make me leave Roon, but I’m a lifetime-member, so I will count on, that Roon will find a solution for me.

But perhaps there is a way of starting from scratch that will let me restore my backup?

Let’s page @support and see if they can respond.

Thanks again, Jim. Resetting Roon Database & Settings got my system up and running with 1.8 and I successfully restored my (1.8) backup from July.

BUT when trying to update to ver. 2, I’m back where I was 5 days ago: the Remote is constantly trying to find (waiting for) my Core.

I hope @support can help me.

Did you also put your Roon remote back on Roon 2.0? Do you have an iPhone you can try? It’s Roon Remote (Legacy) in the Apple App Store.

Yes, I did put my remote (on my Macbook) back to 2.0. I also tried iPhone remote 2.0 app, but same results.

Was not avare of the iPhone remote 1.8 Legacy app. Tried this one also but it tells me that my Core is 2.0 and not compatible.

I’m sorry, I forgot you moved your core back to Roon 2.0. Of course, your remotes need to also be on 2.0.

I’m not sure what to tell you. If it was me, I would go back to Roon 1.8 Legacy and restore your backup and get everything working properly on Roon 1.8 Legacy. Maybe do another backup at that point.

At that point, you can maybe get some help from Roon @support to successfully migrate to Roon 2.0 and not lose your database.

I’m back on 1.8 now, thanks to you Jim. Enjoying my music, although missing my edits from after July (and ARC). I suppose support has many issues to take care of at the moment, but naturally I expect them to find a solution so that I can continue using Roon 2.0.

I tried to make a new backup from 1.8, then update to 2.0, but the problem is still the same also after deleting the database and trying to restore the new (1.8) backup. So I can not find any solution as how to get back to 2.0.

I must admit, that I’m a little puzzled why I hear nothing from Roon Support, not even a confirmation that they have read my issue. At the moment, being forced back on 1.8, with my backup from July, I cannot make any changes/addition to my database, as I hope to be able to restore my backup from november. And of course I cannot use ARC. I really would like to know when (and if) I can expect some help, and also what chances are, that my issue can be solved.

Tried the new 2.0 (build 1182) - same problem.

Hi @support this gentleman has been waiting 2 weeks…

1 Like

I guess your backup is corrupt, which can happen because of a lot of reasons. e.g. power switching off, faulty SSD/HDD, interrupting a process and so there are a lot more to think about. You probably have to rebuild your library from scratch even though that means losing your current edits.

With all due respect, but if you make that many edits (you indicate you did tons of edits, and it is that drastically that you would leave roon if a fix was not applicable), you should make a regular database backup and not store it on your server. That’s asking for a disaster to happen (think of cloud solutions).

Here is one solution which worked for someone with a 1.8 migration to 2.0. Roon Migration Flub-up - #41 by Bruce_Barbour

Thanks @Lars_Grootkarzijn for trying to help. I have always made regular database backups, locally and cloud. I acnowledge that they can be corrupt, theoretically all of them and some of them might be. But when I downgrade to 1.8 legacy, I’m able to successfully restore a backup from July 2022, so how can this backup be corrupt?

Did the problem occur after upgrading from 1.8 to 2.0. Or after upgrading from a 2.0 build to a newer 2.0 build? I thought the inital problem was the second. I added a link to my first post, you might want to take a look at that.

The problem started when upgrading from a previous 2.0 version to 1169 where I could no longer recover any of my ver. 2 backups. When I downgrade to 1.8 I can recover my 1.8 backup (not ideal but much better than loosing all my database) and I have a fully working Roon 1.8. But when I upgrade to 2.0 my Remote can not find my Core.

So I’m kind of forced to stay on 1.8 where have most of my database back. If I move to 2.0 I have to live without my whole database - built it from scratchs again. In none of those workarounds I can make additions, edits etc. because I have no lasting solution (database) at the moment.

Thanks for the link, but it refers as I read it to a situation where the server is on a Mac. Mine is on a NUC, so I don’t think this offers a solution for me?

You are aware that a Roon Core 1.8 needs a different Roon app to control it than a 2.0 Core?
So my best bet is to install your q.8 Roon, restore your 1.8 db backup to it, then installa the latest 2.0 Roon “on top of it” and switch to the 2.0 App controlling it.
Makes sense? :slight_smile: