Restore from backup = wait forever

Roon Core Machine

Synology DS1621+ running Version 7.0
Linux 4.4.180
AMD Ryzen 8 core @ 2.2Ghz
32GB Ram

Running Roon 1.8 (build 831) via steefdebrujn/docker-roonserver:latest in “host” networking mode.

Networking Gear & Setup Details

UniFi switches and AP’s. RoonServer/NAS is on a 3x1GB bonded trunk. Laptop is via WIFI.

Connected Audio Devices


Number of Tracks in Library

I don’t remember. probably >10K and less than 30K.

Description of Issue

Previously my core was running on a mini-PC running Linux and I decided to migrate to my NAS. I installed Roon Core on my NAS using Docker (steefdebruijn/docker-roonserver:latest) and was able to get it to see my music which is stored locally on the NAS. Both NAS/Docker and Linux are running the same version of Roon at this point (1.8 build 831).

I copied over the backups folder contents from my Linux box to the “/backups” mount point in the Docker container and used Settings → Backups to restore the latest backup. The restore seemed to happen succesfully.

After restore it prompted to restart Roon and I re-connected via the Roon app on my Mac and re-logged in with my email/password. After this, the Roon app on my Mac just shows the “loading” Roon logo animation and nothing happens. I’ve been waiting 10minutes and it just sits there.

I tried restarting the Roon app on my Mac, connect and it throws me back in the “loading” animation.

Hey @Aaron_Turner,

Thanks so much for getting in touch about this - we appreciate the details. It looks like you’ve successfully migrated your Core from your mini-PC to the NAS. Congrats!

Since you seem to be using your Mac as a Roon Remote, could you please uninstall it, download it directly from our website and install it?

Thanks :pray:

Good: that works!

Bad: Now I have to update my personal laptop, iphone, iPad, work laptop and my wife’s phone and computer and iPad.

I suppose updating my 4 devices isn’t that bad, but my wife’s stuff… You’re really not winning me any points with the WAF!

Oh, this didn’t work on my work laptop. I had to delete the ~/Library/Roon directory containing all the application settings and then it worked.

Maybe you can just do this for me when I switch Roon Cores?