Restoring TIDAL metadata edits

Hi Support,

I have a classical music library of about 20k tracks on an external hdd directly connected to sonictransporter which runs roon core.

When the library was originally imported, a considerable number of cds failed to identify properly and I spent a large amount of time fixing this, particularly getting the mutlitrack compositions identified properly.

I recently upgraded to 2.6 sonictrasporter software and the path to the hdd got modified to “Music Folder”. Roon re-read the library ignoring my fixes and once again I have a substantial number of cds and composition unidentified.

Restoring from a backup did not help because the old path to hdd remains unavailable.

Please help.

Thank you.


If you have a backup, you should be fine – I would restore again, and then just follow these instructions.

Any issues, let us know :slight_smile:


Are you saying that I simply need to disable the old path for the upgrade to work?


If the old paths were active when the new paths were added, Roon is now tracking the same files twice.

That’s why I recommended restoring the backup and going through the steps listed in that doc, since that will update the old paths to the new locations, as opposed to adding new tracks to your database.

“Backup restore” to work?

Ok, will try and revert.

Thank you.


1 Like

Although roon reports it does not see any files on the old path …

Hi @maxim ---- Thank you for touching base here and sharing the observations you have made after performing the procedure proposed in Mike’s post(s) above. The insight is greatly appreciated!

I believe I have seen a similar behavior previously with another ST user. Although, in their case a similar behavior was noticed after they have a new drive installed in the unit. Before we go ay further, I would like to verify a few things in regard to this observation you have made:

  1. Does the track count underneath the “music” folder accurately reflect the amount of tracks currently in your library?

    “I have a classical music library of about 20k tracks on an external hdd…”

  2. My sense is that all the disabled watch folders are sub folders on the mentioned external HDD, is this indeed the case? Furthermore are the mentioned 20K tracks supposed to be spread across these subdirectories on the HDD?


I had the same thing happen when updated my ST to 2.6 with over 275,000 trks (yes big library).

I tried multiple restores from different back up dates and got all dupes.
Finally started over again and lost all my edits…not fun.

The method; just delete roon server off sonicorbiter gui “software manager” and re install roon server which starts a fresh index of your files and new data base…per Andrew’s instructions.

You may already know this.

Good luck.

My case is the one Eric refers to, and it actually consisted of two different behaviors. The first was the reloading of my music library on to a new hard drive installed in my sonicTransporter-AP by @agillis. Before I reloaded the files, I noticed Roon kept reporting the full number of tracks in my library inside the actively scanned folder on the sT hard drive, even though there were no music files on the drive. (The Roon Mac and iOS apps also showed all the original thumbnails and metadata edits I had made prior to the HD being replaced.) I surmised that if I reloaded the music files they would matchup to the original database, which was intact on the sT’s SSD… That is in fact what happened.

The second issue occurred when I updated to 2.6 couple of weeks later. After the upgrade, Roon began to rescan my entire library from scratch and create duplicates of every album, treating each new duplicate as a previously unseen album (with the blue banner). I feared that I’d have to manually delete all the duplicates (my library was more than 2900 albums) or somehow restore the old database. But, as soon as the rescan completed, Roon proceeded to delete each newly created duplicate in turn, leaving me with my original library intact. I tried to play one of the “new” dupes as this process was happening but got a message that the file did not exist. (Don’t ask me…) A that point I manually deleted all old database backups from the sT and created entirely new ones (including one on Dropbox) and all seems fine to this point.


Thanks for the advice.

I might have fixed the problem. I disabled the old path before restoring from a backup and — fingers crossed — it seems that my edits got restored, too, together with the backup…

I am still checking and will let you know if further help is needed.

But, frankly, this is frustrating: I like listening to music and hate wasting my time figuring out software glitches …


Thank you for touching base with me @maxim, please keep me posted and if further assistance is required I will be glad to lend a hand.



And how do I recover Tidal metadata edits?

I had to “identify” many Tidal albums I added to my database, and many - maybe all — these edits were lost when I restored from a backup.



The re-identification process removes all user edits. I am leery about doing a lot of editing to streaming sources. Which brings up a related question:

@eric if I edit a Tidal album in my library, and Tidal replaces that album with an updated version, will Roon see the equivalence and move my edits over, or, will Roon treat the former album as gone and the updated version as a new album thus potentially losing any edits.

This is not great.

Tidal metadata in classical music is noisy, and if I can’t backup my edits looks like I should not waste my time identifying Tidal albums properly.

Can Roon address this?

I think there’s some confusion here.

Unless I’m misunderstanding, @Rugby was talking about what happens to edits done prior to the reidentification process. If you’ve edited an album, and then you subsequently reidentify it, the new metadata you’ve chosen replaces whatever metadata was present before, and user edits are overridden.

Edits to TIDAL content are no different than other edits, and they are stored in your database, and backed up. I just edited a TIDAL album, ran a backup, deleted the database, restored the back up, and all my TIDAL edits were in place just fine.

If you’re seeing something different @support can definitely help, but we need to figure out what’s different about your setup or workflow from what I just tested here.

Let us know and we’ll figure it out @maxim!