Ripped CDs missing from library

Roon Core Machine

NUC 10 running rock with a 1tb ssd installed for flacs

Connected Audio Devices

iFi Zenstream to Naim NAC N272

Number of Tracks in Library


Description of Issue

Albums missing from library. As an example, I have 5 ripped CDs in my library from Norah Jones, however, when I search my library, I can only see 2 of them, and 7 TIDAL albums. What would be causing my other 3 ripped CDs to not show? Makes me wonder how many other albums stored in internal storage are missing from my library.


have you tried a force rescan ?

1 Like

Just tried it now, no change.

Are they hidden under Versions for each album?

Not sure I follow?

Here as an example I’ve changed the primary version to Tidal. My ripped version is below.

So from album view the Tidal version shows

1 Like

Not sure how to do that on PC, just had a look and not seeing any “versions” buttons.


I don’t believe you will see a version button unless you actually have different versions of the same album in your library.
For example as per @ged_hickman1 you would need a local and/ or Tidal/ Qobuz version as well.

1 Like

Yeah, I guess I don’t have versions as these albums are missing from my library. They should be there though.

If you look at the actual directory they are in can you confirm they are there, also any special characters or bizarre long folder/file names?

1 Like

Yep, I did check that as well. Here is what I see in library, and what I see in storage. The first 2 albums are the ripped CDs, the rest are TIDAL.

and in core storage:


Could you check if they are perhaps unidentified and therefore you’re unable to find them? To check, go to My Albums / Focus / Identified (under INSPECTOR), and then tap/click on the blue “Identified” label. It will turn red and show all unidentified albums in your collection. I apologize if you’ve already tried this.

1 Like

I just gave this a shot. When I clicked on the blue “identified” label, nothing happened. No red, no change in albums.

OK this is odd, so I just manually scrolled through all albums till I found this one, then clicked on the TIDAL version. Then, I found this! … However if i search by artist, find album, click it, there is no versions. This must be some sort of glitch.

I set them all to primary that way, and there they are. Guess they were in there somewhere, just hiding!?

So for anyone else having this issue where albums don’t show up in search, weather by artist, version, or album, try manually scrolling albums till you find it, then versions may appear.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.