Ripped Library shows up on ethernet but not on wifi

Roon Core Machine

Intel NUC i3 Rock Server w/internal storage

Networking Gear & Setup Details

NUC networked with ethernet
Bluesound Node networked with ethernet
Use switch on Xfinity gateway

Connected Audio Devices

Remote laptop and iphone

Number of Tracks in Library

Description of Issue

My library that was ripped and stored on internal storage on the NUC is only available on ethernet on my laptop, and on my iphone when in proximity to my laptop when my laptop is plugged into ethernet (very weird!).

I really would like to get a tablet to operate Roon from but cant until this issue is solved. Anyone have any ideas. Very weird.

Quick thought is that your WiFi has a different network subset than your wired network does.

Does that mean its essentially a different network?

It might be.
Roon needs to have all devices on the same network subset, for example

I have seen examples where the WiFi network has a different subset to the wired network.
This will cause Roon to not see the devices on the wifi network because it’s subset differs from the Core machine.

But it seems very odd that it just would not see the library.

I wonder how I check that out. I hope I don’t have to get Xfinity (comcast) involved.

You could use something like “fing” to check all the ip address of devices in use in your house.

That should tell you right away if there are two different subnets going on

I am guessing that you would be able to check in Windows when connected to Wifi and again wired

Does the Xfinity gateway have an administration portal? It may be able to provide information on the IP addresses assigned.

Also, when you mention that the Xfinity gateway switch is used, is the Xfinity gateway also configured as your network router, or do you have another device acting as a router, especially for WiFi?

In task bar search type “cmd” - this should bring up a command prompt.
In the (black) box type: ipconfig
This will give you a list of what ip addresses are in use by each of your network cards.
Look for the ip4 address of each network
it should be something like 192.168.0.nnn (or 10.0.0.nnn)
if the first 3 sets of digits differ between the wireless and Ethernet network addresses then you have different networks active.

Thanks very much for your assistance. I give up on Roon. I really tried. It has been such a struggle to get it configured. Weeks of posting on the Forum, when one 15 minute call with a tech could have solved all of my issues is enough. Absolute arrogance on the part of Roon. I have cancelled the service.

Hi @William_Pringle,

Our apologies for the delay in getting to your report. We’re sorry to hear that you had some trouble getting your local library configured. We’d be happy to assist with this if you’re still interested. Just reply here in the thread and get back in touch. Thanks!

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.