Ripping problem using Melco D100

Rock running on Intel i7 NUC

I have a Melco D100 connected via the Melco supplied USB3 cable to by Roon ROCK.

Everything worked well at first: Roon could see the Melco and would let me rip and indicate when I refreshed the page the sate of play during the rip.

Now to get the Rock to see the Melco I have to reboot the Rock. Not just restart the software. Then I can rip a CD. Once complete I cannot eject the CD except by the front panel and if I insert a new CD Rock doesn’t recognise any change until I reboot Rock

I’ve rebooted everything more than once

Hardwired using ethernet to my network. iPad is wifi connected

UPNP Bridge to Naim NDS

Hello @Stephen_Harris,

The next time that you encounter this issue after ripping a CD, please respond in this thread with the current time (local) that the issue occurred and the last track that you had played in Roon.

We will then request a set of diagnostic logs from your Core.


Thanks, John

I rebooted at 11:58 local (so I could rip)

Played Chick Core/Gary Burton Señor Mouse then the rest of the album

Ripping started at 12:08 and finished at 12:26 with CD ejected

Then Close Melco CD drawing and Roon still indicates on previous Rip

Eject doesn’t do anything

Would have to cold reboot to be able to rip again

1 Like

Hi @Stephen_Harris,

Thanks for letting us know that timestamp!

I’ve activated diagnostics mode for your account and what this action would normally do is automatically upload a set of your ROCK logs, but unfortunately I am not seeing them come in.

Can I please ask that you use these instructions to manually send me a set from ROCK’s RoonServer/Logs folder?

Hi @Stephen_Harris — I just wanted to reach out and let you know that our team is still investigating your report of the Melco issue we’ll be in touch as soon as we have more information. Thanks for your patience while we investigate!

I’ve been looking into this, but it appears that your machine’s Linux kernel has frozen up its CD-ROM subsystem.

I’ve been trying to reproduce this reliably with a USB CDROM I have here, and I’ve only done it once so far. It happened when the drive was super hot (after ripping many CDs). After letting the CD-ROM cool down for a bit, it ripped fine again.

I’ll poke around more, but unfortunately, when hardware freezes up Linux like this, there isn’t much we can do other than look at the hardware closer.


Thanks, just to make sure I get it 100% you mean by the 'machine’s Linux kernel the Melco’s Linux Kernel?

I’ll try with an Apple DVD drive and a cheap blu-ray drive to see if I get the same problems. I didn’t when I first compared the sound quality of the rips, but neither did I have a problem with the Melco then as I wouldn’t have purchased it.

No, I mean the Linux in the Nucleus (or any Linux system).

A good test to conduct would also be to see if the rips came out identical byte for byte or if there were differences… and then to see if others with other D100 or Superdrives had matching or unmatching bytes.

If the bytes are diff, the sound may be different (not the flac, but the embedded PCM). If the bytes were not different, then claiming SQ differences would be comparable to comparing SQ from copies of the same files.


Now I’m super confused: how does a super hot CD-ROM drive affect the Linux Kernel in the (in my case) Intel NUC i7 running RoonOS 1 build 227.

As far as the sound quality stuff, I’ve found over the years it’s best to keep an open mind and if there is a sound quality difference, when logically there shouldn’t be, to continue to investigate. Given that the rips from a Rock are without metadata (if I remember correctly) it would be most useful if these were available in .wav format to remove another variable.

My CDROM stops working after every rip and the whole thing locks up, power control on rock UI stops working only a reboot brings it back and then one rip.back to square one. Used to work fine only started doing this after the last Rock update. Others have had similar issues. @danny is this being looked at at all. I have had to give up using Rock for this now.


Yep, same symptoms here. Only thing I can’t confirm is whether the problem started after the last update. Good to know I’m not alone.

I tried it again tonight and I successfully ripped 4 CDs using an Apple SuperDrive and 3 using my Melco. Odd considering it didn’t work - locking up after the first CD every time I tried it the last few times. I need to check the updates dates of the Rock to see if that might identify the possible reason for the change.

The problem now is a lack of confidence.

Something definitely changed in Rock at some point I have had this issue definitely since the last update it may have been one previous as I had not ripped anything for a while. Same drive rips fine using EAC on windows so it’s not the drive and it worked flawlessly before with it.


Maybe worth trying again after a reboot of everything as mine seems to be OK now.

Done that too many times. Rocks not been updated recently so I cant see how it can be fixed.

A new CD arrived today so I tried to rip it using the Melco D-100 connected to the Rock. The bloody problem is back again. A Rock reboot was required before the first CD would rip. After that nothing with out another reboot of Rock.

I tried using an Apple SuperDrive and everything worked as it should every time.

Unfortunately both Melco and Roon seem to - deny the problem/blame the other side/don’t care - Strike out as you choose to apportion blame.

@CrystalGipsy, @danny - Which USB drives were you using when you were able to reproduce this issue? Were you using the same drive as @Stephen_Harris?


Phil (posting as a representative of Melco Support)

Mines just a cheapy no name drive from Amazon nothing special. It worked fine until the update that broke the whole ripping thing happens.

@CrystalGipsy - thank you for the info Simon.

Phil (posting as a representative of Melco Support)

some no-name drive… nothing worthy of note.