Rock 1.8 causes crashes

Settings on Windows leads to a crash and Tidal scrolling with touch screen leads to a crash.
Windows 10 Pro 64 bit, Build 19042.789.
Settings and Tidal scrolling only over Android device.

Remove app from iPad and reinstall, problem solved :smiley:

1 Like

No crashes here at all on new iPadAir. Language in German…

No crash here. I live in the Netherlands and first updated on my iPad Roon Remote ( in the App Store: “Werk bij”, that means “update the app”. After that I got the message that the Core (RoonServer on my Mac Mini 2020, Intel i5 processor, 16 gig memory, SSD 512 Gb) needed update (from 1.7 to 1.8). I downloaded the new 1.8 version and it installed. On the iPad in between I got in the Remote app the message to be patient (because the RoonServer needed time (to load all the music and other things).
When this process was far enough the Remote opened up in her new clothes. In my eyes of a fervent beholder a beautiful, modern outfit, the secrets of this new look I have to discover next days.
I want to say thanks to the programmers of this wonderful metamorphosis out of my heart as melomane. Stay safe and be happy,

Reinstall does not solve the issue

1 Like

OMG, Ipad crashes constantly. Mainly when accessing playlists, artists also not showing in playlists. Tapping settings, tracks, history causes also crashes. Sorry guys, not the update I was hoping for! Hope there soon will be bug fixes.
My Core Roon Rock version 1.8 (build 753) - Roon optimized Core Kit Version 1.0 (build 227)

1 Like

Okay what the hell is this? Infinite crashes… hello?
I thought some real it guys were behind roon and its code but clearly i was wrong… these are novice mistakes and should not happend! Did a fresh install on my main server, not a single other roon remote in the network. Yet when it starts and i click on ‘settings’ POEF instant darkness…

1 Like

Same crash problem on 2 windows pc. In one it crashes by clicking “settings”, in the other it enters the settings menu but shows only the first page with a strange layout (overlapping texts and lack of various submenus) and incomplete.
It also crashes when clicking on the “history” menu

With a non-english system all lists show no linked artist-names only a disturbed blue piece of graphics.
Opening tracks let my iPad Pro crash every time. And since the last screen is persistend it also crashs on restart, so only option is to delete and reinstall the app. Not funny.

Reinstalled the app, Now the app won’t even open and crashes immediately… Come on guys… what is this!??

So I have to switch the complete OS language to English just for a little remote app to work properly? It would be a minor problem running the roon app in English, which I did anyway, and keep the OS language German, French, Spanish, or what so ever. Publishing an app worldwide which is restricted to english operating systems seems unacceptable. Come on Roon, didn’t you have any Beta users outside the US?

1 Like

Download at NUC 7i5 doesńt geht complete. Since version 1.8 is already on the iPad Nottingham works. Can somebody help?

Same here, iPad crashes when selecting « settings » Reinstalling app didn’t solve the issue.

Same here: My iPad mini 4 and my iPhone 11 crashes when i go to “settings” and then to “display” or “about”. I need a solution to solve this problem! Reinstallation does not help.

  1. Crashes systematically on composition view - Classical, when one selects a Period and presses Play. Happens on both Windows app and iPad (pro) OS.

  2. When trying to play from Composer view, with a focus on a given Period, I get the following error message: “Tracks played are unavailable”.

To sum up, Compositions view crashes, Composers view won’t even start playing. Album view is OK!!

What a magnificent update.

Roon remote on iOS crashing frequently. Just regular track selection. Not trying to get to settings. Quickly reloads and i carry on. Roon on ipad stable and core stable

Change language iPad to English, that seems to work. In the meanwhile we need to wait for a fix from Roon to put the iPad back again to the desired language

The same here… Roon Remote crashes on IOS(ipad 9 2020). When selecting tracks it crashes, and it crashes when app is restartet. I just see some “not available” in the side, and then it dies. The only way getting it up again is to uninstall/install the app. But when you select something the same ■■■■ happens.
Is there a way to downgrade to 1.7, because this upgrade has not been testet ok.

For the record. Roon 1.8 works fine on my old Samsung Galaxy S8 phone. But not there I wan’t to control Roon from.

Hi everyone,

We’ve recently released an update that we believe will help with settings-related crashes. Please give this update a try and let us know if things are back to normal.

Thanks for your patience as we’ve worked to get this fixed and if yo are still having issues after the update, please just let us know in a new thread!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.