ROCK - After update to build 256 production on my new NUC12WSHi7 HDMI is still not available

Roon Core Machine

NUC12WSHi7, 16GB RAM

Networking Gear & Setup Details

Ethernet

Connected Audio Devices

USB DAC (Denafrips ARESII) for two channel
HDMI Connection to DENON AVR (Multichannel Audio)

Number of Tracks in Library

35,000 tracks

Description of Issue

I have done the update Version 1.0 (build 256) production on my new NUC12WSHi7, however the HDMI is still not available under Audio, likewise USB-C and Thunderbolt. The only options are USB hi-res (when I connect DAC) and HDA Intel PCH.
Screen Shot 2022-12-22 at 14.57.30

Er, I believe the HDA Intel PCH device is the HDMI output…

My old ROCK/NUC system exposes 5 PCH channels, and the HDMI connector uses PCH HDMI 0, which I renamed for the connection to my Denon AVR.

Geoff,
Screen Shot 2022-12-22 at 18.48.50
Thanks, but unfortunately not, I have tried enabling HDA and testing all the HDMI and USB-C ports and there is no output and nothing relating to what a HDMI output should show in ROON. Your view is exactly what I used to see on my old NUC which this has replaced and what I expected here.

Long shot, but is HDMI enabled in the BIOS?

Yes I have enabled HD audio and all of the relevant outputs. Also I have checked and I have the latest bios from Intel.

Hi @John_B ,

I noticed your ROCK hasn’t been online since your post. Can you please turn it on/use it when you have a moment? I’ve enabled logging for it, thanks!

Hi Noris, sorry I have been on holiday. I have since tried installing Ubuntu (linux) as recommended by Intel and this worked, HDMI and are all other functionality is excellent. I am reluctant now to go back to ROCK unless this issue is fixed. Clearly there is no issue with the NUC must be setting in ROCK.

Sorry - but I concur with John_B. I was running the the latest build and the HDMI (ALSA) outputs were showing on my NUC based Rock, but I could not get any sound to manifest itself on my Arcam AVR20. I followed this link (Roon ROCK UEFI Intel NUC not showing HDMI output - #3 by Jinwei_Hao) hoping that it would fix the problem but now the HDMI outputs are not even listed in the Audio section; a retrograde outcome. I was hoping to play some my multichannel material (got PF Animals for Christmas), but no such luck. Is there a version that will work, even if it means downgrading to 1.8?