ROCK and PS Audio Nuwave DSD

Core Machine (Operating system/System info/Roon build number)

Roon ROCK / NUC 8 i5 / OS Version 1.0 (build 219) stable / Roon Version 1.7 (build 571) stable


Netgear Prosafe Plus / NUC connected wired Ethernet

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

PS Audio Nuwave DSD DAC connected USB

Description Of Issue

Trying to optimize connection between Roon and DAC. In setup for DAC, choosing Native gives a hiss, no music. Choosing DSD over PCM, which is how I think DAC handles DSD, give no sound at all. Choosing convert to PCM works, no DSD light when playing DSD files.

Any settings in DSP that would enhance playback of high quality local files, MQA or DSD streamed?


From their forums, it indicates that without the ASIO driver, DoP is how it is delivered.

First, try turning off ALL DSP and any volume Leveling or Volume Control. Make sure the Volume Control is set at fixed. Then try DSD over DoP.

I believe I got it. I had to set Sample Rate Conversion in DSP. Set to this:

and then was able to get this:

Screen Shot 2020-07-20 at 6.35.19 PM

The DSD light come on. I believe 128 (2X) is the max the DAC will do.What settings should I have for Sample Rate Conversion Filter and Sample Rate Modulator (terms that are unknown to me).

Thanks again,

Just wanted to add an update. The problem returned. I don’ t think I changed anything. So I reset the DAC and DSP in Roon to default settings and then everything worked fine.

I wanted to put this here in case anyone had a similar problem in the future.

Thanks again for the help.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.